MSIX Packaging SPSS 26 with KMS License

New Contributor

Hey Everyone, I rarely ever have to post on Forums to get answers but I am at my breaking point. I am trying to package SPSS26 which is licensed through a KMS Server into an MSIX. I have used the MSIX packager as well has PACE Packager. I can succesfully get this into an MSIX, and install it on another machine but no matter what I do the shortcut it creates will not run properly and does not run with the license. I get an Inet 0 error. Now the weird part is if I go to the WindowsApps folder where the MSIX installs and run the Stats.exe that the shortcut points to it launches perfectly. Now I cant expect users to have to go into 10 folders just to run SPSS so it obviously needs to show up in the start menu. I have tried packaging up powershell scripts to run the stats.exe I have changed the working directory (I think I did this correctly) I have tried a lot of things but I am just exhausted from this. The amount of times I have reverted back to my clean VM is crazy. Any help would be greatly appreciated because I am stuck and there is absolutely nothing online about this, also IBM has been zero help and will not help me with this. 

3 Replies

Hi @Coop2667580, if your shortcut takes in an argument, this is currently not supported: MSIX Packaging Tool Known Issues and Troubleshooting Tips - MSIX | Microsoft Docs


You can try to use a Package Support Framework to launch Windows Apps with Parameters - Package Support Framework - Launching Windows Apps with Parameters - MSIX | Microsoft Docs

@Dian Hartono I have not been able to find any arguments for the shortcuts. When I install SPSS on my VM to capture it I do the LICENSE switch and Server Switch but thats it from then on the stats.exe reads a SPSSLic.config file to read the server IP.

Hi Coop,

From your description that the stats.exe executable runs as expected when launches from explorer, it sounds like the program is attempting to find the configuration file on launch and the configuration file does exist in the data laid down by the msix. Since its working outside of the msix container, I'd guess this is related to the working directory or file system filtering.

You mentioned that you tried to redirect the current working directory. By any chance, did you try using process monitor as described: to see if the stats.exe program was failing to find a file when launched in the msix container?

If you can identify/share the specific error stats.exe is encountering, we may be able to suggest a more specific fix/workaround.