Tech Community Live: Windows edition
Jun 05 2024, 07:30 AM - 11:30 AM (PDT)
Microsoft Tech Community

MSIX Instal AppxManifest error 0x80070002

Copper Contributor

Hello there,

 

i have successfully packaging an Office2003 Word to an MSIX App.

When i go to install the MSIX, it runs to 99% and gives following error:

 

Fehler bei der App-Installation. Fehlermeldung: AppxManifest.xml(19,154602): Fehler 0x80070002: Das Paket "Office2003_1.0.0.0_x64__0axtw1mbg53sp" kann nicht registriert werden: Der Pfad "[{System}]" wurde nicht gefunden. (0x80070002)

 

I find out the position to path [{System}]

 

first:

<com:TypeLib Id="ac2de821-36a2-11cf-8053-00aa006009fa"> <com:Version VersionNumber="2.0" LocaleId="0" LibraryFlag="2" HelpDirectory="[{System}]"> <com:Win32Path Path="VFS\SystemX86\FM20.DLL" ResourceId="2" /> </com:Version> </com:TypeLib>

 

second:

<com:TypeLib Id="0d452ee1-e08f-101a-852e-02608c4d0bb4"> <com:Version VersionNumber="2.0" LocaleId="0" LibraryFlag="2" HelpDirectory="[{System}]"> <com:Win32Path Path="VFS\SystemX86\FM20.DLL" /> </com:Version> </com:TypeLib>

 

I try to resolve it with changing [{System}] to VFS\SystemX86\, but there give the next error.

 

What i can do to fix this issue?

I can not upload the Manifest file, the type is not allowed

 

 

best Karsten Seidel

 

17 Replies

Hi Michael,

 

Thank you for reporting this issue. We are tracking a bug with regards to path tokenization but it looks like you already tried using the detokenized path and you hit another error. What is the error that you are seeing?

 

It would be great if you can file a feedback item using the "report a problem" button from the MSIX Packaging Tool settings > feedback tab and attach the full logs and your installer.

 

You can find the logs at %localappdata%\packages\Microsoft.MsixPackagingTool_8wekyb3d8bbwe\LocalState\DiagOutputDir\

 

Thanks,

Peyman

 

Hi Peyman,

I tried many times more to build my Office 2003, but since a couple of days I cannot come as far as I got when I send you the last post.
Now, there is a error alrady after installing and prepearing the package. It's now something with the store: 0x80131500

 

I will send you one more through the feedback.

 

Michael

Hello Peyman,

 

i changed two times the [{System}] to VFS\SystemX86\, following error message by 99% at instal:

 

Fehler bei der App-Installation. Fehlermeldung: AppxManifest.xml(2560,12): Fehler 0x80080204: Das Paket "Word2003_1.0.0.0_x64__0axtw1mbg53sp" kann nicht registriert werden. Das TypeLib-Element erfordert mindestens ein untergeordnetes Win32Path-Element oder Win64Path-Element. (0x80080204)

 

Any Idea?

 

Best Karsten

After Edit the Manifest.xml we have the Log Issue:

 

[Warning] Unable to detect publisher name from provided certificate: System.Security.Cryptography.CryptographicException: Das angegebene Netzwerkkennwort ist falsch. bei System.Security.Cryptography.CryptographicException.ThrowCryptographicException(Int32 hr) bei System.Security.Cryptography.X509Certificates.X509Utils._LoadCertFromBlob(Byte[] rawData, IntPtr password, UInt32 dwFlags, Boolean persistKeySet, SafeCertContextHandle& pCertCtx) bei System.Security.Cryptography.X509Certificates.X509Certificate.LoadCertificateFromBlob(Byte[] rawData, Object password, X509KeyStorageFlags keyStorageFlags) bei MsixPackagingTool.ViewModel.Common.ViewModelBase.ValidateCertificatePassword(Byte[] certBytes, SecureString password) [19.11.18 18:10:38] [Warning] Unable to detect publisher name from provided certificate: System.Security.Cryptography.CryptographicException: Das angegebene Netzwerkkennwort ist falsch.

We have to put second time the certifictae in the field by editing the package manifest . Is there a problem by read the certificate in MSIX?
The certificate is up to date.

regards karsten

Hi Michael,

 

Looks like you are hitting an access violation error with com interface registrations, we are working on a fix and will let you know when it becomes available.

 

For now, try editing the manifest manually to workaround this by setting the version number to 1.5 on com:interface elements that don't have VersionNumber defined using package editor.

 

                <com:Interface Id="000208d4-0000-0000-c000-000000000046">

                                <com:TypeLib Id="00020802-0000-0000-c000-000000000046" VersionNumber="1.5" />

                </com:Interface>

                <com:Interface Id="0002441c-0000-0000-c000-000000000046">

                                <com:TypeLib Id="00020802-0000-0000-c000-000000000046" VersionNumber="1.5" />

                </com:Interface>

 

With regards to certificate, that is by design. Every time a package is modified in any way the signature goes away and you need to provide the certificate to sign the package again.

 

- Peyman

Hello,

 

i changed that info:

 

problem was at this place i found two registring items, is that correct? If only one item wich?

<com:TypeLib Id="00020802-0000-0000-c000-000000000046">

  <com:Version VersionNumber="1.5" LocaleId="7" LibraryFlag="0" HelpDirectory="VFS\ProgramFilesX86\Microsoft Office\OFFICE11\" />

  <com:Version VersionNumber="1.5" LocaleId="0" LibraryFlag="0" HelpDirectory="VFS\ProgramFilesX86\Microsoft Office\OFFICE11\">

  <com:Win32Path Path="VFS\ProgramFilesX86\Microsoft Office\OFFICE11\GRAPH.EXE" /> </com:Version> </com:TypeLib>

 

1. If i let both after change first to version 1.5, i have the following error message: 0x80131500

 

2. if i delete the first item, i can create the MSIX, but if i try to instal: 

 

 

Fehler bei der App-Installation. Fehlermeldung: AppxManifest.xml(2605,12): Fehler 0x80070003: Das Paket "Word2003MMV_1.0.0.0_x64__0axtw1mbg53sp" kann nicht registriert werden: Der Pfad "VFS\Users\KAS\AppData\Local\Temp\VBE" wurde nicht gefunden. (0x80070003)

 

Regards Karsten

The VBE issue in Manifest.xml

 

<com:TypeLib Id="0ed4565c-cf2a-41b8-a6f0-0bce0b5b90d5"> <com:Version VersionNumber="2.0" LocaleId="0" LibraryFlag="6" HelpDirectory="VFS\Users\KAS\AppData\Local\Temp\VBE"> <com:Win32Path Path="VFS\Users\KAS\AppData\Local\Temp\VBE\MSForms.exd" /> </com:Version> </com:TypeLib>

Why is that depend at User?

Hi,

 

Why is that depend at User?

 

regards Karsten

The person doing the packaging needs to ensure the package is properly signed, not the end user.  For information about why signing files is important, see Introduction to Code Signing.

 

Looking at the new error it looks like these paths do not exist in your package:

 <com:TypeLib Id="0ed4565c-cf2a-41b8-a6f0-0bce0b5b90d5"> <com:Version VersionNumber="2.0" LocaleId="0" LibraryFlag="6" HelpDirectory="VFS\Users\KAS\AppData\Local\Temp\VBE"> <com:Win32Path Path="VFS\Users\KAS\AppData\Local\Temp\VBE\MSForms.exd" /> </com:Version> </com:TypeLib>

 

We need your full logs and your installer to investigate this further, looks like you filed a few feedback items about this, but I could not find the logs or installer attached to any of them. Let me know if you already attached them and I will follow up on why I can't see them on our end.

 

Can you please manually attach them to this feedback item https://aka.ms/AA3afhr?

You can find the logs at   %localappdata%\packages\Microsoft.MsixPackagingTool_8wekyb3d8bbwe\LocalState\DiagOutputDir\

 

Thanks,

Peyman 

Hi Peyman,

 

i have publish the links to our package and logs in hub https://aka.ms/AA3afhr

please download there an let us know updated. 

 

regards karsten

Any chance to give us a hand for christmas :)

We are still investigating this issue. Thank you for your patience.

Hi, I updated to Windows 1903, in the hope there might be some better coexistence of MSIX with my Word 2003, which is very customizes for our purpose, but no better results. I also tried Word 2010, I could not get it running either. What shall I do? Thank you Michael

@Peyman Zanjani 

 

Hello with the actual MSIX Packaging Tool, we get error message again. What we can do with this extension? What we can edit in Package, that we can install it?

 

Fehler bei der App-Installation. Fehlermeldung: AppxManifest.xml(2663,12): Fehler 0x80070002: Das Paket "MSIXWord2003_1.0.1.0_x64__0axtw1mbg53sp" kann nicht registriert werden: Der Pfad "VFS\SystemX64" wurde nicht gefunden. (0x80070002)

 

<com:Interface Id="04598fc1-866c-11cf-ab7c-00aa00c08fcf" UseUniversalMarshaler="true"> <com:TypeLib Id="ac2de821-36a2-11cf-8053-00aa006009fa" VersionNumber="2.0" /> </com:Interface>

 

<com:TypeLib Id="ac2de821-36a2-11cf-8053-00aa006009fa"> <com:Version VersionNumber="2.0" LocaleId="0" LibraryFlag="2" HelpDirectory="VFS\SystemX64"> <com:Win32Path Path="VFS\SystemX86\FM20.DLL" ResourceId="2" /> </com:Version> </com:TypeLib>

 

<com:TypeLib Id="0d452ee1-e08f-101a-852e-02608c4d0bb4"> <com:Version VersionNumber="2.0" LocaleId="0" LibraryFlag="2" HelpDirectory="VFS\SystemX64"> <com:Win32Path Path="VFS\SystemX86\FM20.DLL" /> </com:Version> </com:TypeLib>

 

regards karsten

 

Hi Michael,

 

I apologize for not noticing your thread sooner.

 

If my German translation is correct, the error you are seeing is related to the HelpDirectory attribute on your com interface.

Win32 COM entries are less stringent on their requirements and allow registration of help directories that do not exist. MSIX however requires that the path be valid.

 

This HelpDirectory attribute is probably not meaningful for your purposes, so I would just remove the entire attribute.

 

Let me know if that unblocks you! If not, please let me know how else I can be of assistance.

 

Thanks!

James