MSIX Deployment with manual appinstaller file

New Contributor



Please help with our MSIX deployment,,

I would like to distribute the MSIX package via our website with the auto-update feature. I have a signed MSIX package already in a blob level azure container. 

I am getting an error when I try to install the app via an appinstaller file I created. 
Some ways that I tried.

1. The installer file works with  a local uri like `C:\Users\name\Downloads\myApp.appinstaller`


I am using Windows 10 Pro, 2004. OS build 19041.610.

Please check the below code for our appinstaller file. 


<?xml version="1.0" encoding="utf-8"?>
    Uri="" >

    <MainPackage Name="myApp" Publisher="..." Version="1.2.20307.1" ProcessorArchitecture="x64" Uri="" />
		<OnLaunch HoursBetweenUpdateChecks="0" ShowPrompt="true" UpdateBlocksActivation="true"/>
3 Replies
best response confirmed by dicong (New Contributor)

Hi @dicong 


Does a restart of your computer fix the issue? To help us investigate the issue, can you please file a Feedback Hub item (Windows key + F) in this category:



Thank you!




Hi @dicong 


Does the URL for the package or the appinstaller contain any spaces in it?


During some internal tests we did, we had similar crashes (the package worked correctly when manually installed but failed when triggered from the appinstaller).


It turned out that the white spaces from the URL were the problem, even if they seemed to be correctly encoded ("%20"). Once we removed the space from the URl the installation when through without any problems.




Hi Tanaka, 


Thanks for your `restart` advice. And that magic `restart` did solve my problem...:facepalm:  The error disappears and I can install now.