MSIX: Dependent package loading issue from Win10 1903

%3CLINGO-SUB%20id%3D%22lingo-sub-745538%22%20slang%3D%22en-US%22%3EMSIX%3A%20Dependent%20package%20loading%20issue%20from%20Win10%201903%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-745538%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3EExperienced%20different%20dependent%20package%20file%20loading%20behavior%20from%20Win10%201903%20compare%20to%20previous%20build.%20For%20example%2C%20when%20loading%20resource%20DLL%20from%20dependent%20package%26nbsp%3B%20it%20use%20to%20load%20as%20below%20example%20(FwUIRes.dll)%20-%20where%20%232%20is%20MainPackageDependency%20of%20%22Inventor2020%22%3C%2FP%3E%3CDIV%3E%26nbsp%3B%3C%2FDIV%3E%3COL%3E%3CLI%3EC%3A%5CProgram%20Files%5CWindowsApps%5C%3CSTRONG%3EInventor2020%3C%2FSTRONG%3E_24.0.16800.0_x64__nqqhc41zzs088%5CVFS%5CProgramFilesX64%5CAutodesk%5CInventor%202020%5CBin%5Cen-US%5CFwUIRes.dll%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%20%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%3CSTRONG%3EREPARSE%3C%2FSTRONG%3E%3C%2FLI%3E%3CLI%3EC%3A%5CProgram%20Files%5CWindowsApps%5C%3CSTRONG%3EInventor2020ENU%3C%2FSTRONG%3E_24.0.16800.0_x64__nqqhc41zzs088%5CVFS%5CProgramFilesX64%5CAutodesk%5CInventor%202020%5CBin%5Cen-US%5CFwUIRes.dll%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%20%3CSTRONG%3ESUCCESS%3C%2FSTRONG%3E%3CBR%20%2F%3E%3C%2FLI%3E%3C%2FOL%3E%3CP%3EHowever%2C%20from%20%3CSTRONG%3E1903%3C%2FSTRONG%3Ebuild%2C%20it%20start%20looking%20into%26nbsp%3B%20additional%20folder%26nbsp%3B%3CSTRONG%3E%5CWindowsApps%5C%7BPackageFamilyName%7D%5CVFS%5CProgramFilesX64%26nbsp%3B%3C%2FSTRONG%3E%26nbsp%3Bas%20below%20example%2C%26nbsp%3B%3C%2FP%3E%3COL%3E%3CLI%3EC%3A%5CProgram%20Files%5CWindowsApps%5CInventor2020_24.0.16800.0_x64__nqqhc41zzs088%5CVFS%5CProgramFilesX64%3CSTRONG%3E%5CWindowsApps%5CInventor2020_24.0.16800.0_x64__nqqhc41zzs088%5CVFS%5CProgramFilesX64%3C%2FSTRONG%3E%5CAutodesk%5CInventor%202020%5CBin%5Cen-US%5CFwUIRes.dll%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%20%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3B%26nbsp%3BPATH%20NOT%20FOUND%3C%2FLI%3E%3CLI%3EC%3A%5CProgram%20Files%5CWindowsApps%5C%3CEM%3EInventor2020ENU%3C%2FEM%3E_24.0.16800.0_x64__nqqhc41zzs088%5CVFS%5CProgramFilesX64%3CSTRONG%3E%5CWindowsApps%5CInventor2020_24.0.16800.0_x64__nqqhc41zzs088%5CVFS%5CProgramFilesX64%3C%2FSTRONG%3E%5CAutodesk%5CInventor%202020%5CBin%5Cen-US%5CFwUIRes.dll%26nbsp%3B%26nbsp%3B%20PATH%20NOT%20FOUND%3C%2FLI%3E%3C%2FOL%3E%3CP%3EIs%20this%20known%20issue%20from%20build%201903%3F%3CBR%20%2F%3EThanks%2C%3CBR%20%2F%3EDooyoul.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-745538%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3Edooyoul.chung%40autodesk.com%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-745939%22%20slang%3D%22en-US%22%3ERe%3A%20MSIX%3A%20Dependent%20package%20loading%20issue%20from%20Win10%201903%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-745939%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F144986%22%20target%3D%22_blank%22%3E%40Dooyoul%20Chung%3C%2FA%3E%26nbsp%3BThanks%20for%20reporting%20this.%26nbsp%3B%20We%20are%20looking%20into%20the%20issue.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EJohn%20Vintzel%26nbsp%3B%3C%2FP%3E%0A%3CP%3EPM%20Lead%2C%20MSIX%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Contributor

Hi,

Experienced different dependent package file loading behavior from Win10 1903 compare to previous build. For example, when loading resource DLL from dependent package  it use to load as below example (FwUIRes.dll) - where #2 is MainPackageDependency of "Inventor2020"

 
  1. C:\Program Files\WindowsApps\Inventor2020_24.0.16800.0_x64__nqqhc41zzs088\VFS\ProgramFilesX64\Autodesk\Inventor 2020\Bin\en-US\FwUIRes.dll                 REPARSE
  2. C:\Program Files\WindowsApps\Inventor2020ENU_24.0.16800.0_x64__nqqhc41zzs088\VFS\ProgramFilesX64\Autodesk\Inventor 2020\Bin\en-US\FwUIRes.dll         SUCCESS

However, from 1903 build, it start looking into  additional folder \WindowsApps\{PackageFamilyName}\VFS\ProgramFilesX64  as below example, 

  1. C:\Program Files\WindowsApps\Inventor2020_24.0.16800.0_x64__nqqhc41zzs088\VFS\ProgramFilesX64\WindowsApps\Inventor2020_24.0.16800.0_x64__nqqhc41zzs088\VFS\ProgramFilesX64\Autodesk\Inventor 2020\Bin\en-US\FwUIRes.dll           PATH NOT FOUND
  2. C:\Program Files\WindowsApps\Inventor2020ENU_24.0.16800.0_x64__nqqhc41zzs088\VFS\ProgramFilesX64\WindowsApps\Inventor2020_24.0.16800.0_x64__nqqhc41zzs088\VFS\ProgramFilesX64\Autodesk\Inventor 2020\Bin\en-US\FwUIRes.dll   PATH NOT FOUND

Is this known issue from build 1903?
Thanks,
Dooyoul.

1 Reply

@Dooyoul Chung Thanks for reporting this.  We are looking into the issue.

 

John Vintzel 

PM Lead, MSIX