Tech Community Live: Windows edition
Jun 05 2024, 07:30 AM - 11:30 AM (PDT)
Microsoft Tech Community

Missing Language Support in Store App Package

Copper Contributor

Hello all,

 

we have recently added two additional locales to our UWP app UBIK and uploaded it to the Microsoft Store. Here's the list of all supported languages displayed in the store app page. The two new ones are marked in red.

  • Chinese (Simplified)
  • Czech
  • English
  • German
  • Polish
  • Portuguese
  • Portuguese (Brazil)
  • Spanish
  • Spanish (Spain)

The problem is the app is not displayed in those two languages when they are set as the top options in the "Preferred languages" setting, unlike with those that were already supported before.

 

The two things that are really strange are:

  • The original app package (msixbundle) doesn't have this problem and is displayed in the right languages when it is installed through sideloading. But once uploaded (msixupload) to the Microsoft Store and re-downloaded again, it starts to show the problem described above.
  • In the app package details, the language list is "cs, de, de-de, en, es, es-es, pl, pt, pt-br, zh-cn, zh-hans". And the package list does include "neutral v4.3.24.0 UBIK.WinX_4.3.24.0_language-cs.msix" and "neutral v4.3.24.0 UBIK.WinX_4.3.24.0_language-pl.msix". I can also confirm this in the unzipped package. So it seems like the two languages are included in the package.

 

Do you know what could be the cause of the problem?

 

BR, Liang

0 Replies