Installation of MSIX Modification Package

Copper Contributor



During my testing, I faced an issue with per-machine installation of modification package. Wanted to clarify if this is a known thing or am I missing something? And what could be the reason behind this.


I installed the base application (Notepad++ in my case) per-machine using Add-AppProvisionedPackage -online cmdline. When I tried to install my modification package consisting of a plugin to Npp using the same command, it throws "Unspecified Error".
Event viewer logs created under AppXDeployment-Server node are not of much help either.

However, if I install the modification package manually by double clicking the MSIX file or using the Add-AppPackage cmdline on per-user basis, the plugin gets installed and is visible within the base application.

Both base application and plugin installs under VFS.


Thanks in advance for your suggestions and inputs.

3 Replies


How about calling  Add-AppxPackage on your package after provisioning it? Does the installation of the modification package still fail after this extra step?

@marcinotorowski , Thanks for your inputs.

Irrespective of the fact how base application was installed (using Add-AppProvisionedPackage or Add-AppPackage), modification package is getting installed successfully only through Add-AppPackage cmdlet.


We had the same issue and found a solution using the (currently not documented) OptionalPackagePath parameter for the modification package combined with the PackagePath for the main package. 


For example

Add-AppProvisionedPackage -Online -OptionalPackagePath \\share\modificationpackage.msix -PackagePath \\share\mainpackage.msix -SkipLicense