Few Doubts

Occasional Contributor
Hi, I am a beginner to MSIX, I have few issues working with MSIX. Please let me know how to over come below issues. 1. MSIX Packaging tool or any MSIX package created using MSIXPackaging after installing to machine, it is not showing in Add Remove Program? Any setting to be enabled to show MSIX package on ARP? 2. How to use 'Create Package on existing virtial machine'? I have an another VM with 'PSRemoting' enabled. But that machine is not discovering from the MSIX Packaging machine. 3. How to use MSIX Command Line? Whenever I use, I am getting 'Access Denied'. So I copied all MSIX related files to another location and tried. But this time when I use command line UI getting opened. Regards, Bineesh
4 Replies
best response confirmed by John Vintzel (Microsoft)

Hi Bineesh, 


  1.  MSIX applications that you have installed will show up in your Settings > Apps > Apps & features. 
  2.  Is that VM a local or remote VM? We currently only have support in the MSIX Packaging Tool for local VMs
  3. Here is the link to our documentation on how to convert a package using the command line. 




Program Manager, MSIX

Thank you Sharla for your help.


  1. I am able to see Apps in the location you mentioned
  2. I am using VMs from Clound, that could be the reason unable to select vm
  3. I have followed this document, still the command is not working. It it showing access denied if I run from the MSIX packaging tool install location (PFA image). If I copy those files to any other location and try running the command it opens MSIX packaging tool in UI mode. Please let me know if any other setting to be applied run the tool in command line

The error is most likely since you are in the WindowsApps folder.  That has ACLs that might be causing you issues.  We have the command in the Path so you do not need to seek out the specific folder and can just run it from the default location of your command prompt.



John, In the documentation I do not see any command line for conversion of App-V to MSIX, do we have this capability in Commandline option?