Error makepri.exe failed, exit code = -2146958844

Copper Contributor

When I convert MSI to MSIX, I received error on makepri.exe. The same error occur both command line and UI. Anyone experience this error? Any suggestion to solve this error?

11 Replies

Is this just happening as part of conversion or in package editor?  The error The App package's manifest is invalid.


Can you file a feedback hub item, attach the MSI, command line template, and send me the URI to the item.  We can look at it.



I missed you attached the log. We will take a look at that as well.




This entry in the log file points to the (automatically generated) manifest invalid entry.  There's something about this COM object that we don't handle correctly.  


[10/22/2018 8:06:18 AM] [Error]  e r r o r   C 0 0 C E 1 A 1 :   A p p   m a n i f e s t   v a l i d a t i o n   e r r o r :   T h e   a p p   m a n i f e s t   m u s t   b e   v a l i d   a s   p e r   s c h e m a :   L i n e   1 9 ,   C o l u m n   3 8 6 6 ,   R e a s o n :   ' 0 4 3 f 9 8 0 a - e d a 3 - 4 0 b 2 - 9 2 9 4 - 2 b a c 3 f 1 9 5 b 4 8 '   i s   a   d u p l i c a t e   k e y   f o r   t h e   u n i q u e   I d e n t i t y   C o n s t r a i n t   ' { h t t p : / / s c h e m a s . m i c r o s o f t . c o m / a p p x / m a n i f e s t / f o u n d a t i o n / w i n d o w s 1 0 } C l a s s _ I d ' .


Could you send us the manifest file, which should be here (from your log file):




Is there anything unique about the COM object with that GUID in the application you're packaging?



Thank you Cory for your review. I've attached manifest file for your review. 
I will also take a look that ID associated COM class.


Hi Cory,

I've reviewed associated COM component again but nothing unusual.  I've also noticed that the same error happen other MSI too.  Is there any chance you have looking into Schema definition ?
Any update is appreciated.


Hi Dooyoul,


I am looking into the issue you reported.  

No updates yet, but I will let you know as soon as we have a resolution for you.


In the meantime, you may have some luck if you manually limit the number of entry points added on the 'First Launch tasks' wizard page to one.




Hi James,


Thanks for the update. I had the same idea and tried out with only one entry point on the 'First Launch tasks' from wizard page but received the same error.




Hi Dooyoul,


Apologies for the slow response.  We identified the issue you ran into and will be fixing it as soon as time allows.


Given that you ran into additional problems even when you tried limiting the entry points to one, I'm concerned your particular application might be running into additional problems. 

If it would be possible to share the installer in question with us, we can be more certain we have identified all the issues at play. From the manifest it looks like you were testing with Autodesk Inventor?  If I try the version available from the Autodesk website would that give me a good repro of the issue?




Good to know you can attach files to feedback items. I didn't know that?


I have a MSI package along with MST and MSP, the tool in capturing everything but I am facing the same issue. 

makepri.exe failed, exit code = -2146958844


Log file shows this : 

About to start process
[1/7/2019 6:49:20 PM] [Debug]     - File name:                 makepri.exe
[1/7/2019 6:49:20 PM] [Debug]     - Arguments:                 new /cf "C:\Users\Win10\AppData\Local\Packages\Microsoft.MsixPackagingTool_8wekyb3d8bbwe\LocalState\DiagOutputDir\Logs_2\PriConfig.xml" /pr "C:\Users\Win10\AppData\Local\Packages\Microsoft.MsixPackagingTool_8wekyb3d8bbwe\LocalState\DiagOutputDir\Logs_2\VisualAssetsRoot" /mn "C:\Users\Win10\AppData\Local\Packages\Microsoft.MsixPackagingTool_8wekyb3d8bbwe\LocalState\DiagOutputDir\Logs_2\gxcsy0yd.fj5.Manifest" /o /of "C:\Users\Win10\AppData\Local\Packages\Microsoft.MsixPackagingTool_8wekyb3d8bbwe\LocalState\DiagOutputDir\Logs_2\resources.pri" /mf Appx
[1/7/2019 6:49:21 PM] [Info] M i c r o s o f t   ( R )   M a k e P R I   T o o l


Any update and resolution?

Hi Anamay,


Makepri errors tend to be a catch all for something went awry in our conversion logic.  If you can share your full logs or file feedback, I may be able to give you more specifics or workarounds for your problem.


In the meantime, consider giving the latest update of the tool a try. It has addressed many issues that folks were experiencing as Makepri failures. I know there are still some problems especially around COM translations and behavior though.  We are working to address those in future updates to the tool.


If you still hit a problem using the January update, please do send me your logs!