Tech Community Live: Windows edition
Jun 05 2024, 07:30 AM - 11:30 AM (PDT)
Microsoft Tech Community
SOLVED

Error 0xC00CEE23 when Minor Version >= 10

Copper Contributor

I found a strange issue the other day. When the Minor version number is greater than or equal to 10, Windows 10 2004 machines will not be able to install a package from a URI. UNC paths work.

 

Here is the full error message:

 

"App installation failed with error message: error 0xC00CEE23: The XML in the .appinstaller file is not valid: Line 14, Column 11, Reason: '>' expected. (0xc00cee23)"

 

Everything works fine when the version is 9 or less. I just created a 3.10.X.X release for my WPF application & that's when I found the bug. For the time being I just kept my Minor version 9 in the package, & increased the Build number. Not sure what's going to happen when build number reaches 10.

 

When I test the installer on my local network using a UNC path, everything works fine. It's only when I changed to my HTTPS URL that I receive this error.

 

There were similar mentions of the error in the comments for this topic. 

https://techcommunity.microsoft.com/t5/msix-deployment/windows-10-2004-msix-not-updating-please-chec...

10 Replies

@bvenhaus I have the same problem here !

Thanks for reporting this @bvenhaus. We're looking into the issue and working to get it resolved.

 

Cheers,

Tanaka

Same issue here too.

@bvenhaus 

@bvenhaus @Tanaka_Jimha we have the same issue. It's really sad that no response within half of a year.

Same issue is with build number, went from 0.1.9 to 0.1.10 and received the same error.
Any news. It's July 2021! we have the same problem.

I just encountered the same problem and the only reasonable solution was padding version numbers, e.g. first version 1.1.1000.0, second version 1.1.1001.0. I haven't test it deeply but it worked with a few examples. It would probably be a good idea versioning as 1000.1000.1000.0 and always keep the same version-string size to avoid the catching issue.

@plex4j Same issue.
I actually wanted to revise my version numbering system prior to launch.
Sadly not to be? Cant set a version number to year.

Would be nice to get a resolution?

Just experienced this bug also. Microsoft asleep at the wheel.
best response confirmed by Sushant_Bansal (Microsoft)
Solution

Hi all,

 

I am from the MSIX team. This issue has been resolved.

It was an issue in appinstaller that was fixed with an update.

 

Please let me know in case you still face this issue after updating your Windows.

 

Thanks for the feedback!

 

Regards,

Sushant Bansal

PM, MSIX Team

1 best response

Accepted Solutions
best response confirmed by Sushant_Bansal (Microsoft)
Solution

Hi all,

 

I am from the MSIX team. This issue has been resolved.

It was an issue in appinstaller that was fixed with an update.

 

Please let me know in case you still face this issue after updating your Windows.

 

Thanks for the feedback!

 

Regards,

Sushant Bansal

PM, MSIX Team

View solution in original post