Entry point not found while creating msix package using MSIX Packaging tool

New Contributor


I am a beginner and I am trying to use MSIX Packagin tool. So I started with creating a msix package for 7zip. I downloaded the exe from, and specified the location in select installer. I am using self-signed certificate. When the installation completes, it moves to First Launch tasks step and there it does not show any entry point for the specified installer. When I try to browser dialog displays message - we did not detect any new entry points. Run your installer and try again. If I continue to creating package, generated MSIX package is only 19KB in size.


Why entry point is not showing?


Thanks in advance,

5 Replies

@krathore you can specify the entry point in the appxmanifest.xml file and invoke the tool like

makeappx.exe pack /v /o /f /m Appxmanifest.xml /p ./abc.msix

@Sigmarssonthanks for your reply. To use makeappx.exe tool I would need to create AppxManifest.xml file. So I tried following this link to create xml file. So before packaging I tried to test the application. I ran the add-appxpackage command but its giving following error:


PS C:\WINDOWS\system32> Add-AppxPackage -Register E:\AppxManifest.xml
Add-AppxPackage : Deployment failed with HRESULT: 0x80080204, The Appx package's manifest is invalid.
error 0xC00CE169: App manifest validation error: The app manifest must be valid as per schema: Line 22, Column 48,
Reason: '' violates minLength constraint of '1'.
The attribute 'Description' with value '' failed to parse.
NOTE: For additional information, look for [ActivityId] 7ad871fd-5a89-0004-4e50-d97a895ad601 in the Event Log or use
the command line Get-AppPackageLog -ActivityID 7ad871fd-5a89-0004-4e50-d97a895ad601
At line:1 char:1
+ Add-AppxPackage -Register E:\AppxManifest.xml
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : NotSpecified: (E:\AppxManifest.xml:String) [Add-AppxPackage], Exception
+ FullyQualifiedErrorId : DeploymentError,Microsoft.Windows.Appx.PackageManager.Commands.AddAppxPackageCommand

Sorry, I posted the wrong error message and not able to edit the reply. Correct error message is :


PS C:\WINDOWS\system32> Add-AppxPackage -Register E:\AppxManifest.xml Add-AppxPackage : Deployment failed with HRESULT: 0x80073CF9, Install failed. Please contact your software vendor. Deployment Register operation with target volume C: on Package 7zip_1.0.0.0_x64__gh4z7t6838ap6 from: (AppxManifest.xml) failed with error 0x80070057. See for help diagnosing app deployment issues. NOTE: For additional information, look for [ActivityId] 7ad871fd-5a89-0002-1141-d97a895ad601 in the Event Log or use the command line Get-AppPackageLog -ActivityID 7ad871fd-5a89-0002-1141-d97a895ad601 At line:1 char:1 + Add-AppxPackage -Register E:\AppxManifest.xml + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ + CategoryInfo : WriteError: (E:\AppxManifest.xml:String) [Add-AppxPackage], IOException + FullyQualifiedErrorId : DeploymentError,Microsoft.Windows.Appx.PackageManager.Commands.AddAppxPackageCommand

@krathore  As to the error code, I suspect that you have a remnant of a previous attempt and cannot add what the system believes to be the same package twice. Try running get-appxpackage -AllUsers as well as get-appxProvisionedPackage (with and without the -online option).


Generically, capturing 7Zip  in the Microsoft MSIX Packaging tool should find the entrypoint just fine. I package that app using the FileRedirectionFixup to solve some file write issues, and find that OS 2004 is needed to solve a registry issue.  There is still a small loss of functionality with shell extensions, but the app mostly works.

best response confirmed by Sharla_Akers (Microsoft)

Hi @krathore 

If the tool is not showing the entry point that means it did not detect the executable file being created while it monitored the installer. This can happen if the application you are packaging (7zip) is already installed in the machine before you create the package with the MSIX Packaging Tool. We recommend you package your applications in a clean machine or VM to prevent that.


If the application is already installed before packaging, the package you create will probably be almost empty. You could confirm this by opening it with the Package editor available in the tool and exploring the files in it.


Although I don't think any of these is the case here, the entry point may also not be found if the installer fails (so the executable file is not created), if there is no shortcut created to it (it would show up in the browse dialog to add it), or if you are installing to a different disk drive than the specified install location.