Build 1105 issues


Initially, we tried to use the October release and experienced the "package editor" issue.  We found that we didn't even have to go into the package editor to experience the issue when saving off the package.


We upgraded to the November release (1.0.2021.1105) and while that problem went away, we ran into another blocking bug.  The first application we tried (UltraEdit), failed on MakeAppx build.  The log file indicated that the issue was a duplicate COM GUID in the AppXManifest file.  There indeed were two Application Extensions in an Application that were both COM Server / SurrogateServer using the same com clsid guid.  Manually editing these to merge the entries allowed us to have the manifest pass validation on the way back into the editor, but building the package still failed (with yet a different symptom). 


I will be unable at this time to reproduce in order to submit via feeedback hub, as we are running a training class and I have rebuilt a bunch of VMs to go back to the 709 build.  But clearly there are issues with 1105 that need addressing.




3 Replies
Happy to look into this further if you can submit an item after the class to help us better understand the issue.
I was also able to find an error.
"Process MakeAppx.exe failed with exit code 1" with version "1.2021.1105.0".
Unfortunately I don't have the source for the 709 build anymore.
best response confirmed by TIMOTHY MANGAN (MVP)

@John Vintzel  I am happy to report that the 2022.110 build resolves this issue!