Anyone else getting issues with Fonts shared across several packages?

Brass Contributor

Font file names have been changed but are shared by several MSIX packages.


<uap4:Extension Category="windows.sharedFonts">
<uap4:Font File="VFS\Fonts\Font1.ttf"/>
<uap4:Font File="VFS\Fonts\Font2.ttf"/>
<uap4:Font File="VFS\Fonts\Font3.ttf"/>
<uap4:Font File="VFS\Fonts\Font4.ttf"/>


On occasions after a few installs/uninstall we get an error 0x800700005


App installation failed with error message AppX Deployment operation failed with error 0x0 from API Logging because access was denied for file (Full path to one of the Font files) SID:S-1-5-18 (0x800700005)


The fix in all cases is to reboot the machine and then the installation will complete without errors.


Given I can't move the Fonts into a Resource package (Can't have any entries in the AppxManifest.XML) is there anything else I can do to work around this other than making a separate standalone MSIX just for the Fonts?  As even that doesn't really resolve the issue as the User could then easily attempt to run the main products with having installed the Font MSIX package.


Anyone else getting issues with Fonts shared across several packages?

3 Replies
I don't think I've tried what you are doing. Have you tried making the font package a "framework" package and then listing it as a package dependency? I have no idea if this would work (because we aren't sure what can be in a framework package and how they actually work), but it might.
I didn't think that Framework packages could have an Applications element in them, i.e. they are just files with no extra XML elements to extend the package functionality. I'll give it a try though and see if it works.
Oh, right. You can't register the font in the manifest.