Windows 10 and 11 package icons resources

%3CLINGO-SUB%20id%3D%22lingo-sub-3006275%22%20slang%3D%22fr-FR%22%3EWindows%2010%20and%2011%20package%20icons%20resources%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-3006275%22%20slang%3D%22fr-FR%22%3E%3CP%3EHello%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20a%20problem%20with%20my%20Packaged%20Win32%20application%20icons%20resources%20on%20Windows%2010%20and%2011.%3C%2FP%3E%3CP%3EThe%20icons%20look%20great%20in%20the%20Start%20menu%20and%20Taskbar%20but%20when%20I%20add%20a%20desktop%20short%20to%20my%20app%2C%20the%20icon%20is%20displayed%20with%20a%20blue%20background%20color.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHere%20is%20my%20scenario%20%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E1.%20I%20generate%20the%20resources.pri%20file%20using%20native%20Visual%20Studio%20tool%20(see%20attached%20capture)%3C%2FP%3E%3CP%3E2.%20Then%20I%20build%20an%20APPX%20package%20to%20publish%20it%20on%20the%20Store%20using%20the%20command%20line%20%3A%3C%2FP%3E%3CP%3E%22C%3A%5CProgram%20Files%20(x86)%5CWindows%20Kits%5C10%5Cbin%5C10.0.18362.0%5Cx86%5Cmakeappx.exe%22%20pack%20%2Fd%20%22E%3A%5Bcompiled%20app%20folder%5D%22%20%2Fp%20e%3A%5Cpackage.appx%3C%2FP%3E%3CP%3E3.%20I%20can%20sideload%20my%20app%20using%20the%20PS1%20command%3C%2FP%3E%3CP%3E%3CSPAN%3EAdd-AppxPackage%20-Register%20%5Bapp%20folder%20package%5D%5CAppxManifest.xml%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhen%20deployed%20(sideload%20or%20by%20Store)%20the%20icons%20look%20nice%20in%20the%20Start%20menu%20and%20taskbar%20(see%20captures).%3C%2FP%3E%3CP%3EWhen%20I%20drag%20the%20Icon%20from%20the%20Start%20menu%20to%20the%20desktop%20to%20create%20a%20shortcut%2C%20then%20the%20icon%20is%20not%20correct.%3C%2FP%3E%3CP%3ENote%3A%20I%20generated%20all%20the%20visual%20assets%20using%20VS%20for%20all%20sizes%2Fscales%2C%20and%20light%2Fdark%20variants%2C%20and%20unplated.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20appmanifest%20looks%20like%20that%20%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3E%3CVISUALELEMENTS%3E%3C%2FVISUALELEMENTS%3E%3C%2FSPAN%3E%3CBR%20%2F%3E%3CSPAN%3EDisplayName%3D%22PageFabric%22%3C%2FSPAN%3E%3CBR%20%2F%3E%3CSPAN%3EDescription%3D%22PageFabric%22%3C%2FSPAN%3E%3CBR%20%2F%3E%3CSPAN%3EBackgroundColor%3D%22transparent%22%3C%2FSPAN%3E%3CBR%20%2F%3E%3CSPAN%3ESquare150x150Logo%3D%22Assets%5CSquare150x150Logo.png%22%3C%2FSPAN%3E%3CBR%20%2F%3E%3CSPAN%3ESquare44x44Logo%3D%22Assets%5CSquare44x44Logo.png%22%26gt%3B%3C%2FSPAN%3E%3CBR%20%2F%3E%20%3CSPAN%3E%3CDEFAULTTILE%20wide310x150logo%3D%22%26quot%3BAssets%5CWide310x150Logo.png%26quot%3B%26lt%3B%2FSPAN%22%3E%3CBR%20%2F%3E%20%3CSPAN%3ESquare310x310Logo%3D%22Assets%5CLargeTile.png%22%3C%2FSPAN%3E%3CBR%20%2F%3E%3CSPAN%3ESquare71x71Logo%3D%22Assets%5CSmallTile.png%22%26gt%3B%3C%2FSPAN%3E%3CBR%20%2F%3E%3CSPAN%3E%3CSHOWNAMEONTILES%3E%3C%2FSHOWNAMEONTILES%3E%3C%2FSPAN%3E%3CBR%20%2F%3E%3CSPAN%3E%3CSHOWON%20tile%3D%22%26quot%3Bsquare150x150Logo%26quot%3B%22%3E%3C%2FSHOWON%3E%3C%2FSPAN%3E%3CBR%20%2F%3E%3CSPAN%3E%3CSHOWON%20tile%3D%22%26quot%3Bwide310x150Logo%26quot%3B%22%3E%3C%2FSHOWON%3E%3C%2FSPAN%3E%3CBR%20%2F%3E%3CSPAN%3E%3CSHOWON%20tile%3D%22%26quot%3Bsquare310x310Logo%26quot%3B%22%3E%3C%2FSHOWON%3E%3C%2FSPAN%3E%3CBR%20%2F%3E%3CSPAN%3E%3C%2FSPAN%3E%3C%2FDEFAULTTILE%3E%3C%2FSPAN%3E%3CBR%20%2F%3E%3CSPAN%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CP%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAnybody%20has%20an%20idea%20of%20what%20I%20miss%20for%20the%20desktop%20shortcuts%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThank%20you!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CLINGO-LABS%20id%3D%22lingo-labs-3006275%22%20slang%3D%22fr-FR%22%3E%3CLINGO-LABEL%3EAPPX%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EAssets%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3Epackage%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EWIN32%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Regular Visitor

Hello,

 

I have a problem with my Packaged Win32 application icons resources on Windows 10 and 11.

The icons look great in the Start menu and Taskbar but when I add a desktop short to my app, the icon is displayed with a blue background color.

 

Here is my scenario :

 

1. I generate the resources.pri file using native Visual Studio tool (see attached capture)

2. Then I build an APPX package to publish it on the Store using the command line :

"C:\Program Files (x86)\Windows Kits\10\bin\10.0.18362.0\x86\makeappx.exe" pack /d "E:[compiled app folder]" /p e:\package.appx

3. I can sideload my app using the PS1 command

Add-AppxPackage -Register [package app folder]\AppxManifest.xml

 

 

When deployed (sideload or by Store) the icons look nice in the Start menu and taskbar (see captures).

When I drag the Icon from the Start menu to the desktop to create a shortcut, then the icon is not correct.

Note : I generated all the visual assets using VS for all sizes/scales, and light/dark variants, and unplated.

 

 

The appmanifest looks like that :

 

<uap:VisualElements
DisplayName="PageFabric"
Description="PageFabric"
BackgroundColor="transparent"
Square150x150Logo="Assets\Square150x150Logo.png"
Square44x44Logo="Assets\Square44x44Logo.png">
<uap:DefaultTile Wide310x150Logo="Assets\Wide310x150Logo.png"
Square310x310Logo="Assets\LargeTile.png"
Square71x71Logo="Assets\SmallTile.png">
<uap:ShowNameOnTiles>
<uap:ShowOn Tile="square150x150Logo" />
<uap:ShowOn Tile="wide310x150Logo" />
<uap:ShowOn Tile="square310x310Logo" />
</uap:ShowNameOnTiles>
</uap:DefaultTile>

 

 

 

Anybody has an idea of what I miss for the desktop shortcuts?

 

Thank you!

 

0 Replies