MSIX packages failing to install

%3CLINGO-SUB%20id%3D%22lingo-sub-1035665%22%20slang%3D%22en-US%22%3EMSIX%20packages%20failing%20to%20install%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1035665%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20Team%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ewe%20just%20encountered%20couple%20of%20issues%20below%20-%3C%2FP%3E%3CP%3E1.%20Ask%20the%20developer%20for%20a%20new%20package%20.%20This%20one%20isn't%20signed%20with%20a%20trusted%20certificate%20(0*800B0100)%3C%2FP%3E%3CP%3EWe%20have%20been%20using%20same%20signed%20certificate%20for%20other%20applications%20and%20never%20faced%20issue%20.%20Can%20you%20advise%20%3F%20We%20tried%20with%20IBM%20IIB%20toolkit%20app.%3C%2FP%3E%3CP%3E2.%20App%20installation%20failed%20with%20error%20message%20%3AAppXManifest.xml(20%2C9746)%3Aerror%200*80070003%20%3A%26nbsp%3B%20Cannot%20register%20the%20%3CPACKAGE%20name%3D%22%22%3E%20.%20the%20path%20vfs%5Cprogramfilesx64%5Cadobe%5Cadobe%20illustrator%202020%20support%20files%5Ccontents%5Cwindows%5Cillustrator.exe%20was%20not%20found%20.%3C%2FPACKAGE%3E%3C%2FP%3E%3CP%3EAfter%20editing%20the%20package%20we%20could%20see%20illustrator.exe%20is%20already%20present%20under%20adobe%5Cadobe%20illustrator%202020%5Csupport%20files%5Ccontents%5Cwindows%5Cillustrator.exe%20.%20Somehow%20in%20error%20message%20there%20is%20no%20%5C%20available.We%20also%20checked%20manifest%20file%20and%20executable%20location%20is%20correct%20as%20per%20VFS%20location.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAre%20there%20any%20error%20database%20where%20we%20can%20refer%20to%20for%20possible%20reason%20and%20its%20solution%20%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1035771%22%20slang%3D%22en-US%22%3ERe%3A%20MSIX%20packages%20failing%20to%20install%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1035771%22%20slang%3D%22en-US%22%3EHi%20%2C%3CBR%20%2F%3EOn%20second%20issue%20above%20we%20opened%20the%20package%20in%20editor%20and%20opened%20manifest%20file%20.%20Changed%20the%20incorrect%20path%20and%20saved%20it%20.%20installed%20the%20package%20and%20it%20worked%20.%20However%20%2C%20question%20remains%20same%20as%20why%20in%20first%20instance%20proper%20structure%20was%20not%20present%20in%20manifest%20xml%20file.%3CBR%20%2F%3E%3CBR%20%2F%3EOn%20first%20issue%20i%20am%20still%20investigating%20and%20if%20anyone%20can%20shed%20some%20light%20%3F%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1036475%22%20slang%3D%22en-US%22%3ERe%3A%20MSIX%20packages%20failing%20to%20install%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1036475%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F144842%22%20target%3D%22_blank%22%3E%40Amit%20Kumar%3C%2FA%3E%26nbsp%3BLet%20us%20look%20into%20it.%26nbsp%3B%20Do%20you%20still%20have%20the%20logs%20from%20the%20capture%3F%26nbsp%3B%20Can%20you%20file%20a%20feedback%20hub%20item%20and%20message%20me%20the%20link%20to%20it%3F%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EJohn%3C%2FP%3E%0A%3CP%3EPM%20Lead%2C%20MSIX%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1037955%22%20slang%3D%22en-US%22%3ERe%3A%20MSIX%20packages%20failing%20to%20install%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1037955%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F73899%22%20target%3D%22_blank%22%3E%40John%20Vintzel%3C%2FA%3E%26nbsp%3BWhich%20log%20you%20are%20looking%20for%20%3F%20Also%20can%20let%20me%20know%20where%20to%20file%20feedback%20hub%20item%20%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EMoreover%20%2C%20i%20also%20tried%20with%20factset%20application%20and%20i%20am%20getting%20installation%20failure%20error%20.%3C%2FP%3E%3CP%3EThis%20time%20its%20to%20do%20with%20The%20Path%20VFS%5CWindows%5CHelp%20not%20found%20(0*80070002)%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F159322iAFB7E5D9D696BC04%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22VFS_Windows.jpg%22%20title%3D%22VFS_Windows.jpg%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1045920%22%20slang%3D%22en-US%22%3ERe%3A%20MSIX%20packages%20failing%20to%20install%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1045920%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F235896%22%20target%3D%22_blank%22%3E%40James%20Pike%3C%2FA%3Ethanks%20for%20the%20input.%20I%20removed%20windows%5Chelp%20from%20manifest%20xml%20and%20then%20it%20installed.%3C%2FP%3E%3CP%3EAs%20you%20told%20if%20we%20keep%20as%20part%20of%20tool%20it%20would%20be%20helpful.%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F73899%22%20target%3D%22_blank%22%3E%40John%20Vintzel%3C%2FA%3EDo%20we%20know%20when%20is%20the%20next%20release%20of%20MSIX%20packaging%20tool%20%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1048156%22%20slang%3D%22en-US%22%3ERe%3A%20MSIX%20packages%20failing%20to%20install%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1048156%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F144842%22%20target%3D%22_blank%22%3E%40Amit%20Kumar%3C%2FA%3E%26nbsp%3Bwe%20generally%20ship%20every%20three%20months.%26nbsp%3B%20Jan%2C%20Apr%2C%20Jul%2C%20Oct.%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EYou%20can%20sign%20up%20for%20insider%20builds%20at%20%3CA%20href%3D%22http%3A%2F%2Faka.ms%2Fmsixtoolpreview%26nbsp%3B%22%20target%3D%22_self%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttp%3A%2F%2Faka.ms%2Fmsixtoolpreview%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1042735%22%20slang%3D%22en-US%22%3ERe%3A%20MSIX%20packages%20failing%20to%20install%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1042735%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F144842%22%20target%3D%22_blank%22%3E%40Amit%20Kumar%3C%2FA%3E%26nbsp%3BIf%20the%20help%20directory%20was%20not%20captured%20in%20the%20package%2C%20you%20can%20either%20delete%20the%20helpdirectory%20attribute%20from%20the%20com%20element%20or%20add%20the%20windows%5Chelp%20paths%20to%20your%20package.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EI%20recommend%20deleting%20the%20helpdirectory%20attribute.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EIn%20future%20versions%20of%20the%20tool%2C%20this%20will%20likely%20swap%20to%20be%20a%20warning%20in%20the%20package%20creation%20and%20auto%20comment%20out%20the%20help%20directory%20attribute.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EThanks!%3C%2FP%3E%0A%3CP%3EJames%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Occasional Contributor

Hi Team,

 

we just encountered couple of issues below -

1. Ask the developer for a new package . This one isn't signed with a trusted certificate (0*800B0100)

We have been using same signed certificate for other applications and never faced issue . Can you advise ? We tried with IBM IIB toolkit app.

2. App installation failed with error message :AppXManifest.xml(20,9746):error 0*80070003 :  Cannot register the <package name> . the path vfs\programfilesx64\adobe\adobe illustrator 2020 support files\contents\windows\illustrator.exe was not found .

After editing the package we could see illustrator.exe is already present under adobe\adobe illustrator 2020\support files\contents\windows\illustrator.exe . Somehow in error message there is no \ available.We also checked manifest file and executable location is correct as per VFS location.

 

Are there any error database where we can refer to for possible reason and its solution ?

6 Replies
Highlighted
Hi ,
On second issue above we opened the package in editor and opened manifest file . Changed the incorrect path and saved it . installed the package and it worked . However , question remains same as why in first instance proper structure was not present in manifest xml file.

On first issue i am still investigating and if anyone can shed some light ?
Highlighted

@Amit Kumar Let us look into it.  Do you still have the logs from the capture?  Can you file a feedback hub item and message me the link to it?

 

John

PM Lead, MSIX

Highlighted

@John Vintzel Which log you are looking for ? Also can let me know where to file feedback hub item ?

 

Moreover , i also tried with factset application and i am getting installation failure error .

This time its to do with The Path VFS\Windows\Help not found (0*80070002)

VFS_Windows.jpg

Highlighted

@Amit Kumar If the help directory was not captured in the package, you can either delete the helpdirectory attribute from the com element or add the windows\help paths to your package.

 

I recommend deleting the helpdirectory attribute.

 

In future versions of the tool, this will likely swap to be a warning in the package creation and auto comment out the help directory attribute.

 

Thanks!

James

Highlighted

@James Pikethanks for the input. I removed windows\help from manifest xml and then it installed.

As you told if we keep as part of tool it would be helpful.

@John VintzelDo we know when is the next release of MSIX packaging tool ?

@Amit Kumar we generally ship every three months.  Jan, Apr, Jul, Oct. 

 

You can sign up for insider builds at http://aka.ms/msixtoolpreview