MSIX : Modification Package Challenges

Occasional Contributor

Hi,

 

As part of MSIX Assessments we are trying to explore the option of Applications Redundancy, so we testing few  MSIX Modification packages in our environment and having some challenges. Below are the few scenario's will keep updating as and when found issues.

Environment Details:
MSIX Packaging Tool Version - 1.2019.1018.0
Packaging Machine Windows Version - 1809(OS Build 17763.914)
Testing machine Windows Version - 1809(OS Build 17763.1098)

1) Modification package not getting applied Properly.

Main Package - Firefox ESR 68.5.0
Modification Package - Customization(Homepackage settings, browser Cache setting via Moziall.cfg)

2) Identified an issue when Both Main and Modification packages have same file name, New version File which is in Modification Package does not get's applied, tried with Some Inhouse apps

3) As part of Rollback testing - Modification Package Installation/Uninstallations are working fine manually, but when trying to removed from Sccm applicaiton in Software center it shows as uninstall, but still availiable in 'App add-on & downloadable Content' on client machine.

 

4) In our environment we have few Inhouse apps which are environment based apps, source will be the same for across environments with config files and Environment specific shorcuts(Few users will be part of Multiple environments). As Modification packages does not support Shortcuts, this is not going to work as expected. This is also a quiet common scenario's in enterprises. How can we handle like this apps ?

 

5) When ever we create an Newer Version package for the Main Package upgrade, everytime we also need to update the Modification package(Dependency details changes), unless we use same name for MainPackage for each and every updates/upgrades . I believe this is common across the enterprises. How is it helping from Packaging Paralysis ? as we need to update Modification Package, re-distribution & re-deployments

Any Assistance/Guidance would be much Appreciated.

7 Replies
Small Correction - Typo Error in Original Post
Modification Package - Customization(Homepage settings, browser Cache setting via Mozialla.cfg)

Hi @KumarOne

 

Will it be possible for you to test on a Windows Version 1903? We made an update to the modification package such that file overlay properly works. Also ensure that modification property is set to true in the package manifest: 

<Properties> <rescap6:ModificationPackage>true</rescap6:ModificationPackage> </Properties>

 

More info:

https://docs.microsoft.com/en-us/windows/msix/modification-packages#modification-packages-on-windows...

 

-Dian 

Hi @KumarOne,

 

1) As Dian recommended, first try a 1903 build, I had some issues in the past with 1809 too.

 

Also, make sure that the files in both packages are under VFS and not directly in the package root. The last time I checked modification packages worked correctly only when the main package had the application files under VFS folder.

 

4) Can you please give us more details about why you need to change the name of the app instead of just changing its version? Since I don't work at MSFT I don't have any control over how this will be supported by modification packages but I would like to better understand your day to day packaging workflows, challenges, and goals.

Thanks,

Bogdan

@Dian Hartono 

 

Hi Dian,

 

I'm trying to test the package and installation on 1909 and get's failed with below error. I have created custom self-signed certificate for package creation and testing. 

 

The packages which were created on 1809 was signed again on 1909 using sign tool and still issue is same

 

"Either a new certificate must be installed for this app package or you need a new app package with trusted certificates. Your system administrator or the app developer can help. A certificate chain was processed but terminated in a root certificate that isn't trusted (0x800B0109)"

 

And also i have identified, the same issue with the LabCertificate provided in below location. 

https://github.com/microsoft/MSIX-Labs/tree/master/MSIXLab

 

Any assistance will be much appreciated 

 

 

 

Hi @KumarOne

 

Looking at the error, it looks like the root certificate is no longer trusted. As you said, this is a self signed app so you need to install the certificate in order for the app to install. 

 

  1. Right click on MSIX file
  2. Click Properties
  3. Click Digital Signatures
  4. Select Signature from the list
  5. Click Details
  6. Click View Certificate
  7. Click Install Certificate

If you are installing a self-signed certificate for testing purposes, make sure it goes into the Device store under Trusted People.

 

John.

@John Vintzel@Dian Hartono@Bogdan Mitrache 

 

Hi All,

 

Thanks for your responses, I have now managed to get the applications tested. Below are my detailed findings

 

  • Fixed Point 1 & 2
  • Still looking forward for rest of the points(3,4,5).
  • when ever i reset the application , i have noticed Modification package is getting removed

     

    KumarOne_3-1586410951989.png

     


    KumarOne_4-1586410952453.png

     


    KumarOne_5-1586410951989.png

     


    KumarOne_6-1586410951990.png
  • I could see behaviour differences between Manual testing and SCCM Published testing, Has it been testing from sccm ?

@Bogdan Mitrache 

     "why you need to change the name of the app instead of just changing its version?"

Generally we following the Naming standard conventions , i belive it will be same across the enterprises.

Below is my scenario

Base/Main Package - MozillaFirefox68.6.0esrx64en-GB_68.5.0.0_x64
Base/Main Package - MozillaFirefox68.6.0esrx64en-GB_68.6.0.0_x64

Modification Package - Firefox-ModificationPackage-01X

 

Unless i maintain a Unique Identity name for all packages i cannot use Modification package, again and again without any changes, if not i need to keep updating the Modification package every time with Newer version package details under dependency section. Till so far as per my observation apps seem to be working as expected in Manual testing, but not when published from SCCM. Thanks for your response i would be approaching once i have some more results.