Installation of MSIX Modification Package

%3CLINGO-SUB%20id%3D%22lingo-sub-1459368%22%20slang%3D%22en-US%22%3EInstallation%20of%20MSIX%20Modification%20Package%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1459368%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EDuring%20my%26nbsp%3Btesting%2C%20I%20faced%20an%20issue%20with%20per-machine%20installation%20of%20modification%20package.%20Wanted%20to%20clarify%20if%20this%20is%20a%20known%20thing%20or%20am%20I%20missing%20something%3F%20And%20what%20could%20be%20the%20reason%20behind%20this.%3CBR%20%2F%3E%3CBR%20%2F%3EScenario%3A%3C%2FP%3E%3CP%3EI%20installed%20the%20base%20application%20(Notepad%2B%2B%20in%20my%20case)%26nbsp%3Bper-machine%20using%20%3CSTRONG%3E%3CEM%3EAdd-AppProvisionedPackage%20-online%20%3C%2FEM%3E%3C%2FSTRONG%3Ecmdline.%20When%20I%20tried%20to%20install%20my%20modification%20package%20consisting%20of%20a%20plugin%20to%20Npp%20using%20the%20same%20command%2C%20it%20throws%20%22Unspecified%20Error%22.%3CBR%20%2F%3EEvent%20viewer%20logs%20created%20under%20%3CEM%3E%3CSTRONG%3EAppXDeployment-Server%3C%2FSTRONG%3E%20%3C%2FEM%3Enode%20are%20not%20of%20much%20help%20either.%3C%2FP%3E%3CP%3EHowever%2C%20if%20I%20install%20the%20modification%20package%20manually%20by%20double%20clicking%20the%20MSIX%20file%20or%20using%20the%20%3CEM%3E%3CSTRONG%3EAdd-AppPackage%3C%2FSTRONG%3E%3C%2FEM%3E%20cmdline%20on%20per-user%20basis%2C%20the%20plugin%20gets%20installed%20and%20is%20visible%20within%20the%20base%20application.%3C%2FP%3E%3CP%3EBoth%20base%20application%20and%20plugin%20installs%20under%20VFS.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%20in%20advance%20for%20your%20suggestions%20and%20inputs.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1462688%22%20slang%3D%22en-US%22%3ERe%3A%20Installation%20of%20MSIX%20Modification%20Package%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1462688%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F387933%22%20target%3D%22_blank%22%3E%40Mohit_Kapoor%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHow%20about%20calling%26nbsp%3B%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3E%3CSTRONG%3EAdd-AppxPackage%26nbsp%3B%3C%2FSTRONG%3Eon%20your%20package%20after%20provisioning%20it%3F%20Does%20the%20installation%20of%20the%20modification%20package%20still%20fail%20after%20this%20extra%20step%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1462862%22%20slang%3D%22en-US%22%3ERe%3A%20Installation%20of%20MSIX%20Modification%20Package%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1462862%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F354316%22%20target%3D%22_blank%22%3E%40marcinotorowski%3C%2FA%3E%26nbsp%3B%2C%26nbsp%3BThanks%20for%20your%20inputs.%3C%2FP%3E%3CP%3EIrrespective%20of%20the%20fact%20how%20base%20application%20was%20installed%20(using%20Add-AppProvisionedPackage%20or%20Add-AppPackage)%2C%20modification%20package%20is%20getting%20installed%20successfully%26nbsp%3Bonly%20through%20%3CSTRONG%3EAdd-AppPackage%3C%2FSTRONG%3E%26nbsp%3Bcmdlet.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
New Contributor

Hi,

 

During my testing, I faced an issue with per-machine installation of modification package. Wanted to clarify if this is a known thing or am I missing something? And what could be the reason behind this.

Scenario:

I installed the base application (Notepad++ in my case) per-machine using Add-AppProvisionedPackage -online cmdline. When I tried to install my modification package consisting of a plugin to Npp using the same command, it throws "Unspecified Error".
Event viewer logs created under AppXDeployment-Server node are not of much help either.

However, if I install the modification package manually by double clicking the MSIX file or using the Add-AppPackage cmdline on per-user basis, the plugin gets installed and is visible within the base application.

Both base application and plugin installs under VFS.

 

Thanks in advance for your suggestions and inputs.

2 Replies
Highlighted

@Mohit_Kapoor 

How about calling  Add-AppxPackage on your package after provisioning it? Does the installation of the modification package still fail after this extra step?

Highlighted

@marcinotorowski , Thanks for your inputs.

Irrespective of the fact how base application was installed (using Add-AppProvisionedPackage or Add-AppPackage), modification package is getting installed successfully only through Add-AppPackage cmdlet.