Web-Update Error 0x80070490

%3CLINGO-SUB%20id%3D%22lingo-sub-1171957%22%20slang%3D%22en-US%22%3EWeb-Update%20Error%200x80070490%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1171957%22%20slang%3D%22en-US%22%3E%3CP%3EMy%20app%20installs%20without%20issue%20with%20an%20appinstaller%20file.%20And%20the%20updates%20from%20the%20web%20are%20working%20fine.%20However%2C%20after%20the%20app%20updates%20itself%20once%2C%20I%20have%20seen%20many%20of%20my%20test%20machines%20(maybe%20all).%20Fail%20to%20install%20any%20future%20updates.%20The%20eventviewer%20shows%20an%20error%20code%200x80070490%2C%20with%20a%20message%20of%20%22Element%20not%20found%22.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThis%20is%20rather%20puzzeling%2C%20as%20on%20that%20same%20machine%20if%20I%20click%20an%20ms-appinstaller%3A%3Fsource%3D...%20link%2C%20the%20appinstaller%20offers%20to%20update%20the%20app%20and%20does%20so%20successfully.%20After%20that%2C%20the%20app%20searches%20successfully%20for%20updates%20and%20also%20installs%20a%20new%20update%20once.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ETriggering%20a%20%22CheckUpdateAvailabilityAsync()%22%20from%20code%20leads%20to%20a%20%22PackageUpdateAvailability.Unknown%22%20result.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20been%20unable%20to%20find%20that%20error%20code%20on%20the%20internet%2C%20and%20the%20problem%20arises%20for%20a%20longer%20time%20now%2C%20across%20multiple%20updates%20and%20devices.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAny%20hints%20would%20be%20very%20much%20appreciated%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1172728%22%20slang%3D%22en-US%22%3ERe%3A%20Web-Update%20Error%200x80070490%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1172728%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F548680%22%20target%3D%22_blank%22%3E%40marvin_r%3C%2FA%3E%2C%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EIt%20seems%20like%20something%20is%20happening%20during%20the%20update%20to%20cause%20the%20app%20to%20lose%20its%20appinstaller%20file%20association.%26nbsp%3B%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EWhat%20build%20are%20you%20on%3F%20If%20you%20could%20please%20file%20a%26nbsp%3BFeedback%20Hub%20bug%20with%20a%20repro%20under%20Developer%20Platform%20-%26gt%3B%20App%20deployment%26nbsp%3B%20we%20can%20have%20someone%20take%20a%20look%20and%20determine%20the%20root%20of%20your%20issue.%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EBest%2C%3C%2FP%3E%0A%3CP%3ESharla%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1173397%22%20slang%3D%22en-US%22%3ERe%3A%20Web-Update%20Error%200x80070490%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1173397%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F145112%22%20target%3D%22_blank%22%3E%40Sharla%20Akers%3C%2FA%3E%3C%2FP%3E%3CP%3EI%20have%20reproduced%20and%20filed%20the%20feedback%20here%3A%20%3CA%20href%3D%22https%3A%2F%2Faka.ms%2FAA7ayp9%22%20target%3D%22_self%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Faka.ms%2FAA7ayp9%3C%2FA%3E%3C%2FP%3E%3CP%3EUnfortunately%2C%20I%20might%20have%20selected%20the%20wrong%20category%3F%20Sorry%20about%20that.%20Let%20me%20know%20if%20you%20want%20me%20to%20record%20again.%20Also%2C%20my%20users%20are%20all%20using%20Windows%20with%20German%20selected%20as%20their%20UI-language%2C%20I%20hope%20that's%20not%20a%20problem%20for%20the%20diagnostics.%3C%2FP%3E%3CP%3EThis%20shows%20the%20update%20not%20working.%20I%20will%20try%20to%20catch%20a%20working%20update%20when%20I%20get%20a%20chance%20to%20do%20so.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1174997%22%20slang%3D%22en-US%22%3ERe%3A%20Web-Update%20Error%200x80070490%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1174997%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F548680%22%20target%3D%22_blank%22%3E%40marvin_r%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EThank%20you%20for%20doing%20that.%20Would%20you%20mind%20filing%20the%20feedback%20one%20more%20time%2C%20except%20this%20time%20when%20you%20repro%20the%20issue%2C%20please%20don't%20manually%20install%20with%20the%20AppInstaller%20file%20at%20the%20end.%20This%20way%20we%20can%20capture%20what%20the%20app's%20state%20is%20when%20the%20issue%20is%20occurring.%20Thank%20you!%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EBest%2C%3C%2FP%3E%0A%3CP%3ESharla%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1179158%22%20slang%3D%22en-US%22%3ERe%3A%20Web-Update%20Error%200x80070490%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1179158%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F145112%22%20target%3D%22_blank%22%3E%40Sharla%20Akers%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20filed%20this%20again%3A%20%3CA%20href%3D%22https%3A%2F%2Faka.ms%2FAA7c72w%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Faka.ms%2FAA7c72w%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHope%20this%20helps%3F%20Let%20me%20know%20if%20you%20could%20use%20any%20more%20details.%20I'm%20happy%20to%20record%20more%20feedback%2C%20if%20that%20helps.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20verified%20in%20the%20server%20logs%20that%20a%20fresh%20appinstaller%20install%20of%20our%20app%20does%20ping%20our%20server%20for%20updates%20as%20expected.%3C%2FP%3E%3CP%3EIn%20the%20state%20that%20throws%20the%20error%20previously%20described%2C%20I%20have%20verified%20that%20our%20server%20does%20not%20get%20accessed%20at%20all%20-%20the%20logs%20don't%20show%20any%20activity.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAs%20for%20versions%3A%20my%20test%20machines%20here%20all%20running%20Windows%201909%20with%20all%20updates%20installed.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20app%20is%20built%20on%20my%202004%2F20H1%20-%2019041.84%20desktop%20with%20most%20recent%20VS%2016.4.%20The%20app%20consists%20of%20a%20WPF%20project%20and%20some%20UWP%20components.%20The%20entry%20point%20is%20the%20wpf%20application%20(Windows.FullTrustApplication)%2C%20which%20runs%20in%20the%20background%20and%20starts%20a%20UWP%20window%20via%20protocol%20handler.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIf%20source%20code%20access%20would%20help%2C%20we%20could%20do%20that%20if%20you%20have%20a%20secure%20(non-public)%20way%20for%20me%20to%20send%20you%20the%20file.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1195606%22%20slang%3D%22en-US%22%3ERe%3A%20Web-Update%20Error%200x80070490%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1195606%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F145112%22%20target%3D%22_blank%22%3E%40Sharla%20Akers%3C%2FA%3E%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIf%20there%20is%20anymore%20info%20you%20or%20anyone%20could%20use%2C%20I%20would%20very%20much%20like%20to%20provide%20it.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAnd%20any%20suggestions%20on%20how%20to%20get%20updates%20to%20work%20reliably%20would%20also%20be%20much%20appreciated.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1197039%22%20slang%3D%22en-US%22%3ERe%3A%20Web-Update%20Error%200x80070490%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1197039%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F548680%22%20target%3D%22_blank%22%3E%40marvin_r%3C%2FA%3E%2C%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EYou've%20provided%20enough%20information%20for%20us%2C%20the%20engineers%20are%20still%20looking%20into%20the%20issue.%20We%20are%20looking%20into%20the%20root%20cause%20of%20why%20the%20app%20installer%20association%20is%20disappearing%20after%20an%20update%20takes%20place.%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EBest%2C%3C%2FP%3E%0A%3CP%3ESharla%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1222317%22%20slang%3D%22en-US%22%3ERe%3A%20Web-Update%20Error%200x80070490%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1222317%22%20slang%3D%22en-US%22%3E%3CP%3EI'll%20mention%20that%20I%20have%20seen%20a%20similar%20situation%20with%20AppInstaller%20seemingly%20disappear.%20A%20reboot%20cleared%20the%20problem%20on%20the%20machine.%26nbsp%3B%20I%20did%20not%20investigate%20but%20assumed%20it%20was%20a%20windows%20update.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Contributor

My app installs without issue with an appinstaller file. And the updates from the web are working fine. However, after the app updates itself once, I have seen many of my test machines (maybe all). Fail to install any future updates. The eventviewer shows an error code 0x80070490, with a message of "Element not found". 

 

This is rather puzzeling, as on that same machine if I click an ms-appinstaller:?source=... link, the appinstaller offers to update the app and does so successfully. After that, the app searches successfully for updates and also installs a new update once.

 

Triggering a "CheckUpdateAvailabilityAsync()" from code leads to a "PackageUpdateAvailability.Unknown" result.

 

I have been unable to find that error code on the internet, and the problem arises for a longer time now, across multiple updates and devices.

 

Any hints would be very much appreciated

7 Replies

Hi @marvin_r,

 

It seems like something is happening during the update to cause the app to lose its appinstaller file association.  

 

What build are you on? If you could please file a Feedback Hub bug with a repro under Developer Platform -> App deployment  we can have someone take a look and determine the root of your issue. 

 

Best,

Sharla

 

 

@Sharla Akers

I have reproduced and filed the feedback here: https://aka.ms/AA7ayp9

Unfortunately, I might have selected the wrong category? Sorry about that. Let me know if you want me to record again. Also, my users are all using Windows with German selected as their UI-language, I hope that's not a problem for the diagnostics.

This shows the update not working. I will try to catch a working update when I get a chance to do so.

@marvin_r 

 

Thank you for doing that. Would you mind filing the feedback one more time, except this time when you repro the issue, please don't manually install with the AppInstaller file at the end. This way we can capture what the app's state is when the issue is occurring. Thank you!

 

Best,

Sharla

@Sharla Akers 

 

I have filed this again: https://aka.ms/AA7c72w

 

Hope this helps? Let me know if you could use any more details. I'm happy to record more feedback, if that helps.

 

I have verified in the server logs that a fresh appinstaller install of our app does ping our server for updates as expected.

In the state that throws the error previously described, I have verified that our server does not get accessed at all - the logs don't show any activity.

 

As for versions: my test machines here all running Windows 1909 with all updates installed.

 

 

The app is built on my 2004/20H1 - 19041.84 desktop with most recent VS 16.4. The app consists of a WPF project and some UWP components. The entry point is the wpf application (Windows.FullTrustApplication), which runs in the background and starts a UWP window via protocol handler.

 

If source code access would help, we could do that if you have a secure (non-public) way for me to send you the file.

@Sharla Akers 

 

If there is anymore info you or anyone could use, I would very much like to provide it.

 

And any suggestions on how to get updates to work reliably would also be much appreciated.

Hi @marvin_r,

 

You've provided enough information for us, the engineers are still looking into the issue. We are looking into the root cause of why the app installer association is disappearing after an update takes place. 

 

Best,

Sharla 

I'll mention that I have seen a similar situation with AppInstaller seemingly disappear. A reboot cleared the problem on the machine.  I did not investigate but assumed it was a windows update.