MSIX Modification Package Install Failed - "related set cannot be updated"

%3CLINGO-SUB%20id%3D%22lingo-sub-282184%22%20slang%3D%22en-US%22%3EMSIX%20Modification%20Package%20Install%20Failed%20-%20%22related%20set%20cannot%20be%20updated%22%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-282184%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20Experts%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EProblem%3A%20I%20tried%20to%20create%20Modification%20Package%20for%20my%20Application%2C%20when%20I%20install%20the%20Modification%20Package%2C%20the%20installation%20was%20failed%3A%26nbsp%3B%22A%20related%20set%20cannot%20be%20updated%20because%20the%20updated%20set%20is%20invalid.%20All%20packages%20in%20the%20related%20set%20must%20be%20updated%20at%20the%20same%20time.%20(0x80003d17)%22%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EMy%20Steps%3A%20I%20didn't%20use%20%22MSIX%20Packaging%20Tool%22%2C%20I%20used%20%22makeappx.exe%22%3A%3C%2FP%3E%3CP%3E1.%20created%20Main%20Package%26nbsp%3Bfrom%20folder%3C%2FP%3E%3CP%3E2.%20update%20AppxManifest.xml%20of%20Modification%20Package%2C%20added%20%22%3CMAINPACKAGEDEPENDENCY%3EModification%20Package%20from%20folder%3C%2FMAINPACKAGEDEPENDENCY%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20met%20this%20problem%20when%20trying%20AppX%20Optional%20Package%20and%20fixed%20by%20creating%20appxbundle%20with%20optional%20package%20information.%20But%20in%20MSIX%2C%20seems%20msix%20package%20cannot%20be%20included%20into%20msixbundle%20-%20failed%20with%20error%3A%20%22MakeAppx%20%3A%20error%3A%200x80080215%20-%20Non%20appx%20extensions%20are%20not%20allowed%20for%20payload%20packages%20targeting%20older%20platforms.%22%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAny%20idea%20about%20it%3F%20What%20I%20missed%20in%20the%20package%20creating%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%2C%3C%2FP%3E%3CP%3EPeitao%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-282754%22%20slang%3D%22en-US%22%3ERe%3A%20MSIX%20Modification%20Package%20Install%20Failed%20-%20%22related%20set%20cannot%20be%20updated%22%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-282754%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20John%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThank%20you%20for%20your%20reply.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20found%20the%20reason%20of%20%22related%20set%22%20issue%2C%20because%20I%20added%20%3CAPPLICATION%3E%20in%20AppxManifest.xml%20of%20Modification%20package%2C%20seems%20it's%20not%20support%20and%20will%20cause%26nbsp%3B%22updated%20set%20is%20invalid%22.%20After%20removed%20%3CAPPLICATION%3E%20from%26nbsp%3B%3CSPAN%3EAppxManifest.xml%20of%20Modification%20package%20it%20works%20fine.%3C%2FSPAN%3E%3C%2FAPPLICATION%3E%3C%2FAPPLICATION%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EAs%20I%20mentioned%20when%20I%20want%20to%20create%20msix%20bundle%20for%20msix%20packages%20it%20was%20failed%20due%20to%26nbsp%3B%22MakeAppx%20%3A%20error%3A%200x80080215%20-%20Non%20appx%20extensions%20are%20not%20allowed%20for%20payload%20packages%20targeting%20older%20platforms.%22%20that's%20because%20the%26nbsp%3BMinVersion%20of%20%3CTARGETDEVICEFAMILY%3E%20was%20targeted%20to%20old%20platform%20which%20not%20support%20MSIX%2C%20it%20should%20be%20larger%20than%2010.0.17xxx.%20After%20that%2C%20I%20can%20create%20msixbundle%20and%20install%20without%20related%20set%20issue.%3C%2FTARGETDEVICEFAMILY%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EThanks%2C%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3EPeitao%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-282377%22%20slang%3D%22en-US%22%3ERe%3A%20MSIX%20Modification%20Package%20Install%20Failed%20-%20%22related%20set%20cannot%20be%20updated%22%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-282377%22%20slang%3D%22en-US%22%3E%3CBLOCKQUOTE%3E%3CHR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F170790%22%20target%3D%22_blank%22%3E%40Peitao%20Su%3C%2FA%3E%26nbsp%3Bwrote%3A%3CBR%20%2F%3E%3CP%3EHi%20Experts%2C%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EProblem%3A%20I%20tried%20to%20create%20Modification%20Package%20for%20my%20Application%2C%20when%20I%20install%20the%20Modification%20Package%2C%20the%20installation%20was%20failed%3A%26nbsp%3B%22A%20related%20set%20cannot%20be%20updated%20because%20the%20updated%20set%20is%20invalid.%20All%20packages%20in%20the%20related%20set%20must%20be%20updated%20at%20the%20same%20time.%20(0x80003d17)%22%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EMy%20Steps%3A%20I%20didn't%20use%20%22MSIX%20Packaging%20Tool%22%2C%20I%20used%20%22makeappx.exe%22%3A%3C%2FP%3E%0A%3CP%3E1.%20created%20Main%20Package%26nbsp%3Bfrom%20folder%3C%2FP%3E%0A%3CP%3E2.%20update%20AppxManifest.xml%20of%20Modification%20Package%2C%20added%20%22%3CMAINPACKAGEDEPENDENCY%3EModification%20Package%20from%20folder%3C%2FMAINPACKAGEDEPENDENCY%3E%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EI%20met%20this%20problem%20when%20trying%20AppX%20Optional%20Package%20and%20fixed%20by%20creating%20appxbundle%20with%20optional%20package%20information.%20But%20in%20MSIX%2C%20seems%20msix%20package%20cannot%20be%20included%20into%20msixbundle%20-%20failed%20with%20error%3A%20%22MakeAppx%20%3A%20error%3A%200x80080215%20-%20Non%20appx%20extensions%20are%20not%20allowed%20for%20payload%20packages%20targeting%20older%20platforms.%22%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EAny%20idea%20about%20it%3F%20What%20I%20missed%20in%20the%20package%20creating%3F%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EThanks%2C%3C%2FP%3E%0A%3CP%3EPeitao%26nbsp%3B%3C%2FP%3E%0A%3CHR%20%2F%3E%3C%2FBLOCKQUOTE%3E%0A%3CP%3EThere%20is%20a%20lot%20that%20can%20be%20going%20wrong%20here.%26nbsp%3B%20Most%20likely%20you%20are%20trying%20to%20take%20over%20an%20identity%20of%20something%20that%20is%20already%20existing%20on%20the%20device%20or%20defined%20in%20an%20apps%20set.%26nbsp%3B%20It%20would%20be%20like%20trying%20to%20take%20over%20Word%20as%20part%20of%20the%20Office%20suite%20in%20the%20store.%26nbsp%3B%20Can%20you%20share%20the%20manifest%20of%20the%20failing%20package%20and%20the%20bundle%20manifest%20of%20the%20main%20app%3F%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EJohn.%3C%2FP%3E%3C%2FLINGO-BODY%3E
New Contributor

Hi Experts,

 

Problem: I tried to create Modification Package for my Application, when I install the Modification Package, the installation was failed: "A related set cannot be updated because the updated set is invalid. All packages in the related set must be updated at the same time. (0x80003d17)"

 

My Steps: I didn't use "MSIX Packaging Tool", I used "makeappx.exe":

1. created Main Package from folder

2. update AppxManifest.xml of Modification Package, added "<uap4:MainPackageDependency" with Main Package Name, then created Modification Package from folder

 

I met this problem when trying AppX Optional Package and fixed by creating appxbundle with optional package information. But in MSIX, seems msix package cannot be included into msixbundle - failed with error: "MakeAppx : error: 0x80080215 - Non appx extensions are not allowed for payload packages targeting older platforms."

 

Any idea about it? What I missed in the package creating?

 

Thanks,

Peitao 

2 Replies

@Peitao Su wrote:

Hi Experts,

 

Problem: I tried to create Modification Package for my Application, when I install the Modification Package, the installation was failed: "A related set cannot be updated because the updated set is invalid. All packages in the related set must be updated at the same time. (0x80003d17)"

 

My Steps: I didn't use "MSIX Packaging Tool", I used "makeappx.exe":

1. created Main Package from folder

2. update AppxManifest.xml of Modification Package, added "<uap4:MainPackageDependency" with Main Package Name, then created Modification Package from folder

 

I met this problem when trying AppX Optional Package and fixed by creating appxbundle with optional package information. But in MSIX, seems msix package cannot be included into msixbundle - failed with error: "MakeAppx : error: 0x80080215 - Non appx extensions are not allowed for payload packages targeting older platforms."

 

Any idea about it? What I missed in the package creating?

 

Thanks,

Peitao 


There is a lot that can be going wrong here.  Most likely you are trying to take over an identity of something that is already existing on the device or defined in an apps set.  It would be like trying to take over Word as part of the Office suite in the store.  Can you share the manifest of the failing package and the bundle manifest of the main app?

 

John.

Hi John,

 

Thank you for your reply.

 

I found the reason of "related set" issue, because I added <Application> in AppxManifest.xml of Modification package, seems it's not support and will cause "updated set is invalid". After removed <Application> from AppxManifest.xml of Modification package it works fine.

 

As I mentioned when I want to create msix bundle for msix packages it was failed due to "MakeAppx : error: 0x80080215 - Non appx extensions are not allowed for payload packages targeting older platforms." that's because the MinVersion of <TargetDeviceFamily> was targeted to old platform which not support MSIX, it should be larger than 10.0.17xxx. After that, I can create msixbundle and install without related set issue.

 

Thanks,

Peitao