AppInstaller issue with UAP10:FileType

%3CLINGO-SUB%20id%3D%22lingo-sub-2190671%22%20slang%3D%22en-US%22%3EAppInstaller%20issue%20with%20UAP10%3AFileType%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2190671%22%20slang%3D%22en-US%22%3E%3CP%3EIf%20you%20have%20a%20package%20with%20Manifest%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%20%3CTARGETDEVICEFAMILY%20name%3D%22%26quot%3BWindows.Desktop%26quot%3B%22%20maxversiontested%3D%22%26quot%3B10.0.19041.1%26quot%3B%22%20minversion%3D%22%26quot%3B10.0.18941.0%26quot%3B%2F%22%3E%3C%2FTARGETDEVICEFAMILY%3E%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EAnd%20include%20an%20extension%20of%20category%20%22windows.fileTypeAssociation%22%20and%20utilize%20the%20uap10%3AFileType%20without%20any%20uap%3AFileType%20in%20the%20package%2C%20the%20package%20will%20be%20generated%20by%20makemsix%20just%20fine.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EAppInstaller%20will%20claim%20this%20is%20a%20bad%20package%2C%20even%20on%2021H1.%26nbsp%3B%20The%20entry%20in%20the%20AppXPackaging%2FOperational%20log%20will%20have%20event%20ID%20280%20with%20the%20following%20message%3A%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3CSTRONG%3Eerror%200x80080204%3A%20App%20manifest%20validation%20error%3A%20Line%2034%2C%20Column%2012%2C%20Reason%3A%20SupportedFileTypes%20must%20declare%20at%20least%20one%20FileType%20from%20uap%20namespace%20on%20builds%20earlier%20than%2010.0.18941.0.%3C%2FSTRONG%3E%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EAs%20I%20am%20running%20on%2019041%20and%20have%20declared%20the%20minimum%20to%20be%2018941%20it%20appears%20that%20the%20error%20is%20incorrect.%26nbsp%3B%20Quite%20frankly%20it%20seems%20silly%20that%20any%20package%20that%20can%20support%20UAP10%20must%20have%20a%20UAP%20style%20file%20type%20declared%2C%20but%20even%20in%20this%20case%20I%20appear%20to%20meet%20the%20criteria%20as%20explained%20in%20this%20error%20message.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
MVP

If you have a package with Manifest

  <TargetDeviceFamily Name="Windows.Desktop" MaxVersionTested="10.0.19041.1" MinVersion="10.0.18941.0"/>

 

And include an extension of category "windows.fileTypeAssociation" and utilize the uap10:FileType without any uap:FileType in the package, the package will be generated by makemsix just fine.

 

AppInstaller will claim this is a bad package, even on 21H1.  The entry in the AppXPackaging/Operational log will have event ID 280 with the following message:

 

error 0x80080204: App manifest validation error: Line 34, Column 12, Reason: SupportedFileTypes must declare at least one FileType from uap namespace on builds earlier than 10.0.18941.0.

 

As I am running on 19041 and have declared the minimum to be 18941 it appears that the error is incorrect.  Quite frankly it seems silly that any package that can support UAP10 must have a UAP style file type declared, but even in this case I appear to meet the criteria as explained in this error message.

 

0 Replies