Something went wrong initializing the session in the runtime

Copper Contributor

Hi, I'm having this issue for a while now. I cannot get WebXR to work with one machine. VR in general works, just any browser trying to access WebXR apis gets this issue:

Could not create a session because: Something went wrong initializing the session in the runtime

Cannot find any additional information, just this message in the error console.

Even the error message is unsearchable.


Tried with Acer AH100 headset and emulation.
Tried recent and old versions of Edge and Chrome.
Tried reinstalling Mixed Reality Portal.
Tried a few WebXR demos, using both Threejs and raw JS api.


Windows 21H1 64 bit, but started on older version.
Laptop with NVidia Quadro M1000M and Intel HD Graphics 530


I might have an idea on what has caused this. I had an issue with not working windows update on this and another machine ("hang on installing updates" on power off going on for many hours without any change) and uninstalled some package long long ago. It had something VRish in the name, but can't remember unfortunatelly. Something with hololens or mixed reality?

The second machine still works with WebXR, though.


Also asked this question on Reddit /r/WindowsMR.

0 Replies