Hololens 2 app works with holographic remoting, but not when deployed

Copper Contributor

I am developing an app for Hololens 2 on Unity 2019.4.22f1 using MRTK 2.7.1 and XR SDK. I have done all of the basic MRTK setup (I added MRTK Foundation, Extensions, Tools, and Standard Assets using the Mixed Reality Feature Tool; I used the utility "Configure Project for MRTK" in Unity under Mixed Reality > Toolkit > Utilities; I installed the XR Plugin Manager and the Windows XR Plugin and adjusted their settings in Project settings) and I followed this guide to ensure my project was set up to use XR SDK: https://docs.microsoft.com/en-us/windows/mixed-reality/mrtk-unity/configuration/getting-started-with....


I have made a Hololens 2 app before that worked when deployed, and this project is set up almost exactly the same way. The only major difference is that my working app has only one scene, while in this current project I am using multiple scenes loaded additively. I am using the MRTK scene system and have a Default Manager Scene at build order 0 with the standard "MixedRealityToolkit" (configuration profiles) and "MixedRealityPlayspace" objects. I have an object in this scene with a script that additively loads another scene on Awake(). This scene only contains a Unity UI canvas that has a RadialView solver and SolverHandler component on it (MRTK components to make it follow user's head), and this canvas has some child ui elements/images.


When I run the app using holographic remoting (Window > XR > Windows XR Plugin Remoting) everything works. The UI is able to move around and I can press the buttons on the UI.

When I deploy the app to the Hololens 2 and run it, the ui is fixed to the camera/my head and the app doesnt seem to acknowledge my hands at all. I also added a cube to test a non-ui element and it also fixed in front of the camera. It looks almost as if the scene is rendered like a 2D screen in front of me.

My Build settings are set to Universal Windows Platform, HoloLens target device, ARM64, latest installed Windows SDK and Visual Studio, and release mode.


Any idea what could be causing this issue?

2 Replies

@ryanm798 I have the exact same issue and it is driving me nuts...did you manage to resolve ?

I have an issue with rendering the image loaded inside the child object which is visible in unity game mode. Have you encountered something similar to this?