ToDo on iOS devices not opening at all but notifications working

Occasional Contributor

For the past couple of days ToDo on my iOS devices (phone and iPad) have been failing to launch. I am getting the splash screen for about 10 seconds then back to Home Screen. I have tried deleting and reinstalling which worked the very first time I opened the app on phone then back to the same problem. Strangely though the notifications are working properly. Interested to hear if anyone else has this problem. Can’t help but wonder if it’s related to the rollout of MS Lists in SharePoint 

12 Replies
Yes. I also have the same problem on my iPhone and iPad. It works on Android and on my PC very well. This issue started two days back. Hope MS will come with a new update soon.
I have the same problem, ToDo fails to start on my iPhone after the last upgrade.

@Stuart Travers 

I have the same problem on both my iPhone and iPad.  It appears to have started with the most recent update to iOS 14.  Any fixes?


@RA_Hopp Follow-up: An update to To Do was loaded, but the same problem occurred.  I was able to connect to my tasks, but when I closed the To Do app and tried to reopen, it failed.  I only get the screen and then it refuses to open.  When I delete the app and download it again, it lets me set up the tasks again and works until I close the app.  The same problem occurs on the ipad.


Downloaded the latest version, the same problem occurred. It will not start. After 15 seconds nothing tappens.

@Flink_56 I have discovered that deleting the app and reinstalling it does allow all my tasks to load.  I think (still experimenting) that if I keep the app open (do not close it or restart the phone) it may keep going.  Oddly, that does not seem to be the case on the iPad.  Reinstalling it does show my tasks but it closes itself after a short bit of time and then will not reopen.


I sure hope Microsoft can get this to work.  I like the app otherwise.

I and my coworkers are having exactly the same problem. Looking forward to solution ASAP!!!

@RA_Hopp : Thanks for the tip! Deleting and installing again worked out fine. Now it starts and I have all tasks in the lists. However I have not tried / dared to close and restart the app nor restart my phone. I really hope this problem will be solved with the next upgrade. 

Unfortunately we have tried the uninstall/reinstall process several times with only short term results.  


When is MS going to address this issue?  We may soon have to abandon MS ToDO and find another working solution.

@TrentNichols This problem still remains the same. The new version that was released last week did not solve the problem. Have you looked for and found any other solution that can be used instead?

best response confirmed by Stuart Travers (Occasional Contributor)
I downloaded and installed this app yesterday on my iPhone and iPad and it now seems stable on both.
Yes, for me too so either MS listened or they knew about it and were already fixing it