Latest AppxBundle not Installing (Sideloading)


Has anyone else had issues installing the latest To Do .appxbundle?  The posted version is but when you attempt to install it, the version shows up as, so it will not upgrade.  I tried uninstalling the current version first, but the new package won't install.  Visual C++ 2015 Runtime installs (or attempts to) and then the entire install fails with this error:


"Ask the developer for a new app package. This package may conflict with a package already installed, or it depends on things not installed here (package dependencies), or is made for a different architecture (0x80073CF3)"


The error seems to point to a dependency failure.  I already have Visual C++ 2015 installed, so I'm not sure what else it might be.  I've been using (and updating) To Do this way for probably a year and this is the first time I've had issues.  (I have to sideload due to Microsoft Store being blocked by my organization.)




4 Replies

I just tried manually installing the Visual C++ libraries that are listed along with To Do in the Store, but that didn't help - same error.  To Do install still only goes to 20%, says Visual C++ installed and then fails.




Don't you just love it when a janky MS workaround breaks. I'll likely bump into this issue in the next month or so, will add anything if I can help. Will follow this with interest.
Oh, it's a hoot! Just don't upgrade until you hear it's resolved. This started for me when I tried to go to 2.54 (they're now on 2.56). As a side note, the older install in the store (1.48) works fine. It's just so old that I decided to do without and use the web version for now.
best response confirmed by Steve Wright (Contributor)

Finally resolved this. After checking out this article, I took a look a the app package installer event logs, which stated I needed to "Provide the framework 'Microsoft.UI.Xaml.2.7'". That framework is right there in the list of files along with To Do. Installing it allowed To Do to complete its installation :smile:.


I have no idea why it doesn't install automatically as a prereq/dependency for To Do 🤷‍:male_sign:.