Yealink MP56 Microsoft Teams Certified handsets do not sync Outlook contacts

Occasional Contributor

We've deployed a number of Yealink MP56 headsets and cannot get Outlook contacts to sync.  We've attempted just about everything to force a sync, but it appears as though the handsets only display contacts in the Speed Dial list from the desktop client.  Has anyone come across a fix for this, or is it just a Teams bug? Microsoft Teams desktop client syncs great, however, those contacts don't sync on the handset.

17 Replies



Hi ChapmanBryan, 


Just came across your post and i've recently started at a business (as IT Admin) that uses MP56 phones with Teams and they have the contacts synced. I know you posted this back in May but no-one's come back on this so thought i'd create an account and try to help in case you're still waiting.

First question: How do you currently sync contacts from Outlook to Teams (desktop) in the first place? 

Second, and probably done already: Have you made sure the firmware is up to date on the handsets?



The sync would be with the users Outlook contacts to Teams desktop client. That works, it just breaks as soon as you provision the MP56.  Only shows Speed Dial contacts from Teams.


We've also had numerous complains about the Yealink MP56 phones because of poor call quality.  There has been severe latency issues that otherwise forced our hands to deploy the Polycom CCX models or the AudioCodes C450HD handsets.  The moment we plugged these phones into the same network, latency issues were gone.  Have you too also had issues with latency?  We've gone through Yealink Support and Engineering teams to try and mitigate these issues, across multiple firmware updates, but it seems as those these are a constant problem with these phones.  Almost as if they are underpowered for MS Teams to begin with.


Any help would be greatly appreciated.


Okay, and just to double check do all the users you've got on the Outlook contact list have their relevant phone numbers in the 'business' field?


We've had some minor latency issues but nothing particularly bad, and we have a minor issue to do with picking up the handset often doesn't answer the call, you have to use the touch screen to 'accept', but other than that they've been alright for us. 

Yes, all users have their relevant phone numbers in the correct fields. What firmware and Teams version are you currently on, or is your policy to just update immediate as updates are available? We had to go into the Yealink admin portal for each phone to turn off acoustic sound shield. This improved the latency, however, still have considerable delays.
We are currently on:
Teams version:
Firmware version:
Yeah our policy is to just update them as soon as we notice a new firmware update available. Interestingly I'm trying to access the IP interface of the handset i've got next to me and it's stating the site cant be reached despite the phone working fine...
Tried looking at the device logs for it but cant make any sense from that unfortunately.

@Mickkey Interesting, thanks for trying! much appreciated.  We ended up just replacing the Yealink MP56 handsets with the AudioCode C450HD and most, if not all our problems were resolved at our client site.  It has been a three month RMA process going back and forth with Yealink support and engineering team.

You're welcome, sorry I couldnt help in the end. Glad you've got a solution sorted now though.
Have a good one.

We have the same issue. Contacts are linked to Outlook in Teams. But they are not available on the MP56 handset. Like the other user above, they appear if they are a speed dial, but I would like all contacts to be viewable on the handset. The issue also means that incoming calls from contacts are not recognised by name on the handset. Only the callers number is shown

@Mickkey the issue you are experiencing where call are not answered automatically by picking up the handset, and where the user has to press the "Accept" button - have you found a solution for that?  Is it a setting somewhere on the handset itself?


We're experiencing this same issue after the latest MP56 firmware update, too.

Hi Virgil,
We havent found a definite way unfortunately, it's so intermittent that we're having trouble replicating the issue for a diagnostic to be run, to send onto Yealink. Though doubt they'd do much anyway to be fair.
You can downgrade to previous firmware quite easily though, albeit time-consuming if you have alot of handsets in your business.
On the phones' IP UI, go to Settings > Upgrade > select Upgrade at the bottom and browse to your .rom file. You can download the firmware version you want from the Yealink website, they're like 500+MB for some reason though.



Hi, I have also tested a few Teams Phones and do not see any personal contacts on the phone. However I found this in the manual of the Audiocodec C450HD


If a user creates a contact within Microsoft Outlook, their information appears under the
People app on the phone screen. Contacts in Microsoft Outlook are available in read-
only mode. While only phone numbers currently appear, users can search on the phone
for contacts and easily call the people they may email or meet with, using Outlook.


Here's the manual:


Can someone confirm?


Thanks S



Yes, this is correct. The AudioCodes C450HD resolves contacts and they did sync immediately once the phone has been deployed. The Yealink MP56 has a number of issues, this being on of them. I would stay away from this model, as we've tested the Yealink MP54, and no issues. Haven't gone to the extent of testing the Yealink MP58, but I can imagine for an executive category phone, you get what you pay for. Although the AudioCodes aren't the best aesthetically pleasing phones, they did resolve the majority of our problems we were running into with the Yealink MP56 handsets we deployed. Just to be clear, we did eliminate any potential risks with it being the network or any other external factors.

Also, be sure to purchase the new C450HD handsets. They just recently released a new model TEAMS-C450HDPS-DBW. This includes dual band WiFi, more internal memory and an external power supply.

@ChapmanBryan  It's November, we're still seeing latency issues. Just deployed yesterday and praying it improves our situation across 60 users. We've contacted Yealink and they blame MSFT, but other manufacturers don't seem to have the same issues. We're working on automation to reboot nightly to help mitigate the slowness and instability that seem to increase as runtimes increase.


The change management for users going to new phones/Teams is tough enough when everything is working perfectly. It's much worse and harder when the phones don't do the basics well: pickup when users lift the handset fails sporadically, audio is delayed on calls, sidecars go blank, just to name a few of the pain points with the MP56 device.


We're evaluating the warrantee of these devices which aren't performing as expected and may have to return them all and re-deploy another device, which will impact us as an IT team as well as every one of our users.

Hi @Roger Navarro If you find that doesnt improve it at all, we've recently started running which is supposedly the most up to date firmware. Whilst we still have the same occasional issues with pickup on handset lift/no dial-tone on handset lift, it does seem to be slightly better overall. 


If you need the ROM file (we were only given it after our separate support company chased Yealink for ages) i've uploaded it to "WeTransfer"  since the file size is too large to attach here or send via email (even zipped the file is 700mb, what do they put in there!?)








Hi @Mickkey, we worked with Yealink to get the firmware and had it running only on few phones since it a BETA release. We were assuming that the November 3rd release of from would fix the issues as stated in the release notes:
1. Optimized audio latency.
2. Optimized UI reflection latency.
3. Optimized screen saver timeout
4. Fixed an issue that device is offline from TAC.

Now we have 11 phones offline in TAC showing as software update failed, rebooting, signing in/out does not fix. The phones do show online in the Yealink Management Cloud Service with the new firmware ( and you can redeploy it as it fails because it's the same version. I suppose I will update offline phones with the firmware to and see what happens.

Thanks all for posting!

Hi @scottphayre , you're right, in my TAC it's showing a whole host of "non-urgent health status'" due to the firmware wanting to update, despite being as up to date as it can be, which I hadn't thought to include in my above post. As it doesnt effect the users (and I log onto the IP UI of each phone individually if I need to (small team)) i'm happy to have the TAC look awful whilst the users benefit from slightly better performance.

If you remember to, come back here and update us with how it goes!



@Mickkey @Roger Navarro 


Update. Upgraded a phone from to via phone web console. Same results. Phone is online/working, but offline in TAC. Waited a while to make sure, still not showing up.

Downgraded to and it popped back into Teams. Upgraded to phone stayed online/working in TAC and Yealink Management Cloud Service.

My next test was to downgrade the remaining phones to (only way to get them back in TAC) and via TAC going to try update to

Surprisingly the 10 phones that were offline in TAC, that were originally on and were upgraded to via TAC and failed, after downgrading again and updating to they came back online. Only one issue that I have seen. One device is showing it needs an update, but it’s the same darn update.



Rebooted phone and same thing. After about 30 min showed up in TAC as not needing any updates.