What is the expected behavior for a users in Skype Only receiving messages from an Islands user?

Highlighted
New Contributor

We have some users that piloted early versions of the Teams Client, but went back to Skype for Business Online. This was long before before they sorted out the inter-op and upgrade profiles in the new admin portal.

 

When I change the Org-Wide Default Coexistent mode  from "Legacy-Depreciated" to "Skype Only" - I would expect the behavior to be: route all messages from a "Teams Only" or an "Islands" user to the "Skype Only" users Skype for Business Online Client.

 

This works fine when sending messages from "Islands" user Teams Client to users who have never piloted or logged into Teams, who are in "Skype Only" mode (the UI in the Islands Mode Teams client correctly identifies them as Skype users). This is not the case for any users that is in Skype Only mode - but has logged into Teams at anytime over the last few years for testing. 

 

In other words: If a user piloted an old Teams client, and the profile was changed from "Legacy" to "Skype Only" - messages from a user in Islands Mode are still being routed to the Skype Only user's Teams client.

 

Messages sent to a user in Skype Only mode that never tested teams are being routed correctly. 

 

Am I missing something? 

2 Replies
Highlighted
If you’ve verified the settings are the same for the old pilot users and the rest, I’d create a ticket with MS

Adam
PleAse check if there is no old threads in teams with the users communicating! Make sure you start a new thread when starting a chatt! If a conversation was started in teams and s4b it will stay that way even after changing to skype only