Weird error - camera showing black and white

Copper Contributor



I'm having a weird error with MS Teams on Desktop. On my side (with the little preview window), my camera shows in colour and comes through clearly, however everyone else in the call with me sees me in black and white/semi-distorted.


I have tested this in other video apps (Discord, WebEx, Facebook Messenger) and they all work fine showing me in colour, but on MS Teams it turns me black and white. I can see this if I turn on 'large gallery' or 'together mode', but otherwise I can't see it. Going into settings to check my camera shows it in colour as well.


I'm using a Logitech HD Webcam C270. I have unplugged and replugged the camera in, tried updating drivers (they are up to date), and have re-installed teams. The problem seems to be with MS Teams, not with my camera given it doesn't occur in any other app/program


Any thoughts on how to fix this?

71 Replies

Same Issue


Logitech C270

RTX 2080 Ti

Same issue Logitech C270 and Nvidia Geforce 3080, all on latest versions. Only in Teams to other users, my self view looks correct and other apps like Zoom work just fine.

@Ibby85 Same issue here.  Logitech C930e with NVidia 3070 w/ driver version 460.89.  Preview and testing looks fine on my end, but viewers tell me I appear to be doing Film Noir in Teams :|

What helped to resolve the problem for me is to uninstall MS Teams completely and to reinstall it. The problem was caused by the installation of OBS after MS Teams. Adding a virtual camera through OBS seems to cause the Problem with MS Teams. If the virtual camera is already there when zou install MS Teams, it seems to work.

Same issue here, I have tried two different cameras and I am using nvidia graphics card

I will report if I find a solution.





I went in BIOS and I enabled Intel UHD Integrated Graphics which sorted the issue.


It seems like it is a bug or incopatibility between Nvidia and MS Teams.


Please let me know if this worked for you.







In my case, I have an AMD system, not a solution... 


But yes, the issue seems to be in the Nvidia drivers with Teams.

Having same issue with Logitech Webacm c930e and Nvidia GTX 1650 Super (driver version 460.89)

I would have loved this to be the solution for me... Unfortunately my BIOS doesnt have an Intel UHD Integrated Graphics possibility :(


For me too, the issue only seems to be with Nvidia drivers and Teams.


My system: ASRock Fatal1ty H370 Performance - Logitech Webcam C505e & Microsoft Lifecam - Nvidia GeForce RTX 2060 (driver version:



Adding my "me too!" to this.

Logitech C920
RTX 2080

Uninstalling NVidia Graphics Driver version 460.89 and reinstalling the version that came with my device (327.X) fixed the issue for me (NVidia Quadro K4000).

Has anyone tried to turn off the "In-Game Overlay" feature of the nvidia drivers?nvidia_geforce_experience.png

EXACT same issue for me. Really becoming an issue as I have to present and be on camera a lot for meetings. Really hard to be taken seriously when it looks like I'm on an LSD trip. As with others on here, I've had two versions. Originally there would be that delay, I'd see the camera reset and then my self cam woulda be choppy but everyone saw me okay. I just rebuilt most of my computer (minus the GPU of course) and now having the B&W + orange sherbet spots for me. Picture below.


And yes, it happens with Razer as well.


Razer Kiyo webcam

eVGA GTX 1070

X570 Aorus Elite WiFi

Ryzen 5600X

GSkill Ripjaw V series 32GB

Currently have this issue too with my Logitech C920x webcam too


I have AMD Ryzen 7 3700x and Nvidia RTX 3060 Ti with all the latest drivers installed. I installed OBS last night and started having this issue in Teams. I will try to uninstall OBS and reinstall Teams to see if that fixes the problem.

@Ibby85  I found a fix for me, go on the teams settings, and disable gpu acceleration, that seemed to work for me. 

This worked for me, disabling GPU acceleration resolved the BW video issue.

I tried and it didn't work for me. Seemed to look good for like 30 seconds and then went back to black and white w/ colored squares.

Throwing my hat in the ring on this one.  Affecting me with teams as well, tried uninstalling everything including OBS and Nvidia broadcast but getting the same issue and has happened on 2 of my systems. 


1st was Threadripper Gen1 / RTX2080 / Logitech Brio 4k.  

2nd is Threadripper Gen2 / RTX 3090 / Logitech Brio 4k (second new one)


Really frustrating to troubleshoot 


Also having the same issue.



GTX 1070 (Driver Version 460.89)

16 GB Ram

AverMedia Live Streamer CAM 313



Same issue here - nvidia 2070 super (drivers 460.89) and Razor Kiyo camera.


The same camera and teams work fine on a seperate laptop that has no nvidia graphics card, so some issue between teams and nvidia when using these cameras seems likely