Website Tab in PC app not showing

Occasional Contributor

Hi Folks,


Hoping someone can help.  Since yesterday, using the Teams app on the PC, our website tab for the team just shows a black page.  Basically, we have teams set up and on the team SharePoint site we have created a list.  That list page has been added to the teams App as a website tab.  Has worked well up until now. Today it's just a black page (refreshing tab doesn't fix it).  Opening teams on 365 (in IE) gives a 'This content cannot be displayed in a frame', but will show if you reload the tab.  Does not give the error when using Chrome.

16 Replies
Pretty sure teams used edge to render the tabs. Have you tried using edge to hit the URL saved in the settings for the tab?

Hmm,  This is in a remote desktop environment on Server 2012 R2 so no edge at all.  But I did try it on a machine (just in case) that just accesses 365 and had the same issue in the Teams IE interface.  Logging on to the Teams interface through edge works fine - just like Chrome works. Downloading and running the Teams app on this machine seems to be working though (after the login request when you access the website tab).  I'm  going to try a reinstall of teams on the terminal servers and see if that improves anything.  It's almost like the Teams app on the remote desktop session isn't showing the login screen on the website tab.

Yeah that's odd. try signing out on your Remote session inside of Teams and log back in / start it back up so it flushes it's cache, see if that makes a difference.

Tried that unfortunately - no success.

So your using the web client on the remote computers? or you have desktop client?

Hi Christopher,


Using the desktop client mainly.  Just trying the web client to see if it resulted in an error also.

So the plot thickens.  Tried creating a new user.  Added them to the team blah blah.  Initial use and login when I clicked on the website tab works - list shows as it should.  Full log off and log on for user, ta dah! Back to black screen.

File a support ticket and share it here. Grab also the logs you get. When you post the ticket ID here, I will try to help you pointing some Teams folks to this thread

Experiencing a somewhat related issue.  When configuring a tab to point to a SharePoint webpage, the page just appears blank.  This happens in IE and Edge browser, but works fine in Chrome and also in Teams desktop app.  Pointing to other webpages, like or something, works just fine across all browsers.  So something about SharePoint online pages...

Hi Juan,


Ticket # 10748511

Update on this.  Credit to Frank van der Burgh  on this thread:


Going in to your cache (c:/user/appdata/roaming/microsoft/teams and deleting the file settings.json


Allows teams to work again fine, until, it would seem the app is closed again then you need to repeat the process.

@Craig Bolton Hi, i also opened a ticket for that Problem: [13617584] 

@Anton Dorfmann   Hi Anton.  Support were able to fix my issue - they sent us a hooks.json file to rectify the issue and I just distributed that through a group policy.

@Craig Bolton Hi Craig, thanks for the information. Was that hooks.json peronalised for you or could you share it, so i may make a try? 


@Anton Dorfmann 

Hi Anton,

Try a simple notepad with:  {"enableProcessIntegrityLevel": false}


Save it as hooks.json  to your respective user's file : C:\Users\(user)\AppData\Roaming\Microsoft\Teams


Hope it works :)

@Craig Bolton Thanks for that !!

I´ll try and hopefully it will help us also :)