Webcam redirect not working in Teams on WVD

%3CLINGO-SUB%20id%3D%22lingo-sub-1840507%22%20slang%3D%22en-US%22%3EWebcam%20redirect%20not%20working%20in%20Teams%20on%20WVD%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1840507%22%20slang%3D%22en-US%22%3E%3CP%3EUsing%20the%26nbsp%3B%3CSPAN%3EMSRDC%20client%20it%20works%20(WVD%20optimized)%20fine.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3EUsing%20the%26nbsp%3BMSTSC%20client%2C%20I'm%20able%20to%20bring%20up%20the%20Windows%20Camera%20app%20up%20and%20it%20detects%20my%20camera%20showing%20my%20video%20feed%20fine.%20Other%20apps%20detect%20it%20fine%20as%20well.%20If%20I%20try%20to%20join%20a%20Teams%20meeting%2C%20a%20banner%20shows%20up%20top%3A%20%22Video%20isn't%20working%20We%20couldn't%20use%20your%20webcam%20for%20video.%22%20Fallback%20mode%20is%20enabled%2C%20%22WVD%20Media%20Not%20Connected%22.%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1840507%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EMicrosoft%20Teams%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EWindows%20Virtual%20Desktop%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Highlighted
Occasional Visitor

Using the MSRDC client it works (WVD optimized) fine.

Using the MSTSC client, I'm able to bring up the Windows Camera app up and it detects my camera showing my video feed fine. Other apps detect it fine as well. If I try to join a Teams meeting, a banner shows up top: "Video isn't working We couldn't use your webcam for video." Fallback mode is enabled, "WVD Media Not Connected".

0 Replies