SOLVED

We're still setting up your team. Please try again later.

%3CLINGO-SUB%20id%3D%22lingo-sub-1558135%22%20slang%3D%22en-US%22%3EWe're%20still%20setting%20up%20your%20team.%20Please%20try%20again%20later.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1558135%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3EI%20have%20set%20up%20a%20channel%20within%20Teams%2C%20I%20am%20trying%20to%20get%20the%20email%20address%20and%20keep%20getting%20a%20message%20%22We're%20still%20setting%20up%20your%20team.%20Please%20try%20again%20later%22%20This%20was%20set%20up%20about%203%20hours%20ago.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22TonyTony_0-1596185352879.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F209258i261215F12EBA8A8A%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20title%3D%22TonyTony_0-1596185352879.png%22%20alt%3D%22TonyTony_0-1596185352879.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1558135%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ECommunity%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1559157%22%20slang%3D%22en-US%22%3ERe%3A%20We're%20still%20setting%20up%20your%20team.%20Please%20try%20again%20later.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1559157%22%20slang%3D%22en-US%22%3E%3CP%3EHello%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F745779%22%20target%3D%22_blank%22%3E%40TonyTony%3C%2FA%3E%26nbsp%3B%20%26nbsp%3BAccording%20to%20a%20similar%20post%20on%20our%20answers.microsoft.com%20site%2C%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3CEM%3EIf%20you%20just%20set%20up%20your%20Teams%2C%20there's%20a%20propagation%20delay%20of%2024%20hours.%20You%20can%20try%20it%20again%20afterwards.%3C%2FEM%3E%3CBR%20%2F%3E%3CBR%20%2F%3E%3CEM%3EIf%20it%20does%20not%20work%2C%20you%20can%20contact%20Office365%20Support%20directly%20for%20provisioning%20issue.%20You%20can%20go%20to%20Office.com%20%26gt%3B%20Need%20help%20widget%20on%20the%20bottom%20right%20side.%20They%20can%20run%20provisioning%20scripts%20to%20provision%20the%20account.%3C%2FEM%3E%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EHere's%20the%20link%20to%20the%20item%20I%20quoted%20above.%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fanswers.microsoft.com%2Fen-us%2Fmsteams%2Fforum%2Fall%2Ferror-we-are-still-setting-up-your-team%2F454036e5-d6a2-4f16-b495-bae2a7717797%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fanswers.microsoft.com%2Fen-us%2Fmsteams%2Fforum%2Fall%2Ferror-we-are-still-setting-up-your-team%2F454036e5-d6a2-4f16-b495-bae2a7717797%3C%2FA%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1559424%22%20slang%3D%22en-US%22%3ERe%3A%20We're%20still%20setting%20up%20your%20team.%20Please%20try%20again%20later.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1559424%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F745779%22%20target%3D%22_blank%22%3E%40TonyTony%3C%2FA%3E%26nbsp%3B%20Sometimes%20this%20takes%20forever%20%3A)%3C%2Fimg%3E%3CBR%20%2F%3ETry%20logging%20out%20and%20back%20in%20or%20try%20the%20web%20client%20and%20see%20if%20that%20helps!%20Otherwise%20just%20wait%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1565043%22%20slang%3D%22en-US%22%3ERe%3A%20We're%20still%20setting%20up%20your%20team.%20Please%20try%20again%20later.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1565043%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F745779%22%20target%3D%22_blank%22%3E%40TonyTony%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20the%20same%20issue.%20Created%20a%20channel%20last%20Saterday%20and%20no%26nbsp%3B%40address%20possible%20until%20today%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1616676%22%20slang%3D%22en-US%22%3ERe%3A%20We're%20still%20setting%20up%20your%20team.%20Please%20try%20again%20later.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1616676%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F745779%22%20target%3D%22_blank%22%3E%40TonyTony%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20am%20having%20this%20issue.%20Teams%20and%20channels%20created%20week%20ago%2C%20I%20am%20still%20getting%20this%20error%20while%20trying%20to%20get%20email%20address%20of%20the%20channel.%20Are%20you%20still%20having%20this%20issue%3F%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1771571%22%20slang%3D%22en-US%22%3ERe%3A%20We're%20still%20setting%20up%20your%20team.%20Please%20try%20again%20later.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1771571%22%20slang%3D%22en-US%22%3E%3CP%3EI%20am%20also%20experiencing%20this%20issue.%26nbsp%3B%3C%2FP%3E%3CP%3E%3CBR%20%2F%3EThe%20channels%20for%20which%20I%20try%20to%20create%20an%20email%20address%20were%20all%20set-up%20weeks%20ago%20and%20are%20being%20used%20for%20chats%20etc%20without%20a%20problem.%20I%20can%20create%20a%20link%20to%20the%20channel%2C%20using%20the%20option%20%22Get%20link%20to%20channel%22.%20Howevever%2C%20when%20I%20select%20%22Get%20email%20address%22%20in%20the%20same%20channel%20menu%2C%20I%20get%20the%20above%20mentioned%20error.%20This%20is%20consistent%20for%20all%20channels%20in%20all%20teams%20that%20I%20have%20(8%20teams%20with%20each%20around%205%20channels%20each).%20Logging%20out%20and%20back%20in%20again%20and%20restarting%20MS%20Teams%20doesn't%20help.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHas%20anyone%20received%20a%20solution%20yet%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1854545%22%20slang%3D%22en-US%22%3ERe%3A%20We're%20still%20setting%20up%20your%20team.%20Please%20try%20again%20later.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1854545%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F829128%22%20target%3D%22_blank%22%3E%40JohsLock%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI'm%20having%20the%20issue%20too.%20I%20set%20up%20the%20channels%205%20days%20ago%2C%20and%20no%20email%20address.%20I%20checked%20the%20web%20app%20and%20desktop%20app%20--%20the%20message%20is%20%22we're%20still%20setting%20up%20your%20team.%20Please%20try%20again%20later.%22%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2041874%22%20slang%3D%22en-US%22%3ERe%3A%20We're%20still%20setting%20up%20your%20team.%20Please%20try%20again%20later.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2041874%22%20slang%3D%22en-US%22%3E%3CP%3EI%20just%20had%20this%20recently.%26nbsp%3B%20In%20my%20case%2C%20it%20was%20caused%20by%20renaming%20the%20channels%20after%20they%20were%20created.%26nbsp%3B%20My%20initial%20solution%20was%20to%20rename%20the%20channel%2C%20delete%20it%2C%20then%20create%20a%20new%20channel%20with%20the%20correct%20name.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EBut%20I%20have%20a%20better%20fix%20now%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E1.%20Delete%20the%20channel.%3C%2FP%3E%3CP%3E2.%20Restore%20the%20channel.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAfter%20doing%20this%2C%20the%20%22Get%20email%20address%22%20function%20seems%20to%20work%20perfectly.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Visitor

Hi,

I have set up a channel within Teams, I am trying to get the email address and keep getting a message "We're still setting up your team. Please try again later" This was set up about 3 hours ago. 

 

TonyTony_0-1596185352879.png

 

7 Replies

Hello @TonyTony   According to a similar post on our answers.microsoft.com site, 

 

If you just set up your Teams, there's a propagation delay of 24 hours. You can try it again afterwards.

If it does not work, you can contact Office365 Support directly for provisioning issue. You can go to Office.com > Need help widget on the bottom right side. They can run provisioning scripts to provision the account.

 

Here's the link to the item I quoted above. https://answers.microsoft.com/en-us/msteams/forum/all/error-we-are-still-setting-up-your-team/454036...

Best Response confirmed by ThereseSolimeno (Microsoft)
Solution

@TonyTony  Sometimes this takes forever :)
Try logging out and back in or try the web client and see if that helps! Otherwise just wait

@TonyTony 

I have the same issue. Created a channel last Saterday and no @address possible until today

@TonyTony 

I am having this issue. Teams and channels created week ago, I am still getting this error while trying to get email address of the channel. Are you still having this issue? 

I am also experiencing this issue. 


The channels for which I try to create an email address were all set-up weeks ago and are being used for chats etc without a problem. I can create a link to the channel, using the option "Get link to channel". Howevever, when I select "Get email address" in the same channel menu, I get the above mentioned error. This is consistent for all channels in all teams that I have (8 teams with each around 5 channels each). Logging out and back in again and restarting MS Teams doesn't help.

 

Has anyone received a solution yet?

@JohsLock 

I'm having the issue too. I set up the channels 5 days ago, and no email address. I checked the web app and desktop app -- the message is "we're still setting up your team. Please try again later."

I just had this recently.  In my case, it was caused by renaming the channels after they were created.  My initial solution was to rename the channel, delete it, then create a new channel with the correct name.

 

But I have a better fix now:

 

1. Delete the channel.

2. Restore the channel.

 

After doing this, the "Get email address" function seems to work perfectly.