Users cannot upload files

Copper Contributor

Hello, we have just created Teams account for our business. I invited users by sending invitations from Teams. However, no one besides me (admin) can upload any files. While uploading files, users get the error "please check if the site is available and try again later".

I found out that other users can't access to the corresponding SharePoint site. When a user opens an image that the admin sent as attachment, they receive such error (see the attached image below). I think I need to give them permission to access to SharePoint but I can't figure out how. Any help is appreciated.

11 Replies

Hi @volkantan - are these users guests or employees in your org? If they're guests, did they click to accept the invite to get added to your org's directory?


All users added to your Team gives them edit rights in the SharePoint site, so you shouldn't need to also add them to the corresponding SharePoint. Are the other users who can't access SharePoint employees or guests?

Hi @Kelly_Edinger - these are employees in my org. I invited them using Invite people button in Teams and sent invitations by email (as shown in the attached picture). Then they clicked to accept my invitation. I can see them as members in the org inside Microsoft Teams. But still no luck. We have also recently created another Microsoft Teams account for our other business, we are having the same problem there. I have also attached the console log error, which appears whenever I try to upload something. I have tried with the app and other browsers.


Other users who can't access SharePoint are employees that I invited by email.

Hi @volkantan - is this the free version of Teams or do you have an Office 365 subscription? 

Hi @Kelly_Edinger

Yes, this is the free version. I visited this URL and typed in my business email and opened my Teams account.

Do I need a paid subscription for uploading files?

Hi @volkantan - according to Microsoft, you shouldn't, but there's not really a lot of helpful information posted yet about managing the free version:



Hi @Kelly_Edinger - I have absolutely tried everything, yet no luck. It is really strange that I seem to be the only one having this problem.

@volkantan i have the same problem, i tried to contact the support microsoft on chat but they answered me to use this forum. I have a teams app on windows 10 and i can't upload any file from my pc. I try to use the account of my owner team and there isn't nothing to do. If i want to upload file on a private message appear me a message that invite me to buy one drive business, if i want to upload file i a channel there is a message that says "Could not recover your files We are trying to restore them." or "We are setting up your files. Check back in a few minutes" and i can't upload any file. it's incredible!!!! someone help us!!!

I have the same problem too, and my teammates experiencing the same problem too. 

@volkantan We have the same issue with some of our users. They can however upload files just fine if they do it directly in SharePoint instead of via Teams ('Open in SharePoint' from the Teams Channel).




you will just need to go to "", sign out your personal account ( which is not your organization account), if there are multiple personal accounts, make sure to log out all. 


how to make sure all are signed out? just go to "" again, make sure the default account there is not your personal account. and also log in using your corporate account again. then go to your team - close and start again.


Last resort, after you have done above, restart your computer. 

Hi Team,


Might be , your sharepoint site is locked. Please connect with your sharepoint administrator and unlock the site.


Thank you


Jijesh KT