User sign up with company email id failing error : <Email id> hasn't been added to your organization

%3CLINGO-SUB%20id%3D%22lingo-sub-1415481%22%20slang%3D%22en-US%22%3EUser%20sign%20up%20with%20company%20email%20id%20failing%20error%20%3A%20%3CEMAIL%20id%3D%22%22%3E%20hasn't%20been%20added%20to%20your%20organization%3C%2FEMAIL%3E%3CLINGO-BODY%20id%3D%22lingo-body-1415481%22%20slang%3D%22en-US%22%3E%3CP%20class%3D%22%22%3EHi%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWe%20are%20a%20small%20company%20trying%20out%20the%20Teams%20Free%20edition.%20I%20am%20the%20IT%20admin%20(sorts%20of)%20and%20I%20am%20trying%20to%20see%20why%20one%20user%20is%20facing%20this%20error%20when%20trying%20to%20sign%20up%20%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%20class%3D%22contentCodeblock%22%3E%3CSPAN%3E%3CEMAIL%20id%3D%22%22%3E%20hasn't%20been%20added%20to%20your%20organization's%20directory.%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3E%3C%2FEMAIL%3E%3C%2FSPAN%3E%3CSTRONG%3EContact%20your%20admin%20or%20try%20a%20different%20email.%3C%2FSTRONG%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHere%20is%20what%20has%20happened%20so%20far%20(In%20chronological%20order)%20%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3COL%3E%3CLI%3EI%20signed%20up%20for%20MS%20Teams%20Free%20edition%20with%20my%20personal%20%3CSTRONG%3E%40yahoo.com%3C%2FSTRONG%3E%20email%20id.%3COL%3E%3CLI%3EThis%20account%20which%20which%20I%20signed%20up%20for%20MS%20Teams%20is%20different%20from%20the%20account%20with%20which%20I%20am%20writing%20this%20question%3C%2FLI%3E%3CLI%3EMy%20current%20account%20(used%20for%20writing%20this%20question)%20is%20created%20using%20an%20email%20id%20on%20my%20company%20domain.%3C%2FLI%3E%3C%2FOL%3E%3C%2FLI%3E%3CLI%3EWhile%20signing%20up%20I%20choose%20%22For%20Work%22%3C%2FLI%3E%3CLI%3EAfter%20signing%20up%20and%20setting%20Teams%20on%20my%20system%2C%20I%20sent%20out%20invites%20to%20all%20the%20company%20employees%20using%20the%20company%20email%20id%20(i.e.%20%3CUSERNAME%3E%40companyname.com%20email%20ids)%3C%2FUSERNAME%3E%3C%2FLI%3E%3CLI%3E16%20employees%20have%20successfully%20signed%20up%20so%20far%20and%20we%20have%20been%20using%20Teams%20properly%3COL%3E%3CLI%3EThe%20latest%20successful%20sign%20up%20was%20just%20a%20few%20minutes%20before%20the%20problematic%20sign%20up.%3C%2FLI%3E%3C%2FOL%3E%3C%2FLI%3E%3CLI%3EHowever%2C%20when%201%20user%20tried%20to%20sign%20up%20yesterday%20the%20above%20mentioned%20error%20starting%20appearing%20and%20the%20sign%20up%20could%20not%20happen.%3C%2FLI%3E%3CLI%3EWe%20do%20not%20have%20an%20Office%20365%20subscription.%3C%2FLI%3E%3CLI%3EAfter%20failing%20to%20sign%20up%20with%20the%20employee%20email%20id%2C%20I%20created%20another%20email%20id%20in%20the%20company%20domain%20and%20used%20it%20to%20sign%20up%20to%20teams.%3C%2FLI%3E%3CLI%3EAt%20the%20very%20first%20step%20of%20sign%20up%20I%20get%20the%20above%20error%20message%20(This%20is%20a%20brand%20new%20email%20id%20created%20just%20now%20for%20this%20sign%20up%20process).%3C%2FLI%3E%3C%2FOL%3E%3CP%3EI%20initially%20posted%20this%20question%20here%20%3CA%20href%3D%22https%3A%2F%2Fanswers.microsoft.com%2Fen-us%2Fmsteams%2Fforum%2Fall%2Fuser-sign-up-with-company-email-id-failing-with%2F5be61da6-403f-4380-aa84-b829c0a5b7a7%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fanswers.microsoft.com%2Fen-us%2Fmsteams%2Fforum%2Fall%2Fuser-sign-up-with-company-email-id-failing-with%2F5be61da6-403f-4380-aa84-b829c0a5b7a7%3C%2FA%3E%20where%20I%20found%20this%20issue%20reported%20by%20many%20other%20people.%20I%20was%20then%20directed%20here%20by%20a%20Microsoft%20moderator.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%20class%3D%22%22%3EAlmost%20all%20of%20those%20posts%20(on%20answers.microsoft.com)%20seem%20to%20suggest%20the%20cause%20as%20some%20other%20Microsoft%20service%20subscription%20using%20email%20id%20from%20the%20same%20domain%20name%20and%20that%20the%20domain%20ownership%20need%20to%20change.%20I%20tried%20that%20by%20going%20to%20the%20following%20two%20links%20%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CUL%3E%3CLI%3E%3CA%20href%3D%22https%3A%2F%2Fadmin.microsoft.com%2Fadmintakeover%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fadmin.microsoft.com%2Fadmintakeover%3C%2FA%3E%3C%2FLI%3E%3CLI%3E%3CA%20href%3D%22https%3A%2F%2Fportal.office.com%2Fadmintakeover%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fportal.office.com%2Fadmintakeover%3C%2FA%3E%3C%2FLI%3E%3C%2FUL%3E%3CP%3EIn%20both%20the%20cases%2C%20when%20I%20try%20to%20login%20with%20the%20my%20current%20Microsoft%20account%20(with%20which%20I%20am%20writing%20this%20question)%20I%20get%20the%20error%20as%20seen%20below%20%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22Screenshot%202020-05-24%20at%206.27.36%20PM.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F194200i9BB27ED3B4B5173C%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20title%3D%22Screenshot%202020-05-24%20at%206.27.36%20PM.png%22%20alt%3D%22Screenshot%202020-05-24%20at%206.27.36%20PM.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%20class%3D%22%22%3EFurther%20what%20is%20different%20about%20my%20case%20compared%20to%20other%20existing%20such%20questions%20is%20that%2016%20other%20people%20have%20already%20successfully%20signed%20up%20with%20the%20company%20email%20id.%20None%20of%20the%20faced%20this%20issue.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHow%20can%20I%20go%20about%20resolving%20this%20issue%20for%20this%20one%20employee%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIf%20any%20of%20the%20MS%20support%20staff%20need%20more%20details%20(about%20the%20domain%20name%20or%20the%20specific%20email%20id%20having%20this%20issue)%20in%20a%20private%20message%2C%20please%20let%20me%20know.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWe%20as%20a%20company%20are%20moving%20from%20Slack%20to%20Teams%20and%20it%20is%20absolutely%20essential%20that%20every%20employee%20is%20able%20to%20sign%20up%20and%20use%20Teams.%20If%20not%20we%20will%20have%20to%20abandon%20teams%20and%20go%20back%20to%20Slack%20(which%20I%20would%20not%20prefer).%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAny%20help%20in%20this%20regard%20is%20greatly%20appreciated.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1415481%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAdministrator%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EAdoption%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EMicrosoft%20Teams%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3C%2FLINGO-SUB%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1416143%22%20slang%3D%22en-US%22%3ERe%3A%20User%20sign%20up%20with%20company%20email%20id%20failing%20error%20%3A%20%3CEMAIL%20id%3D%22%22%3E%20hasn't%20been%20added%20to%20your%20or%3C%2FEMAIL%3E%3CLINGO-BODY%20id%3D%22lingo-body-1416143%22%20slang%3D%22en-US%22%3EUpdate%20%3A%20While%20the%20problem%20with%20that%20one%20specific%20email%20id%20continues%20to%20exist%2C%20I%20have%20been%20able%20to%20get%20that%20employee%20on%20to%20Teams%20by%20creating%20an%20alias%20email%20id%20and%20signing%20up%20with%20that%20email%20id.%3CBR%20%2F%3E%3CBR%20%2F%3EI%20had%20to%20use%20a%20completely%20different%20browser%20(Chromium)%20and%20an%20incognito%20window%20to%20get%20that%20sign%20up%20working.%3CBR%20%2F%3E%3CBR%20%2F%3EHowever%20I%20would%20really%20like%20to%20have%20this%20issue%20actually%20resolved%20and%20not%20have%20a%20symptomatic%20relief.%20So%20if%20someone%20can%20help%20me%20get%20to%20the%20root%20of%20the%20issue%20with%20that%20one%20particular%20email%20id%2C%20it%20would%20really%20help.%3C%2FLINGO-BODY%3E%3C%2FLINGO-SUB%3E
Highlighted
New Contributor

Hi,

 

We are a small company trying out the Teams Free edition. I am the IT admin (sorts of) and I am trying to see why one user is facing this error when trying to sign up :

 

<Email Id> hasn't been added to your organization's directory. Contact your admin or try a different email.

 

Here is what has happened so far (In chronological order) :

 

  1. I signed up for MS Teams Free edition with my personal @yahoo.com email id.
    1. This account which which I signed up for MS Teams is different from the account with which I am writing this question
    2. My current account (used for writing this question) is created using an email id on my company domain.
  2. While signing up I choose "For Work"
  3. After signing up and setting Teams on my system, I sent out invites to all the company employees using the company email id (i.e. <username>@companyname.com email ids)
  4. 16 employees have successfully signed up so far and we have been using Teams properly
    1. The latest successful sign up was just a few minutes before the problematic sign up.
  5. However, when 1 user tried to sign up yesterday the above mentioned error starting appearing and the sign up could not happen.
  6. We do not have an Office 365 subscription.
  7. After failing to sign up with the employee email id, I created another email id in the company domain and used it to sign up to teams.
  8. At the very first step of sign up I get the above error message (This is a brand new email id created just now for this sign up process).

I initially posted this question here https://answers.microsoft.com/en-us/msteams/forum/all/user-sign-up-with-company-email-id-failing-wit... where I found this issue reported by many other people. I was then directed here by a Microsoft moderator.

 

Almost all of those posts (on answers.microsoft.com) seem to suggest the cause as some other Microsoft service subscription using email id from the same domain name and that the domain ownership need to change. I tried that by going to the following two links :

 

In both the cases, when I try to login with the my current Microsoft account (with which I am writing this question) I get the error as seen below :

 

Screenshot 2020-05-24 at 6.27.36 PM.png

 

Further what is different about my case compared to other existing such questions is that 16 other people have already successfully signed up with the company email id. None of the faced this issue.

 

How can I go about resolving this issue for this one employee?

 

If any of the MS support staff need more details (about the domain name or the specific email id having this issue) in a private message, please let me know.

 

We as a company are moving from Slack to Teams and it is absolutely essential that every employee is able to sign up and use Teams. If not we will have to abandon teams and go back to Slack (which I would not prefer).

 

Any help in this regard is greatly appreciated.

 

1 Reply
Highlighted
Update : While the problem with that one specific email id continues to exist, I have been able to get that employee on to Teams by creating an alias email id and signing up with that email id.

I had to use a completely different browser (Chromium) and an incognito window to get that sign up working.

However I would really like to have this issue actually resolved and not have a symptomatic relief. So if someone can help me get to the root of the issue with that one particular email id, it would really help.