User Photos not updating

%3CLINGO-SUB%20id%3D%22lingo-sub-96499%22%20slang%3D%22en-US%22%3EUser%20Photos%20not%20updating%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-96499%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20all%2C%20I'm%20having%20users%20update%20their%20photos%20and%20they%20aren't%20showing%20up%20for%20other%20users%2C%20they%20are%20propgating%20throughout%20365%20but%20Teams%20still%20doesn't%20show%20them.%20I%20opened%20up%20my%20Teams%20client%20on%20a%20laptop%20I%20haven't%20used%20in%20a%20bit%20and%20it%20updated%20the%20photos.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EDoes%20anyone%20know%20how%20long%20it%20takes%20Teams%20to%20update%20these%20photos%3F%20Obviously%20it's%20cached%20somewhere%2C%20and%20curious%20to%20what%20that%20pulls%20from%2C%20what%20the%20timer%20is%20and%20can%20you%20manually%20tell%20Teams%20to%20refresh%20this%20photo%20cache%3F%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-96499%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EMicrosoft%20Teams%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESettings%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-150306%22%20slang%3D%22en-US%22%3ERe%3A%20User%20Photos%20not%20updating%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-150306%22%20slang%3D%22en-US%22%3Eyeah%20i%20was%20just%20about%20to%20tell%20you%20to%20restart%20it%20so%20it%20updates%20cache.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-150303%22%20slang%3D%22en-US%22%3ERe%3A%20User%20Photos%20not%20updating%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-150303%22%20slang%3D%22en-US%22%3EFixed%20it!%20Logged%20out%20of%20the%20Teams%20client%20and%20logged%20back%20in.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-150295%22%20slang%3D%22en-US%22%3ERe%3A%20User%20Photos%20not%20updating%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-150295%22%20slang%3D%22en-US%22%3EMy%20photo%20is%20working%2C%20but%20it%20does%20not%20show%20the%20photo%20of%20one%20of%20the%20other%20users%20on%20my%20team.%20They%20added%20the%20photo%20over%20a%20week%20ago%2C%20it%20does%20show%20up%20for%20me%20in%20Outlook%20and%20in%20Skype.%20It%20does%20show%20his%20correct%20photo%20in%20the%20web%20version%20of%20Teams%20but%20not%20in%20my%20Android%20or%20PC%20client.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-150292%22%20slang%3D%22en-US%22%3ERe%3A%20User%20Photos%20not%20updating%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-150292%22%20slang%3D%22en-US%22%3Eif%20you%20update%20your%20photo%20on%20prem%2C%20it%20will%20sync%20to%20all%20365%20services%20including%20Teams%2C%20it%20just%20takes%20like%20a%20week%20to%20propagate.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-150288%22%20slang%3D%22en-US%22%3ERe%3A%20User%20Photos%20not%20updating%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-150288%22%20slang%3D%22en-US%22%3E%3CP%3EI%20am%20having%20the%20same%20issue%20here%20as%20well.%20Is%20there%20a%20known%20fix%3F%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-97292%22%20slang%3D%22en-US%22%3ERe%3A%20User%20Photos%20not%20updating%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-97292%22%20slang%3D%22en-US%22%3E%3CP%3Eyeah%2C%20my%20Teams%20on%20laptop%20is%20getting%20photos%20but%20not%20my%20desktop%20Teams.%20Not%20sure%20what%20causes%20it%20to%20update.%20Still%20trying%20to%20figure%20that%20out.%20Something%20up%20with%20the%20client%20itself%20not%20rendering%20them%20or%20updating%20cache.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-97041%22%20slang%3D%22en-US%22%3ERe%3A%20User%20Photos%20not%20updating%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-97041%22%20slang%3D%22en-US%22%3E%3CP%3EActually%20I%20stand%20corrected.%20I%20changed%20my%20photo%20in%20the%20Teams%20app%20yesterday%20and%20it%20is%20now%20visible%20in%20Office%20365%2FYammer%20etc.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-96674%22%20slang%3D%22en-US%22%3ERe%3A%20User%20Photos%20not%20updating%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-96674%22%20slang%3D%22en-US%22%3E%3CP%3EI'm%20pretty%20sure%20the%20MS%20Teams%20profile%20photo%20isn't%20connected%20to%20O365%20at%20this%20time.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-754377%22%20slang%3D%22en-US%22%3ERe%3A%20User%20Photos%20not%20updating%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-754377%22%20slang%3D%22en-US%22%3E%3CP%3ETeams%20doesn't%20want%20to%20log%20out%20here%20%E2%80%A6%20%3A(%3C%2Fimg%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIt%20stays%20on%20the%20loading%20screen%20forever%20%E2%80%A6%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-816771%22%20slang%3D%22en-US%22%3ERe%3A%20User%20Photos%20not%20updating%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-816771%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F875%22%20target%3D%22_blank%22%3E%40Christopher%20Webb%3C%2FA%3E%26nbsp%3Btwo%20years%20later%20and%20still%20major%20issues%20with%20profil%20photo%20syncing.%20Several%20users%20have%20new%20profile%20photos%2C%20which%20show%20in%20the%20Teams%20web%20app%2C%20but%20not%20in%20the%20desktop%20Teams%20app%20-%20after%20several%20days.%26nbsp%3B%20I%20have%20restarted%20my%20computer%20a%20few%20times%2C%20no%20change.%20We%20are%20having%20similar%20issues%20in%20SharePoint%2C%20so%20I%20can%20only%20assume%20that%20the%20entire%20profile%20photo%20handling%20in%20Office%20365%20is%20mostly%20broken.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-834176%22%20slang%3D%22en-US%22%3ERe%3A%20User%20Photos%20not%20updating%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-834176%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F54636%22%20target%3D%22_blank%22%3E%40Ian%20Caldwell%2C%20MSc%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHi%2C%20we%20are%20also%20affected.%20This%20is%20really%20annoying!%3C%2FP%3E%3CP%3EAny%20solution%2C%20dear%20Microsoft%20Teams%20team%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-836986%22%20slang%3D%22en-US%22%3ERe%3A%20User%20Photos%20not%20updating%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-836986%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F875%22%20target%3D%22_blank%22%3E%40Christopher%20Webb%3C%2FA%3E%26nbsp%3Bhave%20a%20look%20on%20this%20thread%3A%26nbsp%3B%3CA%20title%3D%22Office%20365%20Profile%20picture%20not%20displayed%20inside%20SharePoint%20People%20Web%20Part%20on%20Modern%20Site%20Page%22%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2FSharePoint%2FOffice-365-Profile-picture-not-displayed-inside-SharePoint%2Fm-p%2F297608%22%20target%3D%22_self%22%3EOffice%20365%20Profile%20picture%20not%20displayed%20inside%20SharePoint%20People%20Web%20Part%20on%20Modern%20Site%20Page.%26nbsp%3B%3C%2FA%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1076681%22%20slang%3D%22en-US%22%3ERe%3A%20User%20Photos%20not%20updating%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1076681%22%20slang%3D%22en-US%22%3E%3CP%3EI%20just%20updated%20a%20bunch%20of%20user%20profile%20photos%20in%20Office%20365.%20I%20see%20some%20of%20the%20updated%20photos%20when%20logged%20into%20Teams%20(desktop)%2C%20but%20other%20users%20are%20still%20displaying%20old%20photos.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhen%20I%20log%20into%20Teams%20on%20the%20web%2C%20I%20see%20all%20of%20the%20updated%20photos.%20Microsoft%20support%2C%20have%20you%20figured%20out%20a%20way%20to%20get%20the%20new%20profile%20photos%20to%20actually%20sync%20with%20Teams%20desktop%20client%3F%20I%20tried%20logging%20out%2C%20and%20logging%20back%20in%2C%20but%20that%20only%20worked%20for%20some%20users.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1083616%22%20slang%3D%22en-US%22%3ERe%3A%20User%20Photos%20not%20updating%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1083616%22%20slang%3D%22en-US%22%3EPhotos%20are%20cached%20locally%20for%20installed%20version%20of%20teams%2C%20and%20don't%20update%20properly.%20Users%20can%20manually%20clear%20their%20Teams%20cache%20for%20the%20photos%20to%20update.%3CBR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Fsocial.technet.microsoft.com%2FForums%2Fen-US%2Ff9e1c12b-47a6-4b12-8d5c-a57fda4d9042%2Fwhat-folders-are-used-by-teams-for-caching%3Fforum%3Dmsteams%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fsocial.technet.microsoft.com%2FForums%2Fen-US%2Ff9e1c12b-47a6-4b12-8d5c-a57fda4d9042%2Fwhat-folders-are-used-by-teams-for-caching%3Fforum%3Dmsteams%3C%2FA%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1283512%22%20slang%3D%22en-US%22%3ERe%3A%20User%20Photos%20not%20updating%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1283512%22%20slang%3D%22en-US%22%3E%3CP%3EOther%20users%20can%20see%20the%20update%20profile%20pic%20once%20they%20sign%20out%20and%20sign%20back%20in.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1403105%22%20slang%3D%22en-US%22%3ERe%3A%20User%20Photos%20not%20updating%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1403105%22%20slang%3D%22en-US%22%3E%3CP%3EI%20turned%20on%20multifactor%20authentication%20and%20now%20I%20am%20having%20this%20issue.%20I%20can%20see%20other%20user%20photos%20and%20team%2Fgroup%20photos%20on%20the%20Teams%20web%20app%2C%20but%20on%20Teams%20desktop%20users%20just%20have%20a%20grey%20photo.%20I%20have%20tried%20logging%20out%2C%20uninstalling%2C%20clearing%20cache%2C%20removing%20my%20work%20account.%20All%20to%20no%20avail.%20I%20even%20turned%20multifactor%20off%20again%20and%20I'm%20still%20having%20this%20issue.%26nbsp%3B%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-center%22%20image-alt%3D%22Capture2.PNG%22%20style%3D%22width%3A%20103px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F193090iD606BFCCA18D96C9%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20title%3D%22Capture2.PNG%22%20alt%3D%22Capture2.PNG%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1425467%22%20slang%3D%22en-US%22%3ERe%3A%20User%20Photos%20not%20updating%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1425467%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F406171%22%20target%3D%22_blank%22%3E%40JWhiteFEI%3C%2FA%3E%26nbsp%3BI%20am%20having%20the%20same%20issue.%26nbsp%3B%20All%20app%20and%20all%20web%20app%20are%20showing%20photos%20except%20MS%20Teams%20desktop%20app%2064%20bit.%26nbsp%3B%20Could%20it%20be%2064%20bit%3F%26nbsp%3B%20The%20pictures%20of%20unknown%20people%20should%20at%20least%20have%20people's%20initials%2C%20not%20a%20silhouette%20of%20the%20blank%20person.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1425667%22%20slang%3D%22en-US%22%3ERe%3A%20User%20Photos%20not%20updating%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1425667%22%20slang%3D%22en-US%22%3EThank%20you!%20I%20haven%E2%80%99t%20seen%20this%20problem%20specifically%20for%20teams%20desktop%20app%20mentioned%20by%20anyone%20else.%3CBR%20%2F%3E%3CBR%20%2F%3EI%20mean%2C%20all%20of%20my%20other%20office%20desktop%20apps%20are%2064bit%20and%20those%20work%2C%20it%E2%80%99s%20just%20Teams.%20Do%20you%20use%20multi%20factor%20authentication%20on%20your%20account%3F%20It%20may%20not%20be%20related%2C%20but%20I%20noticed%20this%20issue%20began%20after%20enabling%20it%20on%20my%20account.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1426720%22%20slang%3D%22en-US%22%3ERe%3A%20User%20Photos%20not%20updating%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1426720%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F406171%22%20target%3D%22_blank%22%3E%40JWhiteFEI%3C%2FA%3E%26nbsp%3BAll%20people%20in%20my%20organization%20have%20MFA%20enabled.%26nbsp%3B%20From%20all%20others%20Teams%20desktop%20apps%20that%20I%20have%20seen%2C%20I%20am%20the%20only%20one%20experiencing%20the%20%22picture%20or%20initials%20is%20not%20loading%20on%20any%20user%20except%20mine%20and%20only%20showing%20a%20silhouette%22%20problem.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1427077%22%20slang%3D%22en-US%22%3ERe%3A%20User%20Photos%20not%20updating%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1427077%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F630774%22%20target%3D%22_blank%22%3E%40dkoziupa-sas%3C%2FA%3E%26nbsp%3BOk%2C%20it%20may%20be%20a%20standalone%20issue%20with%20MS%20Teams%20then.%20Although%20I%20am%20having%20another%20issue%20with%20my%20account%20where%20I%20can't%20access%20Outlook%20Web%20App.%20I%20continually%20get%20an%20error%2C%20%22Repeating%20Redirects%20Detected%22.%26nbsp%3B%3CBR%20%2F%3EI%20am%20also%20global%20admin%2C%20and%20cannot%20access%20the%20exchange%20admin%20either%2C%20getting%20the%20same%20error.%20Have%20you%20experienced%20either%20of%20those%20errors%20by%20chance%3F%3C%2FP%3E%3CP%3EAgain%2C%20I%20don't%20know%20if%20these%20issues%20are%20connected%20to%20the%20Teams%20one%2C%20just%20trying%20to%20cross%20reference%20to%20narrow%20it%20down%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1453719%22%20slang%3D%22en-US%22%3ERe%3A%20User%20Photos%20not%20updating%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1453719%22%20slang%3D%22en-US%22%3E%3CP%3EThis%20worked%20for%20me!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1502654%22%20slang%3D%22en-US%22%3ERe%3A%20User%20Photos%20not%20updating%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1502654%22%20slang%3D%22en-US%22%3EI%20faced%20the%20same%20problem%20on%20my%20PC%20and%20actually%20found%20one%20solution%20for%20that.%3CBR%20%2F%3EJust%20SIGN%20OUT%20and%20sign%20in%20to%20the%20application.%20It%20worked%20for%20me%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1774257%22%20slang%3D%22en-US%22%3ERe%3A%20User%20Photos%20not%20updating%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1774257%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F406171%22%20target%3D%22_blank%22%3E%40JWhiteFEI%3C%2FA%3E%26nbsp%3B-%20just%20in%20case%20others%20face%20the%20same%20problem%3A%3CBR%20%2F%3EIn%20my%20case%20it%20helped%20that%20after%20first%20installation%20of%20teams%20i%20clicked%20%22%3CSTRONG%3Echeck%20for%20updates%3C%2FSTRONG%3E%22%20-%20after%20Activating%20the%20updates%20Teams%20was%20restartet%20and%20all%20pictures%20where%20shown%20as%20expected%20%3B)%3C%2Fimg%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Deleted
Not applicable

Hi all, I'm having users update their photos and they aren't showing up for other users, they are propgating throughout 365 but Teams still doesn't show them. I opened up my Teams client on a laptop I haven't used in a bit and it updated the photos. 

 

Does anyone know how long it takes Teams to update these photos? Obviously it's cached somewhere, and curious to what that pulls from, what the timer is and can you manually tell Teams to refresh this photo cache? 

 

Thanks!

22 Replies
Highlighted

@dkoziupa-sas Ok, it may be a standalone issue with MS Teams then. Although I am having another issue with my account where I can't access Outlook Web App. I continually get an error, "Repeating Redirects Detected". 
I am also global admin, and cannot access the exchange admin either, getting the same error. Have you experienced either of those errors by chance?

Again, I don't know if these issues are connected to the Teams one, just trying to cross reference to narrow it down

Highlighted
I faced the same problem on my PC and actually found one solution for that.
Just SIGN OUT and sign in to the application. It worked for me
Highlighted

@JWhiteFEI - just in case others face the same problem:
In my case it helped that after first installation of teams i clicked "check for updates" - after Activating the updates Teams was restartet and all pictures where shown as expected ;)