User can't get Teams to work - error message

Copper Contributor

Have a user in a business environment in Peer to peer, getting the following error:
microsoft teams won't allow the user to sign in, getting error code caa70004


Teams is currently the free version, so finding support for this is next to impossible.   The app just wants to Restart, and goes no where but the error code.   Local users, not on O365, but the users account can log in on

Any help would be appreciated.   And no, have not just done the uninstall/re-install, yet.



31 Replies
10x man u solve my problem

Thank you - this has helped to finally resolve it for me. I had both TLS 1.1 and 1.2 checked and had to check 1.3 (experimental) to get it working. I could see in the Teams folder that the IndexedDB and some other folders that were not created previously were now being created.

This issue has long been completed.   


Complete re-install of teams likely using the fix-it utility from Microsoft repaired the issue.

Since then we have gone to the full Office 365/Microsoft 365, just makes it better.



Remove User Windows Credentials in Control Panel Credential Manager

Uninstall Teams

Delete   'C:\Users\username\AppData\Roaming\Teams' folder


Reinstall Teams

Sorry, this issue has long been fixed.   Re-installed and upgraded to the paid version with Microsoft 365.  No issues since, and Teams only just keeps getting better.

@DHuttema None of this worked for me.  i've done it all.  what did work:

1.  open IE

2.  Go to IE Options

3.  Click advanced

4.  click reset...

5.  scroll down to:  Use TLS 1.3 (experimental)  and check the box.  

click OK


log back into teams with 100% success.  



I tried so many different methods and turning my Avast firewall off was the only thing that worked. Thank you!

@Rhys Allen 

Thanks for your share. It save me too.

Very appreciate.

The Microsoft Teams desktop app automatically updates whenever a new version gets released. You can check your current version here:

Click the menu next to your profile picture at the top right of Teams
Hover on About
Select Version

You can also check if there are any available updates instead:

Click the menu next to your profile picture
Select Check for updates
Microsoft Teams will check if there are any updates. It should automatically update your Teams while you use the app

This May Work,

I spent a few hours trying to fix this issue on business 365 account. Teams just stopped working on a single computer with the error caa70004.  All other 365 Apps worked fine. 


I tried re-installing, tried clearing the cache multiple times, attempted multiple suggested solutions.


This was on a Windows 11 Pro machine with everything up to date. 


Finally gave enabling TLS 1.1 and TLS 1.2 in Internet Options. 


That seemed to solve everything.  Signed in without any issues after that. 

Thought I'd update in case anyone else is loosing their mind trying to get this to work :) 

Also, not Teams related but at the same time had another user that was having trouble signing into Outlook desktop application. Just stopped working in the middle of the day. He was getting error 0x80004005 (unable to sign in)

After trying everything, I suggested he'd try to enable TLS 1.1 and TLS 1.2 in Internet Options. Figured if it fixed issues with signing into Teams, it might also fix issues with signing into Outlook.

He enabled TLS 1.1 and TLS 1.2 and Outlook immediately started working again.