User can't access guest accounts in Teams after configuring MFA

Super Contributor

Hello Teams Community,

 

Please i need your help on this

 

After configuring MFA user had problems with Teams status not showing and OneDrive not working properly. I suggested removing cache from office folders, removing saved logins from the credential manager, and so on, which removed said problems.

 

Unfortunately, later user discovered, that he cannot access guest organizations on his Teams desktop app, in broswer or even in incognito browser mode.

 

When trying to switch there is displayed what I attatched here: 

 

IBN_0-1650452616281.png

 

It says in loose translation "we are sorry, but problem occured. Restart. If it wont help, then log out and log in". User still doesnt have access after loggin out and in.

 

 

Then I got response from a user that I attatched as 

IBN_1-1650452831463.png

 

where I added my comments explaining some terminology, and added a error which user was talking about with my translation.

 

After this I re-required MFA registeration in Azure AD, but it still didn't fix the problem. This is the message I got from a user as shown below:

 

IBN_2-1650452948288.png

 

 

 

 

IBN_3-1650453012278.pngIBN_4-1650453095950.png

 

IBN_5-1650453176070.png

 

I then asked if user tried to authenticate using other ways, than just accepting in app, and user told us that he tried SMS code, but still couldnt access.

 

 

 

1 Reply

@IBN 

 

Since the community has not yet responded to your post, you might want to seek assistance with other resources that are focused on tech support:

 

  • Ask your IT manager to open a support case or call Microsoft using the support line you were given.  Other options for business subscription admins are listed here:

Get support | Microsoft Docs

https://support.serviceshub.microsoft.com/supportforbusiness/create