USB plug of the "Logitech Group" will cause Teams to freeze on macOS Catalina


Hi peeps,


I'm going through a weird issue on macOS Catalina. People in my business use teams to collaborate and attend meetings with their Windows and macOS laptop in a conference room (Big TV and sound system). There is a microphone and speaker accessible from a usb cable. The issue is that as soon anyone connect that logitech system to their Mac it will complete freeze Microsoft Teams. The way to escape ? Force quit the app. The Mac will still work properly even if Teams completly unresponsive. 


Reading on forums I see that people where having that kind of troubles on macOS Catalina beta but I can't believe macOS users are still stuck with that similar issue. 


Privacy access to cameras, microphones and screen sharing are not the issue on that case.


Thanks !


UPDATE : Freeze will occur each time I plug in our "Logitech Group". Seems to be working fine if customer wait 1 min and 34 sec before being able to use Teams again. it's always 1min34sec for it to work. 

19 Replies


Hi, we have the same issue for about two month now. Here you can read a bit more. What we know so far: 

have same issue have tried across multiple Mac devices (laptops/newer/older hardware). Teams is now worthless with Logitech camera's on Catalina. The only solution we are finding is downgrade the OS. We are NOT seeing any response now matter how long we've waited (tried waiting 30 minutes teams remains frozen). @fsauve 

@fsauve  We are experiencing the same issues

@magnusjenssen et al.

Same error here also, even with High Sierra and Mojave. We had a meeting with Microsoft support yesterday. They know about the issue. However they are not focusing on it. Instead they are focusing on the way Teams autoupdates for Mac. When this is solved we will be able to downgrade to a working version as a workaround. We will therefore not be able to take advantage of the new features or security updates in the latest version. On this page Microsoft states that Logitech Group is a certified product for Teams

I asked Microsoft to post an official statement. Hopefully we will se that soon.





This also happening on a sennheiser bluetooth dongle i was using.


same here! I created a MS UserVoice bug report, maybe upvoting helps:


We are also experiencing this challenge when connecting our Macbooks to Logitech Meetup and Rally.

Teams version:

MacOS: 10.15.3

Sad we have to create a UserVoice in order to get our certified devices working. Microsoft - please address this issue asap.

@fsauveI think I found a sloution or Workaround. The Logitech Group provides a bluetooth function use it !

I think the issue occurs only with the cable because it's a Catalina Issue but when you connect your MacBook over bluetooth with your Logitech Group then MS Teams works without the freezing issue. I tried it and the bluetooth function is reliable and it works :)


Check it out. I hope my answer was useful :)

And for the camera? Learn 2800 users to use bluetooth instead of plugging in USB is not an option for us. @MsN_2001 

@Ulf Lundqvist 

The camera is connected with the Logi Group and the camera works as well. When you are connected over bluetooth with your Logi Group all devices --> (Camera, Speakers --> Logi Group) works.

Okei, yeah that is the only workaround which is working at the moment and my opinion is that working over bluetooth is a good solution but that is my opinion.

Hi, you could also downgrade to a older version. Then it will work until it autoupdates. You could also use the webclient i Chrome. Then it also works. But it would be nice to see a real solution coming. Here you can download a older version:

Hi, We are having same issue here with MacOS Catalina and Logitech Meetup. Could we get a fix please ? 


@MsN_2001 How did you get the camera to work? Microphone and speaker works well over bluetooth, but I only have my FaceTime Camera available.



Hi all,

Just use the online version of teams until this get fixed. You can even supply users a direct URL to teams, they might just need to click 'Use web app'.

I just tested with my logitech device. Microphone, Speaker and Camera. And it WORKS great!

Yes you have the use the browser (Chrome, Safari won't work), but that's is fine for now until they fix the issue. I see no performance issues.

Have a nice day


Tried this and it still doesn't work.  Also tried to download the Logitech Broadcaster App to use a wi fi webcam and that is also blocked by Catalina.  

Hi everyone, 

We are still having this issue. I saw on some other forums that it might be fixed for some people, so just wanted to say that it is definitely not fixed for us. 

The only difference is that we are using Logitech cc3000e, so a product older than Logitech Group, but basically the same thing. 

I can confirm that version works, but that is not really a solution, since it will update itself. The latest version hangs for about 2 minutes when starting the application. 



Things are worse for me. Teams freezes with my Sennheiser MB 660 bluetooth dongle. I got around it by waiting a few minutes and then all was good. Not anymore. It never unfreezes. I have installed a catalina update. I may have to uninstall and reinstall Teams. This is kind of pathetic that this is not fixed yet. When I unplug the dongle, Teams comes back to life in 2 seconds. 


One workaround is to use Teams via a browser. It works there even with my dongle plugged in.