Update breaks Teams for Linux

Copper Contributor

I'm on Fedora 33 latest patches and I recently got the 1.4 Teams update.  It completely broke my ability to join calls somehow.  Anybody else have this issue?  A simple rollback to 1.3 fully restored functionality.  Whenever I click a meeting link in 1.4 Teams says "unable to join this call."  Strangely after update Teams asked me to sign in like I'd never used it before - yet it shows all prior chat history.




$  sudo dnf list --showduplicates teams
Last metadata expiration check: 0:00:10 ago on Wed 10 Mar 2021 03:12:51 PM GMT.
Installed Packages
teams.x86_64                                                                      @teams
Available Packages
teams.x86_64                                                                      teams 
teams.x86_64                                                                        teams 
teams.x86_64                                                                       teams 
teams.x86_64                                                                      teams 
teams.x86_64                                                                      teams 
teams.x86_64                                                                      teams 
teams.x86_64                                                                       teams 





8 Replies

Hi, I am seeing the same problem on Debian testing.

I can join calls in the organisation my account is associated with but joining other meetings via a link from an invitation does not work. I do not even get an error message.


I tried the following 2 scenarios:

When I click a link and Teams is not opened, it will be opened, I can log in and choose my organisation and then I just get to the teams in that organisation, not to the call.

When I click the link with Teams already running, it comes to the foreground and nothing happens.


Downgrading to makes calls via links work again.


This issue https://techcommunity.microsoft.com/t5/microsoft-teams/problem-with-joining-a-meeting-with-microsoft... might be similar.


Please let me know if and how I can gather more information on this issue.




Im also having the same problem on Ubuntu 18.04-5 LTS and Teams
I couldn't join meetings.
I had to revert back to the previous version using

sudo apt install teams=

 and it worked again.

I have the same problem here. My workaround has been to revert back to the earlier version. I'm on a Ubuntu 20.04 LTS machine.
The problem has been fixed with version, which is currently available as Teams Insiders. I've not done any further tests so far, but at least I can open meetings again.

Hello, @abuesching Hi , I've got the same version as you.
How could register? What is your Linux version?
I'm personnally with Debian.
May you look at :
If you'v got the time.
Thank's in advance.



I am running Ubuntu 20.04 (fully updated as of 04-23-2022), and have Microsoft Teams (v. (64-bit).  It's honestly running well.  Granted, it's NOWHERE NEAR as advanced in features as the Windows version, but at least it works.  I'm hoping that upgrading to Ubuntu 22.04 later this year will allow Microsoft to update Teams on Linux so that it functions more like its Windows brother does.