Unable to select microphone or speaker device in Microsoft Teams (Windows 10)

New Contributor

Microsoft Teams is currently unable to make/receive calls due to the app being unable to set a Microphone or speaker device. 
The 'Audio Devices' profile within settings is set to 'Custom Setup' and no other option is available in the drop down (screenshot attached). 
When try to continue using the custom setup, no devices are available as the drop-downs are unclickable (screenshot attached). 


Other useful info: 

  • OS: Windows 10 - latest
  • Microsoft Teams Version: (64 bit). It was last updated on 22/09/2019.
  • I have uninstalled and re-installed teams. 
  • Audio devices work fine in all other applications
  • No other application is using the devices when Teams is being tested. 
11 Replies
Click start in windows and search for microphone. Should be something along mic access or something. Make sure this is turned on so apps can access your mic. I’m not at PC or I would get settings but sometimes this not being enabled will not allow device access to the mic drivers.

@Chris Webb - Checked that location - It is set to allow access. 

Make sure you scroll down that page, at the bottom is an actual section for allow desktop apps access. Make sure it's own and Teams is allowed.

@Chris Webb  - Checked both lists - Its got access. 
It also has a time/date when it was last accessed. It appears to all start working about 20mins after the application is launched, but each time the application is started, it doesn't allow me to select any devices (Microphone or Speaker). 
No settings are changed in those 20mins and the PC itself is left pretty much idle. 
I have now been able to replicate this behaviour 3 times. 
Each time the application is booted, we see the behaviour shared in the previous screen shots. About 20mins later, the dropdown menus are usable and the devices work without issue. 

Odd.... Assuming you've signed out and signed back into Teams (Not quit and start). This clears the cache. Doubt it's related, but I've seen it fix some weird stuff.
Also are you running Skype for Business alongside Teams in Islands or anything? Try Closing out the Skype client if it's still running and see if it has any effect if so. I've seen Skype have effect on Teams devices.

@Chris Webb - Not running skype or any other application that could use the microphone/speaker whilst running teams. 
I have tried logging out and back in. No joy unfortunately. 

Its a really strange issue and I've tried everything I can think of. :( 

At this point has to be drivers I would think.

@Chris Webb 

I had this same thing happen today - all of a sudden and once I turned on every possible thing in my Windows 10 microphone setting - it all worked. I will turn off other items once I get through my meetings today. No device AT ALL would connect to Teams.


What worked for me on Windows 10 was to go to the Sound Mixer Options (which seems to also be called (App Volume device preferences). This lists apps with the volume,  Output and Input Devices. Toggling the Output device from default to the specific option for my headset got this working again in the Teams app.

Hi, I got the same issue. Tried everything reinstallation delete local settings, ...
At the end following solved the issue:
1 right-click start menu
2 select device manager
3 click Sound
4 delete all sound devices
5 Click Bluetooth
6 Delete all audio devices
7 click scan for new hardware devices icon at the toolbar
8 Restart PC
Restart Teams and check the audio device in teams it should be solved
Related Conversations
Teams analytics
ThomasSteibl in Microsoft Teams on
0 Replies
Some useful resources
Tony Phillips in Microsoft Teams for Education on
0 Replies
Still can't access calendar in Teams.
BartBr_PPCI in Microsoft Teams on
1 Replies
Which comes first, Teams or SharePoint?
JVandy in Microsoft Teams on
2 Replies