Unable to remove old account sing up form Teams on Mac OS

Copper Contributor

I cannot remove an old sing account from Teams on Mac OS. I have to delete the keychain, I delete the temp folder, and remove and reinstall Teams, and the old account is still there. I have a case open with the Microsoft team, and they cannot figure it out. Where is the login info store, and why has Microsoft not provided a solution where users can remove accounts as easily as they can add? Please help! 


Screenshot 2023-01-13 at 17.13.57.png

28 Replies

Can you check if you can delete the information from the below steps:

1. Uninstall Microsoft Teams (Go to Applications -> Microsoft Teams -> Command+Delete -- when asked, enter MAC password)
2. Browse to ~/Library/Application Support/Microsoft/ (Terminal -- cd ~/Library/"Application Support"/Microsoft/)
3. Delete Entire "Teams" folder (sudo rm -rf Teams)
4. Install Microsoft Teams
5. Open Teams. Use as usual, as this would either let you chose an existing account and follow process or will prompt to enter your desired account to chose)

With Regards,
Satish U
Thank you for the suggestion, I have tried, and is not working. This is a major bug for MS Teams for MacOS. I should be able with out any technical knowledge to remove any user id that I wish from MS Teams.

@Jovan_S I'm having the same issue....  With an old employer account


@JP Nacif Drah 

Same here. I have not seen any good solution for this issue. I just read somewhere to remove the full Office suite from macOS and install it once again - there was a dedicated Python script for that. It would be good to get some confirmation. 

@RealTime_M365 I have tried that and NOT WORKING! 

I have a ticket open with MS team, and THEY do not even know how to fix. I have a script to use, but I am not an IT person and do not know how to use it.... why is this so hard?

@Crunchie I did uninstall all of office365, deleted everything Microsoft related from my Mac (including folders, etc), then went to Keychain and removed everything from there, I run a script to clean the cache, and then reinstalled Teams. It worked for a hot minute and then my old work accounts came back.   Clearly there is something staying in the computer...  Or maybe it syncs with other Apple devices?  Maybe we have to remove everything from every device and then reinstall?

i have an odd feeling I have to comply and reformat the hard drive .... this is not optimal at all
I have the same feeling, and I plan to do it during my holidays time.
So I also have this problem, on a *brand new Mac*!!! So the issues is clearly at MS´ servers, not the local device. And yes, I've tried the solutions listed below.
The issue is happening for me on an installation on a brand new device, so it's clearly nothing to do with things in buried folders. The problem is clearly in Microsofts servers.

More over, it won't even allow me to join meetings, because it goes into some god awful login doom loop, then MS servers kill the connection after too many attempts.

Typical MS junk.

@ikd1000 I am getting the same issue - the doom loop is a good descriptor - I can join teams meetings about half the time - cannot find a way to remove the old accounts - and I do not want to risk uninstalling all office products at this point.  Suggestions?  MacBook Pro running Ventura 13.4.1

Same here, cant remove older accounts

In Keychain search "microsoft" instead of "teams" and remove any "application password" type files starting with com.microsoft.oneauth.*

This is what finally fixed it for me.

Thank you for the suggestion,  and sadly it does not work at all. I (we the MS engen) have tried it all and no one can find out what is going on.  At one point they said there are hidden files that drive the log in but where are there ! 

@Jovan_S Doing specifically what I said has now worked for removing the existing logins on over 10 devices here. 


I tried following steps without any success [successful one shared at the end of the post]
- quitting the app and uninstalling it
- then deleting the cache from ~/Library/Application Support/Microsoft/
- deleting all the keys from Key Chain Access that came as a part of teams keyword search
- re-installing the app
It didn't work.


This worked

- did all the above steps

- search Microsoft keyword in the key Chain Access

- delete the keys that has com.microsoft.oneauth and com.microsoft.adalcache

Screenshot 2023-08-23 at 2.05.32 pm.pngScreenshot 2023-08-23 at 2.07.14 pm.png

This will remove the existing accounts at the startup.


Hope this helps.

Thank you so much! Deleting Application Support files in both User and System Library + removing keys from Keychain Access worked for me.

@Anit_Kumar THAT worked for me, thank you very much!