Unable to Get Link for MS Teams directly, getting SharePoint instead

Copper Contributor

Hey Everyone!

For the past couple of weeks, I have been using the 'Get Link' feature in MS Teams to directly share the link to my peers so that they can directly access the link from Teams without having to go to another external page.

But recently, since yesterday as I was checking, I am getting only the option to copy the Sharepoint link (attached). Earlier, I had the option to either copy the link from MS Teams or from Sharepoint. But now, I am only getting the option to copy from Sharepoint.

Now, every time someone would try to click on the link, they are getting redirected to a webpage instead of being redirected within Teams.

Is there any way this issue can be resolved?

28 Replies
Microsoft is going to change the way to share a link to files in Teams, so it this problem could be a hiccup in the rollout of the new sharing link feature

@cr2007  We have the same issue, was this option taken away and why? 

Me ocurre lo mismo. Es verdaderamente incómodo. Espero que lo corrijan pronto.

@Rorsini @alvaromartinez 

I had tried in the MS Community, here's a link for the same.

I'll bring up this to him, that other users are facing the same issue too.

@cr2007 Our tenant is having this issue as well.  Do we know if this is a bug or intentional?


I agree with Juan Carlos. When a Team is created (in Teams) a SharePoint site is automatically created. This becomes the repository for everything related to the Team. This is to include videos in the near future (recorded meetings in a Team will be stored on the Team SharePoint site; meetings recorded in Chat will be stored in OneDrive).


I believe a SharePoint site was always created for a Team, so if the link looks different, it may be that it was always going to SharePoint.



True, but earlier, we had an option for either taking a Teams link, or a SharePoint one. (as attached from an image found online before that feature vanished)

Even though the file was originally stored in SharePoint.

Now, we're not given the initial option. which doesn't help
If I were to link it to a message I put within Teams, it should take me to the document within the app instead of redirecting me to an external page (which sort of ruins the idea in the first place)

I had put this in another Microsoft Forum ( from where I got this answer:


I would advise you to check with your team and see everyone experiencing the same behaviour, if so please contact your IT administrator and make sure that there has not been any recent change to Organization external sharing policy.

If this issue has impacted your tenant then IT administrator can open a case with dedicated Microsoft team to look further in this:

Here is the link to that discussion:



I understand what you are saying. You have files in a Teams group that contains files. You want to send a link to that file to another Team member and have that file open in Teams, NOT SharePoint.

Here is my Test:

  1. Opened a Team where I am a Owner.
  2. Went to a channel and clicked on Files.
  3. Right clicked on a file and 'Copy link'.
  4. Opened a Teams Chat with a test account.
  5. Posted the link I copied into a conversation.
  6. Opened the link from the Chat
    1. File opened in Teams.
  7. Sent the copied link to different account via Outlook email.
    1. Clicked the received link 
    2. File opened in SharePoint

Don't know how you are sharing links, or if you are sharing links with members of the Team that the file came from, but it seems that if the link is shared within Teams, the file opens in Teams. Using the link externally causes the file to open in SharePoint.

I did steps 1-4 (Step 4 I put it in a hyperlink in a Teams message also)

4. Posted the link in the chat

5. I click on the link (in Teams)
6. A new window opens on my browser, opening that file there instead of opening it within Teams


I get the same outcome as you mentioned in Step 7.



Ahhhhh. I did this test in the desktop version of Teams (Microsoft Teams Version, and it sounds like you are using the browser version of Teams.


Is this the case?


Only Desktop (Version (64 bit) )
I also tried the web version initially to see if it was only an issue with the Desktop App.
Turns out it was an issue in both.


Then I don't know what to say. Please see the png attached to this comment.

When I clicked on the link you see in the attached png, the document opened in Teams.


When all else fails, Quit Teams (if you are on a Windows computer, right click the icon in the taskbar and select Quit - if you are on a Mac, click on 'Microsoft Teams' in the menu bar and select 'Quit Microsoft Teams' from the dropdown menu). Then restart. See if the problem replicates.


If it does, you may need to open a ticket with MS Support.


All these methods are done and tested (Right-Click+Quit, Checking for updates, putting a request to my IT Admin, UNinstalling and reinstalling the app, but to no avail.

I have put a ticket to the MS Community ( Here is a link to the same:

Anyways, thanks


Sorry I couldn't be of more help.


Please let me know if this issue gets resolved.




@cr2007I guess this is in line with the vision of making the same experience for users across the platform, all the comments and tests are great but the final point is this is up to the new update/release that Teams/Sharepoint options should be the same.


that is why previously you had the option to share the link as Teams or SharePoint but now it is by default Sharepoint as if you are sharing from Sharepoint the link will be for Sharepoint so the same will be experienced on Team if you share the link/file it will be from Sharepoint only as the files are in that Repository of the SharePoint.

best response confirmed by ThereseSolimeno (Microsoft)

Alright so I checked MS Teams today
And it has been resolved
I am able to see the Teams link too

It has been solved
Probably you may need to check with your IT Administrators.


would you please post a screenshot of the Teams link that you are seeing?

All my links in Teams are SharePoint links






This is what I get when I use the Get Link feature


Yep....I get this option in a Teams group the link options range from a Microsoft Teams to a OneDrive to a SharePoint, depending on the file.


Files I share from my computer (which are backed up to my business OneDrive) will show a OneDrive only link option.

Files that originated as a screenshot and have been shared with me will show a SharePoint only link.

Files that are uploaded to Teams show a Microsoft Teams link as well as a SharePoint link.


Thank you for bringing this up and I am very glad that it has been resolved.