Unable to Auto Login on Microsoft Teams Room devices ?

Copper Contributor


We recently joined our Microsoft teams rooms device to Azure AD and upgraded OS from Win10 1903 to Win 10 20H2 (automatic updates). We are not pushing any policies on this device either through SCCM or Intune but after Azure AD joined and system upgrade when the device is rebooted it did not auto login with default Skype user account, its getting stuck on login screen and waiting for user to hit enter. This is big issue now as end users need to hit enter manually to get teams rooms app launch.


I tried to set AutoLogon registry also (which it was not present earlier) but still no luck

AutoAdminLogon = 1 (REG_DWORD)

DefaultDomainName = blank (REG_String)

DefaultUserName = Skype (REG_String)


Has anyone experienced this before ? Please advice.




6 Replies
Here’s how to reset the auto login. Was this the same location where you set it? https://www.thegrahamwalsh.com/microsoft-teams-room-auto-logon-issues/
Thanks for your reply and sorry for delay in my response. Yes we followed your blog only to create registry keys, even we compared rest of the keys also with our device but no luck, its still stuck on login screen. Right now as a temporary solution we had to create one pager on how to get teams screen if stuck on login screen for end users and pasted in all our conference rooms.



By chance do you use McAfee/Trellix encryption or any other encryption on these devices?


We had a similar issue and were able to resolve it with the info here: https://communitym.trellix.com/t5/Encryption-PC-and-Mac/Autologin-not-working-with-autoboot-devices/...


The fix specifically was to either rename or delete the entries for the Credential Provider that was interfering with Winlogon from the paths below.


HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Authentication\Credential Providers\

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Authentication\Credential Provider Filters\


More info on why this happens: https://learn.microsoft.com/en-us/windows/win32/api/credentialprovider/nf-credentialprovider-icreden...


In Windows 10, if a credential provider wants to automatically log the user on in a situation Windows does not think is appropriate, the system will display a sign in button as a speed bump. One example of this is when a user with an empty password locks the computer or signs out. In that scenario, Windows does not directly log the user back in.

Also had this behaviour. After AAD login, AutoAdminLogon was still set correctly to 1. But from my experience, the MTR tries to login to AAD with "Skype" as username what fails due to it is only a local account.
Changing DefaultUserName (HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon) from "Skype" to ".\skype" repaired it. Adding ".\" switches authentication back to the local device.
I ran into the same issue, but mine is even worse. With mine I am not able to sign into the device as a admin, the abiilty to change to the admin account from the skype user is not there anymore.
More Detail:
When going to the teams room setting menu, which I have to type in the Admin account to access( so the admin account exist), I then click windows settings and am only allowed to sign back into the skype user. There is no option for me to sign in with another account. I just opened a ticket with MS.

Hi @Christopher Holschuh 

Have you already received a solution?

I have the problem that the Skype user cannot log in correctly. After logging in, the device always restarts. It is also no longer possible to change the user.