Unable to access files in a new Team

Not applicable

24hrs after creating a new Team, I am no longer able to view/access Files (see error below), although I can still get to the files on the SharePoint site.


Does anyone know why/how this happened, and is there a way to fix this, or do I need to recreate the Team?    Thank you!


17 Replies

We noticed that a file access issue occurs when the team name contains a single quote (' ).


Renaming the group does not work. You must recreate.


We have other file access issues but the proposed solution should work for you.


I hope this will help.


Update : 

We also notice that, in certain condition, files only avaible for Office 365 administrators. For now, we don't have any clues for this problem. We hope Microsoft fix this bugs.

I have this same issue and I believe it's because I renamed a channel and then renamed the Sharepoint folder that contains the files to match.  At that point it seems to have lost the connection to the Sharepoint location of the files.


Any help in resolving this is much apprecaited as I don't want to delete this channel!!

best response confirmed by adam deltinger (MVP)

For anyone still facing this issue, go to the teams members tab and change the user permission to OWNER and then back the MEMBER.


This solved the problem for me. Not an ideal solution but at-least it worked.

@arshish-maneckji Thanks.


I observed the same behaviour here. Your workaround solved the issue. 

This issue is repeatable.


@arshish-maneckji thank you so much for this! it solved my issue. 

Hi ,

i have created a new group in teams a few days before but cant share any attachments keeps showing "we are setting up your files check back in few minutes.

i tried changing members as owners but no joy 




clicking on files option shows "we cant get your files , we are working on getting them back 

please suggest a solution for this as many users reported this error on the community

@arshish-maneckji worked like a charm! This should be marked as the solution. 


Hi arshish, I have a lot of teams, should I go thru all of them?

thanks for a quick answer.

I can't access files in the general tab. My classmates can but I cant see the files. I also am unable to change user permissions as I didn't create the team. Do you have any solutions?

I had the same issue but with a private channel

here is the procedure for fixing the issue


1. Go to your Teams admin center

2. Go to Teams TAB then "Manage Team"

3. Select your Team (Or Channel) and click on edit

4. Rename it (check if there is no space after the name or special character)

5. Save

My problem was a "space" added at the end of the name of my channel.


I know this is old but for anyone currently having this problem go to the top right click the ellipsis and got to open in SharePoint for the channel you are having issues with.

You should be able to send a request for permission from there as it will get denied and come up with this option.

Not sure if it work for everyone but it has worked for some of my teammates.

@Abdelkarim1426 Hi,

in my case I´ve renamed the O365 Backend URL and that caused the problem with the files Tab.

It seems that following reasons can youse the problem:

- renaming the Backend (solution, rename once again)

- renaming Channels (solution, rename once again)

- special Characters in URL or Channels (solution, rename)


Hope it works



@arshish-maneckji We just tried this, and seemed to have given me only access to the Files tab, but not the contents: meaning that I can see what's in the Files-tab(or directory), but could not open the files, or download the files. I also was not able to upload files in the group: either in chat box or to Files-tab. --- seems there are some glitches in granting access to the members in the group. We will be working on this again with our IT tomorrow, will update with any progress we made. 



Sorry I meant we tried: change member->owner->member approach.

@LW20200423Have you tried opening in SharePoint and check the Team Owners and/or Members have editing enable on the Chanel folder.

@arshish-maneckji Your solution worked well for us today. We observe also our channel name contained an underscore, which lends some credibility to Anonymous above re: single quote in channel name.