Trouble editing shared documents

%3CLINGO-SUB%20id%3D%22lingo-sub-1635849%22%20slang%3D%22en-US%22%3ETrouble%20editing%20shared%20documents%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1635849%22%20slang%3D%22en-US%22%3E%3CP%3EI%20used%20Teams%20at%20my%20last%20job%20and%20we%20had%20no%20issues%20sharing%20documents%20that%20were%20uploaded%20into%20a%20team%20as%20long%20as%20the%20user%20did%20their%20editing%20after%20clicking%20%22Open%20in%20Desktop%20App%22.%26nbsp%3B%20At%20my%20new%20place%2C%20we%20are%20having%20all%20kinds%20of%20issues%20with%20saving%20documents%20and%20getting%20errors%20about%20saving.%26nbsp%3B%20We%20use%20SharePoint%20here%20where%20at%20my%20old%20place%20everything%20was%20stored%20on%20OneDrive.%26nbsp%3B%20Some%20of%20the%20errors%20are%20related%20to%20saving%20a%20new%20copy%2C%20which%20should%20never%20have%20to%20be%20done.%26nbsp%3B%20I've%20attached%20an%20error%20about%20the%20document%20%22...not%20been%20uploaded%20to%20the%20server.%26nbsp%3B%20Do%20you%20want%20to%20close%20this%20file%3F%22%26nbsp%3B%20It's%20on%20AutoSave.%26nbsp%3B%20Is%20this%20just%20a%20time%20lag%20issue%3F%26nbsp%3B%20Help!!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1635849%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EFiles%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1636509%22%20slang%3D%22en-US%22%3ERe%3A%20Trouble%20editing%20shared%20documents%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1636509%22%20slang%3D%22en-US%22%3E%3CP%3EHi%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F782324%22%20target%3D%22_blank%22%3E%40RacheleRP%3C%2FA%3E%26nbsp%3B%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EOneDrive%20is%20technically%20a%20SharePoint%20library%20and%20a%20Teams%20Team%20is%20backed%20by%20a%20SharePoint%20site%20but%20that%20is%20a%20story%20for%20another%20day.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EBack%20to%20the%20task%20at%20hand.%20Could%20you%20walk%20me%20through%20from%20start%20to%20finish%20please%20as%20I%20can%20see%20the%20good%20old%20upload%20centre%20at%20play%20here%2C%20not%20seen%20that%20in%20a%20while.%20That%20will%20be%20the%20Orange%20icon%20in%20the%20system%20tray.%20Might%20be%20worth%20seeing%20that%20it%20doesn't%20have%20anything%20holding%20it%20up%20as%20that%20can%20cause%20issues.%20(Right%20click%20the%20icon%20to%20check)%20Also%20what%20version%20of%20Office%20is%20being%20used%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHowever%20like%20you%20say%20this%20doesn't%20sound%20like%20normal%20practice.%20So%20are%20we%20talking%20about%20editing%20a%20file%2C%20already%20stored%20in%20a%20Team%2FSharePoint%20and%20just%20expecting%20it%20to%20save%20a%20new%20version.%20Or%20is%20this%20a%20file%20that%20is%20new%20and%20being%20saved%20back%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESorry%20to%20ask%20so%20many%20question%20but%20if%20you%20could%20walk%20me%20through%20how%20the%20file%20is%20first%20opened%20etc.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHenry%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
New Contributor

I used Teams at my last job and we had no issues sharing documents that were uploaded into a team as long as the user did their editing after clicking "Open in Desktop App".  At my new place, we are having all kinds of issues with saving documents and getting errors about saving.  We use SharePoint here where at my old place everything was stored on OneDrive.  Some of the errors are related to saving a new copy, which should never have to be done.  I've attached an error about the document "...not been uploaded to the server.  Do you want to close this file?"  It's on AutoSave.  Is this just a time lag issue?  Help!!

5 Replies
Highlighted

Hi @RacheleRP ,

 

OneDrive is technically a SharePoint library and a Teams Team is backed by a SharePoint site but that is a story for another day.

 

Back to the task at hand. Could you walk me through from start to finish please as I can see the good old upload centre at play here, not seen that in a while. That will be the Orange icon in the system tray. Might be worth seeing that it doesn't have anything holding it up as that can cause issues. (Right click the icon to check) Also what version of Office is being used?

 

However like you say this doesn't sound like normal practice. So are we talking about editing a file, already stored in a Team/SharePoint and just expecting it to save a new version. Or is this a file that is new and being saved back?

 

Sorry to ask so many question but if you could walk me through how the file is first opened etc.

 

Thanks

 

Henry

Highlighted

@henryarphillips365 

Henry,

 

Thank you for touching base so quickly.  I hope you had a nice holiday weekend.  It seems we had multiple issues.  One was that some of our team was linking graphs from a private document to the shared Excel document.  It seems Teams doesn't like Excel links to external data.  You'd think Microsoft would fix that.  Anyway, another issue has to do with the error I attached to my original request for help.  We also had team members who would always get an error that told them they had to save a copy.  What I don't know is if our team is still having issues.  I should have more information late this afternoon as our team has a meeting to go over the shared document every Wednesday.  

 

Highlighted

@henryarphillips365 

 

Well....about half of the team had no problems.  I was able to duplicate one of the issues so I'll describe.  The team member opened the shared document and the clicked "Open in Desktop App" as directed.  She did her editing (which is really just coping a worksheet into the Master) and then tried to close the document.  She got the error below that told her to Discard Changes or Save a Copy.  I DONT want the team to save copies, that defeats the whole purpose of using Teams.  She emailed a copy of her changes and I tried to copy the sheet and experienced the same error.  Rather than save a copy or discard I just hit the "X" and closed the doc.  Changes were, of course, not saved.  I did the entire exercise a second time, just for kicks and giggles, and low and behold, no error.  It doesn't make any darn sense.  The team member said she tried a few times with no luck.  I'm supposed to talk to another team member that had issues tomorrow morning.  

 

We also had an issue with the "driver" of the meeting, my boss, being able to see all the changes.  He opened the document and shared his screen in our Zoom meeting.  The changes on one of the sheets weren't there, but when I opened it (at the same time) they were.  He closed and reopened and they still weren't there.  WHY is Teams being so flaky?  

Teams Errors Save.jpg

Highlighted

Hi @RacheleRP ,

 

It is hard to say and I wouldn't say this is a common place issue as what you are trying to do is basic.

 

We also have to remember that Teams is the facilitator but really in terms of problem areas we are looking at Office and SharePoint Online.

 

Out of interest is this issue only seen with this one Excel doc or many others? Also just to ensure it is saved as xlsx and not say xls?

What version of Office do you have? As I am still conscious that I am sure you mentioned something about the upload centre? As you will want to ensure this is in a happy state.

henryarphillips365_0-1599727093750.png

 

 

As looking at your screenshot the issue is that the upload that would have saved a new version failed and therefore it presented the option to save a copy as a backup.

For the office version if you click on File with Excel or Word etc. open and click on Account towards the bottom left for me you should see something like: 

henryarphillips365_1-1599727219621.png

 

 

Also on the same page do you see user information, is the office app signed in as the user that has permissions to the Team/SharePoint? As I have seen instances where Office that is not licensed by the signed in user by way of an M365 account and that can cause access issues.

 

Thanks

 

Henry

 

 

Highlighted

Morning @henryarphillips365 

 

Thanks for the input.  As far as these issues being with one doc or many, we've only just started sharing on Teams and this is the first document.  So I can't really say it's one or many.  Originally the document was saved as .xls but I fixed that early.  The master is .xlsx for sure but I don't know if the documents the team members are copying their data from are .xls or .xlsx.  Do you think that matters?  Reminder, they copy their updated tab from their document into the master.  

 

I believe that we are all on Office 365.  The office version on the master document is the same as yours with the exception that yours says "(Preview)".  

 

RacheleRP_0-1599738304456.png

 

I can't imagine that someone other than the person with permission to the Team is updating the document.  I don't know if anyone has M365 but I can check with IT.  

 

I have a conversation with another team member this morning who had issues yesterday but I don't imagine they will be different issues than what we are already running into.  Fingers crossed.  

 

Thanks!  Have a great day.  

Rachele