Teams windows app and Teams web app issue

Not applicable

Having an issue with MS Teams Windows app not updating the last modified time in the "modified" column. When I make a change to a word doc or an excel file in Teams, the modified time often wont change. Meaning it will say the last update was a minute ago (when in reality it was 5 hours ago). If I go into the web app it shows the correct time (last updated 5 hours ago). I share these teams files and folders with other people so its not showing the last updates. I have to go into the web app to see updated time. Anyone know how to solve this? I've tried logging out but that helped for a minute and then it goes back to not showing the correct modified time.


edit: can also see the new modified time in Sharepoint. So both web app and Sharepoint are correct, but Windows app is not updating.


I'm running Windows 10 Enterprise (OS build 19044.1766).

1 Reply

Just an update. I updated to Windows 11 and the Windows Teams app still doesn't update the last modified date