Teams video not working

Occasional Contributor

There is an online lecture that always gets the max. capacity of 250 which sometimes allows me into the meeting room even when the capacity exceeds. But, the problem is that even when i get in early whenever the professor starts to share his screen i don't manage to see what he is sharing and sometimes i can't also see the camera showing him also.

Any idea what the problem could be.

15 Replies



Do you know if there is any other student with the same problem? So that we are sure that the professor really sharing something.


Are you using the desktop client ( for Teams or the Web client ( Test both of them and see if that helps. It could also be bandwidth related, Teams will prioritise audio over video and sharing. So try another connection if possible.


Also if there is over 250 participants in that lecture you should recommend your school using Live Events instead, that is also using Teams but allows over 10000 viewers.

@Linus Cansby It's not only me but with like 2-5 more. The thing is that it used to happen but gets solved when i exit an rejoin the meeting. And yes he is sharing the document. I am using the desktop one and will try later the web one. We did ask the university but they just ignored us since the lecture gets recorded. But recently also in the same course the recordings only show the audio it is not showing the video.

I am using Teams on my cell phone (oneplus 7t pro mclaren on the T Mobile network). For several months, Teams was working perfectly. Now, I am having the same issue. I can hear audio and share my video; however, I can no longer view anyone's shared screen or video. When others share their video, Teams either shows their video for a fraction of second and then freezes on a still image or shows a completely gray screen. When people share their screen, I see a completely gray image. In terms of bandwidth, I am using a 5G connection and am able to seamlessly use similar features (ie: view others' video and shared screen) on other platforms (ie: WhatsApp, Bluejeans, Hangouts, and Zoom). Please help me with trouble shooting this issue.

@BradleyNRL I am also having this problem on my mac. Worked perfectly until about 10 days OK. Now I cannot get incoming vide or sharing. Starts fine and cuts out 20 sec or so into a call.

@ChrisW603 I also have this problem on my Mac. It used work fine, but since last month I have been seeing this issue sporadically.

@Linus Cansby  Same issue at my workplace too. It's all happening for last couple of weeks. 

Same at my workplace. Tried two meetings today with just two participants and they were hopeless and not usable. We swapped over to zoom and it was perfect.

It's so bad nobody in our organisation uses it.

@ChrisW603 One of my users is having the exact same issue on their laptop using an external camera.  She tried onboard camera as well and Teams still did not work.  Other video conferencing software such as Zoom works fine.  We uninstalled the software and re-installed, and it still did not work.  Pretty sure it was one of Microsoft's famous updates that is causing this issue.

I’m currently using the Microsoft teams app on phone to attend lectures but I’m unable to see the video the staff is presenting . I have tried everything except deleting and reinstalling the app
Please help
We have the same issue; video works with 2 people joined but as soon as a 3rd person joins, we lose the video. We tested the bandwidth and it's not the issue and have updated Teams and uninstalled and reinstalled. Anyone have a solution yet?
I am experiencing the same issue. Is there a fix yet?

We are having the same issue - incoming video cuts to host of the meeting once more than 2 participants- All the other participants can see each other and host.


This is very frustrating.

Hi @AhmedAfifi 


We had similar issue and i believe this has to do with QoS implementation. Try QoS as mentioned in below article or pass this to your professor as their environment has to do it.:


Implement Quality of Service in Microsoft Teams - Microsoft Teams | Microsoft Docs

After causing a lot of faff I found a simple resolution, by enabling the [ Disable Hardware Acceleration ] from the Setting> General on Teams done the trick

@Linus Cansby I am having similar problem when using web app. And desktop app is failing to download but let me try again