Teams video crashes the internet connection when connected via ethernet cable

Copper Contributor

I have a strange issue which I can not resolve.


When making video calls through my wireless internet connection everything is fine however when I make a video call through the ethernet connection it crashes every time without fail.  I have tried 4 different ethernet cables priced from £10 to £50 so its definitely not the cable and I just got my Sky router changed as I hoped that was the culprit however the same issue has arisen.


I need to use the ethernet connection as its a better connection to work remotely off the office VPN.


It is clearly a Teams issue as all other video calling software works fine, its just Teams that doesn't.


Any suggestions apart from stop using Teams?

8 Replies



That is an odd one. You'd expect it to be the other way around.  First thing I would say is ensure Windows Updates are all up to date and applied?

Yes its very strange, I have been living with it for about 6 months its never worked, everything is fully up to date@PeterRising 

@GToner  Do you have any other device that you can try with the ethernet connection to check if the same thing happens?

I have now resolved this issue. the problem was that my ethernet cable was connected into a USB C adapter which housed other connections such as a second monitor, keyboard etc, and Teams for some reason crashed when using video through this connection. I now have a single ethernet adapter that connects into my USB A drive into my surface laptop and no longer have any issues. works like a dream!
I tried this method and it solved it for me as well!
Texto de origen
This is absolutly annoying, i have the same problem but don't have the option to use an etheret via USB A.
Can someone give a posible solution to this issue or more information about it o directly how to solve it?
Thanks in advance.

@dannysateler I have the same problem with my laptop. It uses a combined USB-C adapter. My broadband is from Sky.

Using the combined USB-C adapter in my laptop, Teams will crash the newer Sky SR203 router BUT work perfectly with the older SR102 router.

It seems to be a combined router & adapter problem for some reason. The combination of both causes the problem.

I have the exact same problem. Does this have a fix?