Teams tries to connect to network drives during start up - and ends up starting really slow

%3CLINGO-SUB%20id%3D%22lingo-sub-2446454%22%20slang%3D%22en-US%22%3ETeams%20tries%20to%20connect%20to%20network%20drives%20during%20start%20up%20-%20and%20ends%20up%20starting%20really%20slow%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2446454%22%20slang%3D%22en-US%22%3E%3CP%3EI%20run%20Microsoft%20Teams%20on%20MacOS%20and%20noticed%20the%20following%2C%20to%20much%20frustration%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20a%20NAS%20on%20my%20home%20office%20network%2C%20which%20is%20not%20always%20connected.%20When%20Teams%20starts%20up%2C%20and%20the%20NAS%20is%20not%20connected%20(also%20when%20I'm%20travelling)%20it%20tries%20(without%20notification)%20to%20connect%20to%20this%20NAS%2C%20resulting%20in%20a%20startup%20time%20of%20up%20to%205%20minutes%2C%20and%203-6%20messages%20popping%20up%20that%20it%20cannot%20connect%20to%20the%20NAS.%3C%2FP%3E%3CP%3EIt%20is%20not%20only%20frustrating%2C%20but%20also%20unnecessary%20-%20why%20would%20Teams%20need%20anything%20from%20a%20network%20storage%20location%20during%20startup%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAnyone%20who%20recognises%20this%20and%20knows%20how%20to%20get%20rid%20of%20it%3F%20I%20run%20on%20MacOS%2C%20so%20no%20registry%20hack%20solutions%20please%20%3B)%3C%2Fimg%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2446454%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EMicrosoft%20Teams%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2450413%22%20slang%3D%22en-US%22%3ERe%3A%20Teams%20tries%20to%20connect%20to%20network%20drives%20during%20start%20up%20-%20and%20ends%20up%20starting%20really%20slow%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2450413%22%20slang%3D%22en-US%22%3EDo%20you%20have%20some%20print%20screens%3F%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2450974%22%20slang%3D%22en-US%22%3ERe%3A%20Teams%20tries%20to%20connect%20to%20network%20drives%20during%20start%20up%20-%20and%20ends%20up%20starting%20really%20slow%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2450974%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F72542%22%20target%3D%22_blank%22%3E%40adam%20deltinger%3C%2FA%3E%26nbsp%3Bnot%20right%20now%2C%20but%20all%20it%20says%20is%20Unable%20to%20connect%20to%20delphinosvr%2C%20followed%20by%20an%20OK%20button.%20Screenshots%20won%E2%80%99t%20show%20more%20than%20that%2C%20and%20in%20fairness%20I%20think%20it%E2%80%99s%20a%20clear%20design%2Fimplementation%20flaw.%20Teams%20had%20no%20business%20on%20that%20network%20location%2C%20certainly%20not%20during%20startup%20and%20login.%3C%2FP%3E%3C%2FLINGO-BODY%3E
New Contributor

I run Microsoft Teams on MacOS and noticed the following, to much frustration:

 

I have a NAS on my home office network, which is not always connected. When Teams starts up, and the NAS is not connected (also when I'm travelling) it tries (without notification) to connect to this NAS, resulting in a startup time of up to 5 minutes, and 3-6 messages popping up that it cannot connect to the NAS.

It is not only frustrating, but also unnecessary - why would Teams need anything from a network storage location during startup?

 

Anyone who recognises this and knows how to get rid of it? I run on MacOS, so no registry hack solutions please ;)

7 Replies

@adam deltinger not right now, but all it says is Unable to connect to delphinosvr, followed by an OK button. Screenshots won’t show more than that, and in fairness I think it’s a clear design/implementation flaw. Teams had no business on that network location, certainly not during startup and login.

It shouldn’t afaik! Have you somehow installed the Teams profile on the NAS?
You can check the logs and see what they say or post them:

https://docs.microsoft.com/en-us/microsoftteams/log-files

Adam

@adam deltinger thanks for that tip. 

 

Here's what I did tonight: 

 

1. logout of Teams

2. shutdown NAS

3. restart Teams 

 

Before getting to the login stage the attached window had already popped up 5 times. The list with accounts to select from (I have 3 Teams accounts) showed up immediately after the 5th one.

 

4. Login

 

That was flawless as always.

 

6. Collect log files as you suggested

 

I found no reference to my NAS in any of the log files

 

7. Did a grep for the NAS on all files in ~/Library/Application Support/Microsoft/Teams

 

No reference foud at all

 

I'm completely puzzled - the startup time is 3-4 minutes due to this, whenever I am not on my home-network.

 

Angelo

 

@DelphinoCons 

 

Have the same issue at startup, as well as at shutdown.  In fact, Teams locks up and becomes non-responsive trying shutdown if the network drive is not available.  Creepy behavior. 

I've been having the same issue for several months now. Makes me very concerned about privacy issues.
Same here. And have several colleagues cursing teams because of this behavior. Looks like the Microsoft guys either have always perfect network connection to their network drives, don't use home office at all or don't have any network drives in use. Otherwise they would have fixed that in a second.