Teams - Tenant drop-down missing on the account I was invited with

New Contributor



Invited as guest -> Accepted invite -> Can't see tenant dropdown on Teams on that account.

However, the invite and drop-down is showing when I log in with a different account (explained below)


I know there are quite a few topics on this issue, but my case seems a little weird - 3 tenants involved

  • I work in company Alpha (

  • Company Bravo invited my Alpha user to their (teams) organization

    • At this point I should get a dropdown menu in my Alpha Teams to switch tenants - but I don't. (have updated/cleared cache etc)
  • I have a user in company Charlie that is native to that organization (not invited)

    • In this company (Charlie) I can see the dropdown menu with access to Company Bravo tenant
    • These have no relation with eachother whatsoever - so this doesn't make any sense?
    • Switching tenant here naturally says does not exist in company Charlie.


Company Alpha - No dropdown. Access to Company Bravo should be here

Company Charlie - Dropdown with access to Company Bravo - These 2 have no relation with eachother


Did my invitation get mixed in with Company Charlie when I accepted the invite somehow?

When I clicked the accept invitation link in my e-mail I was:

  • Logged into company Alpha on the Teams Desktop Application
  • Logged into company Charlie on a web browser incognito mode

So after writing this down I'm starting to suspect the invitation link lached onto the web browser login and messed it up.. Obviously my fault if that happened.

I don't quite sure understand how this has happened when it should be associated by email and not current login.


Can it be fixed with a re-invite?

4 Replies
best response confirmed by adam deltinger (MVP)
Hi @nikkle

You could well be correct here

Solution should be

1.) As user in Charlie tenant leave organisation Bravo

2.) Have tenant Bravo check their Azure AD and ensure you are not there - in either you tenant Charlie or tenant Alpha address. If so, delete it and then remove it out of the recycle bin

3.) Wait for some propagation time - let's say 24 hours to be sure (that's the max prop time usually in Azure AD

4.) Get tenant Bravo to reinvite you as user in tenant A on that address and ensure you are logged in in all clients as user in tenant A

Hope that answers your question

Best, Chris

Best, Chris

@Christopher Hoard Hello, thanks for the reply!


First things first, I managed to fix it. I tried following the steps provided, but unfortunately I don't have the "Organizations" tab on my Charlie account because organization Bravo isn't really there I think, it's just bugged out. The steps you provided will surely help someone else facing similar problems though.


How I fixed it:

I got someone with access to Tenant B to give me a link that goes directly to the teams channel I was invited to. When I pasted this into the browser it finally asked me to setup MFA for that tenant and thereafter the tenant access menu appeared. Simple enough hehe


I still have the wrong tenant dropdown in Tenant Charlie though, but I'll just leave it there.. 


@nikkle This is a BUG.

I accepted an invite from my kid's school (yes, now using Teams for real life remote learning).

After adding email addresses, removing them, removing Teams on Mac...

I realized I can ONLY switch from one direction to another:

>> I can only show it in a browser, since I've lost the ability to switch in the app



Note the org switch is missing here:



Hi Nikkle, I am also experiencing this issue and these are steps to replicate:
1. Invite guest from another tenant
2. Guest accepts invitation
3. Guest has 2+ tenants in the Tenant dropdown of Teams (top right)
4. Guest does not see the new tenant in drop-down.

A temporary fix for this is to tell the guest to toggle back and forth between the available tenants in the list, and THEN the new tenant will appear in the list.

5. Odd issue: Guest switches back to their original tenant, and then my tenant disappears again?

Easy fix: Always asks the user to quit and re-open Teams using "Quit" from the notification tray.

Permanent fix, but not a good fix:
1. Close teams
2. Start>run> %appdata%/Microsoft/Teams > Clear all data in this folder
3. Re-open teams, and then my tenant now appears.

Could Microsoft fix this without requiring intervention from IT Manager?
It is really difficult to tell clients to clear their Teams cache or tell every new guest to quit-reopen teams when I invite them. Thanks!