SOLVED

Teams says "This app cannot be found", but Power BI is installed

Iron Contributor

I've just started playing with Power BI and want to send a report via Teams to see how this feature works. Power BI for Teams is a free feature, the Power BI app is installed in the recipient's Teams , permissions are set, from my Power BI account I select "Chat in Teams", 

JefferyHallett_0-1689376341876.png

a message is sent to the recipient saying they have a Power BI, the recipient gets the message, but when they click on Open they get the simple message "This app cannot be found."

JefferyHallett_2-1689376565715.png

Any ideas?

 

 

3 Replies
best response confirmed by Jeffery Hallett (Iron Contributor)
Solution

Hi @Jeffery Hallett,

 

Please take a look at these steps, and try to resolve your issue by using them:

1. Confirm Power BI installation: Make sure that the recipient has the Power BI app installed in their Teams application. Sometimes, app installations can be user-specific or require additional steps.

Add the Power BI app to Microsoft Teams - Power BI | Microsoft Learn

2. Verify permissions: Check that the recipient has the appropriate permissions to access and view the Power BI report. Review both the Power BI settings and the Teams settings to ensure the recipient has the necessary access rights.

3. Clear Teams cache (recipient side)

Clear Teams cache - Microsoft Teams | Microsoft Learn

4. Update Teams app: Ensure that the recipient has the latest version of the Teams app installed. Outdated versions may have compatibility issues with certain apps, including Power BI. Updating to the latest version can help resolve such issues.

Update Microsoft Teams - Microsoft Support

5. Try alternative sharing methods: If the problem persists, consider alternative ways to share the Power BI report. You can export the report as a PDF or image file and directly share it with the recipient through Teams' chat or file sharing features.




Please click Mark as Best Response & Like if my post helped you to solve your issue.
This will help others to find the correct solution easily. It also closes the item.

If the post was useful in other ways, please consider giving it Like.


Kindest regards,


Leon Pavesic

Hi, Leon.
Thanks for the suggestions.
I will test all these first thing tomorrow and let you know.
Jeff
I checked all the suggestions but am still getting the app not found message. I'll try contacting Microsoft.
1 best response

Accepted Solutions
best response confirmed by Jeffery Hallett (Iron Contributor)
Solution

Hi @Jeffery Hallett,

 

Please take a look at these steps, and try to resolve your issue by using them:

1. Confirm Power BI installation: Make sure that the recipient has the Power BI app installed in their Teams application. Sometimes, app installations can be user-specific or require additional steps.

Add the Power BI app to Microsoft Teams - Power BI | Microsoft Learn

2. Verify permissions: Check that the recipient has the appropriate permissions to access and view the Power BI report. Review both the Power BI settings and the Teams settings to ensure the recipient has the necessary access rights.

3. Clear Teams cache (recipient side)

Clear Teams cache - Microsoft Teams | Microsoft Learn

4. Update Teams app: Ensure that the recipient has the latest version of the Teams app installed. Outdated versions may have compatibility issues with certain apps, including Power BI. Updating to the latest version can help resolve such issues.

Update Microsoft Teams - Microsoft Support

5. Try alternative sharing methods: If the problem persists, consider alternative ways to share the Power BI report. You can export the report as a PDF or image file and directly share it with the recipient through Teams' chat or file sharing features.




Please click Mark as Best Response & Like if my post helped you to solve your issue.
This will help others to find the correct solution easily. It also closes the item.

If the post was useful in other ways, please consider giving it Like.


Kindest regards,


Leon Pavesic

View solution in original post