Teams Room System (formerly SRSv2) does not recognize externally hosted Teams meeting

Copper Contributor

Hi All,


At times, we receive Teams meeting invites from people outside of our organization and we would like use our MS Teams Room System (formerly Logitech SmartDock Skype Room System v2) to join the meeting. 


What we have been doing is we forward the Teams meeting invite sent by the external organization to the room resource, manually accept the invite from the room resource's mailbox, and the MS Teams Room System recognize the invite as a Teams meeting (the Teams Room UI shows a "Join" button and an MS Teams logo instead of  "..." button ). All good so far. 


Going forward, I want the room resource to process those forwarded external Teams meeting invite automatically which has been resolved by executing the following powershell Cmdlet : 

Set-CalendarProcessing -Identity "Room 221" -ProcessExternalMeetingMessages $true

However, now every time we forward an externally hosted Teams meeting invite to the room resource, the Teams Room System does not recognize the invite as a Teams meeting (the Teams Room UI shows a "..." button instead of a join button). I've done the steps outlined in this article ( as well but it's still not working. 


Has anyone else experienced this issue or know how to fix this ? 


Update: We have had some occurrences where the Teams Room System does not recognize the external invite as a Teams meeting when we accepted the invite manually within the room resources mailbox.




28 Replies



H Brian,

I'm a couple of steps behind you and still trying to add our meeting room to an externally hosted meeting. I've tried forwarding on the invite to our meeting room with the Teams Room System, but nothing is appearing in it's calendar. The room does not seem to have a mailbox to check - is that normal? The room has a Meeting Room license but no Exchange Online license.


Do you have any pointers?




@bchristian915  i've just tested this and confirmed it works for me. My setup is an Intel NUC with MTR loaded and a USB-connected touchscreen (Logitech Tap system).

I've confirmed that when enabling the processexternalmeetingmessages flag, external guests can either invite the room by its email address, or internal staff can forward an externally-created meeting request on to the room. It will be automatically accepted, show on the MTR Display, and be recognized as a teams meeting with a join link.

Has this come right at your end or are you still seeing issues? Have you tried to reset the MTR app back to defaults and configure it again with the room account?

@Peter Nicholson Have you tried logging into as the meeting room in a web browser and does it show the inbox? The account that you are assigning the license to does have an Exchange Online mailbox, which doesnt require a license as long as the type is resource.

@UnearthSo far I've got no more issues regarding this. Everything's working as expected all of a sudden. 

@bchristian915 have you figured this out? We have the same issue but it seems to only affect certain external meeting, not all. I am guessing this could have with the external company's teams settings maby? I do not know wich one, and was hoping you might figured something out?


Hi Brian,


I'm having the same issue. I only see the "..." instead of the join button. I've also enable the external processing capabilities without any luck. Did the issue came back or once it starting working normally everything works since?

thank you,


@MADrouin Has anyone had any luck getting this to work?


Any Rooms that are directly invited are showing the 'JOIN' button as expected, however if we forward a Teams meeting request to the rooms they refuse to recognise them as Teams meeting and just show the 3 dots.


We've configured the settings as per everyone's recommendations (don't delete subject or comments, allow external), but its made no difference. 


This is quite frustrating so any thoughts would be much appreciated! :)


@Mark Taylor Hi Mark,

we opened a ticket last Friday. I'm hoping that they can help us with the issue.


We have also found that if you forward the meeting internally, the join button appears. We  can reproduce the issue only when the meeting if forwarded to the room when the meeting is created from an external contact.



@MADrouin Hi Marc-André


Thank you very much for the update, I was debating doing the same thing myself.

I will hold fire for a little while to see if you get an answer.

If you dont then perhaps we will try a case as well.


Many thanks for your help!



@Mark Taylor  Hi Mark, just to let you know Microsoft is escalading the issue to level 2 support. I will let you know our findings...

@MADrouin Hey... thank you very much for the update. Much appreciated! Fingers crossed.

@MADrouin just joining the conversation here, with the same issue on a Logitech TAP system.

Internal invites can be forwarded, but external invites that are forwarded gives the 3 dots...


Looking forward to hear the finding from lvl2!

@Dan Hansen i think we solved this. We removed "internal safelinks" and the meetings startet showing as teams meetings again!


Found it in exchange admin center - Advanced treaths.

@Thomas_Baklund Hi


I can see why that may impact it, but we have setting turned off, and these are external invites being forwarded internally, so the external email would have already been subject to the safe link rewrite before it is forwarded?


Is there a workaround here I am missing?







@Mark Taylor Not in our case, incoming links looks fine, but when we sent around they where turned into safelinks and when we kept the cursor on it the link was "eu.safelinke...." When we turned it of, the link switched to "" We did a lot in the process so it might be combined with something else, but this looked like the fix.

@Thomas_Baklund Hi


It feels like there could be something in this, just not quite sure what! :)


So basically in Exchange you've configured a Safe Links policy for your domains that have the 'Apply safe links to email messages within the organsation' NOT ticked?


If so that's what we have (and have from the start in our case).




@Mark Taylor  We had the same issue - this command solved the problem for us:


Set-CalendarProcessing -DeleteComments $false

@MariusKristiansen2020 We used this also combined with the safelinks. Maby both is needed if safelinks is active.

@Dan Hansen Hi all, Microsoft ended up running a fix in the background in regards to safelinks. We couldn't get a straight answer to what they actually did, but I would suggest to open a ticket with Microsoft and reference the same issue that we had.


I would also reference our ticket # 19036011, hoping they might give someone else a complete answer.


I believe the main challenge on our side was basically just trying to understand their explanation.