Teams - renamed user still displayed with old name

%3CLINGO-SUB%20id%3D%22lingo-sub-1621302%22%20slang%3D%22en-US%22%3ETeams%20-%20renamed%20user%20still%20displayed%20with%20old%20name%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1621302%22%20slang%3D%22en-US%22%3E%3CP%3EI%20renamed%20user%20in%20365%20admin%20centre%2C%20the%20new%20name%20is%20correctly%20displayed%20in%20Teams%20admin%20centre%20but%20-%20in%20the%20Teams%2C%20the%20old%20name%20is%20still%20used%20everywhere%20even%20for%20new%20posts%2C%20when%20adding%20to%20new%20team%20etc.%20Any%20help%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1621302%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ERename%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1621322%22%20slang%3D%22en-US%22%3ERe%3A%20Teams%20-%20renamed%20user%20still%20displayed%20with%20old%20name%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1621322%22%20slang%3D%22en-US%22%3EDid%20you%20change%20display%20name%20too%3F%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1621555%22%20slang%3D%22en-US%22%3ERe%3A%20Teams%20-%20renamed%20user%20still%20displayed%20with%20old%20name%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1621555%22%20slang%3D%22en-US%22%3EYes%20I%20did...%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1919030%22%20slang%3D%22en-US%22%3ERe%3A%20Teams%20-%20renamed%20user%20still%20displayed%20with%20old%20name%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1919030%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F775971%22%20target%3D%22_blank%22%3E%40Tom733%3C%2FA%3E%26nbsp%3BI'm%20having%20the%20same%20issue%20with%20one%20account.%20Did%20you%20ever%20find%20a%20resolution%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Contributor

I renamed user in 365 admin centre, the new name is correctly displayed in Teams admin centre but - in the Teams, the old name is still used everywhere even for new posts, when adding to new team etc. Any help?

3 Replies
Did you change display name too?

@Tom733 I'm having the same issue with one account. Did you ever find a resolution?